summaryrefslogtreecommitdiff
path: root/app-arch/lxqt-archiver
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /app-arch/lxqt-archiver
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'app-arch/lxqt-archiver')
-rw-r--r--app-arch/lxqt-archiver/Manifest2
-rw-r--r--app-arch/lxqt-archiver/lxqt-archiver-0.5.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/app-arch/lxqt-archiver/Manifest b/app-arch/lxqt-archiver/Manifest
index c95929789f6d..d7135b4fc0f5 100644
--- a/app-arch/lxqt-archiver/Manifest
+++ b/app-arch/lxqt-archiver/Manifest
@@ -1,3 +1,5 @@
DIST lxqt-archiver-0.4.0.tar.xz 167124 BLAKE2B 2d9295200c284e2dc0c2b538a92952dd0a11882211e5d1d5838141583b4a595b65c26a057e5c9733190182a5f78958e15d0e086356d75dd4e0c72d3510a34cfc SHA512 e1b323cd118af3726009e153c4f9766ec53b29fa0280530da16e2101d36ec45b55de0fe3d87c1386a4e5b3d88712fd209659b4ebb9344af689812600ae136ed6
+DIST lxqt-archiver-0.5.0.tar.xz 176312 BLAKE2B c7e843ba59e3c313fbd1b32f848fb3c988fe144886f64b284f49716a200866a8c22d68b00ece8f61b103d8ab55f4de6a2a86371637b56a842fb516520af29964 SHA512 01747499fece79010f359bfe5987dd0ef96daa92269659dc64543a78a4540ed7e5ff2e0b2ae6ab620c6be7244f4e350a18aa08657e7d84429fa20d0a264977c6
EBUILD lxqt-archiver-0.4.0.ebuild 1180 BLAKE2B e683fb27236235e2dce15e1d957a435be42a953585cd16b881766808e510e390b42b7b7a199d0929d4f51ed8b1de360e78e8e45537f38b5378152da4b2658f95 SHA512 0cef2d37e234144395e7569790be0a2b84b1b67568559da56769cb68dd8af92aa6220d3d6f961904a08ae573a78810f9e09a6e840b08bfbcdd9fb3a72327e3cd
+EBUILD lxqt-archiver-0.5.0.ebuild 1281 BLAKE2B e232c8fa691010f83b7c9e42ec0c5261ecca37eea7ee979eae0884707c1c65a141438b8e6adfc525b81fc404b16116259229ad434a5d57e63428587ace8282a6 SHA512 874b29dc79cca620d1933893bb5fb5f21e1d1f3696d22812d732c9a52987017b2ba6b9187de20ad097b680b864b4fa019ef3ddd5295fe430613907953bd18465
MISC metadata.xml 330 BLAKE2B 1f25c787f9b43ef0ef62206ca9ab67dfab8b95b2786fc84248541159507290229b291b9f83541adc196b58a9dcad7c0f3abd18c5c899a98978dc72403386896d SHA512 12f4638550e157da50134bf6c7cb480bd49661b9655900efdbb12a023c4bd4cd13018d7caa672096329691cf8556f89c9d13d6710463048329c8e3bd5f04f6ee
diff --git a/app-arch/lxqt-archiver/lxqt-archiver-0.5.0.ebuild b/app-arch/lxqt-archiver/lxqt-archiver-0.5.0.ebuild
new file mode 100644
index 000000000000..06092b0c39a0
--- /dev/null
+++ b/app-arch/lxqt-archiver/lxqt-archiver-0.5.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt GUI File Archiver"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.10.0
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ >=dev-qt/qtx11extras-5.15:5
+ >=x11-libs/libfm-qt-1:=
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ elog "Please note that this is only a graphical front-end, and additional"
+ elog "packages are needed to have support for specific file formats."
+ elog "For example, to be able to work with the 7-Zip format, the"
+ elog "'app-arch/p7zip' package may be used."
+ elog "For the full list of supported formats, see the 'README.md' file:"
+ elog "https://github.com/lxqt/lxqt-archiver/blob/master/README.md"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}