summaryrefslogtreecommitdiff
path: root/app-arch/lxqt-archiver
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /app-arch/lxqt-archiver
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'app-arch/lxqt-archiver')
-rw-r--r--app-arch/lxqt-archiver/Manifest3
-rw-r--r--app-arch/lxqt-archiver/lxqt-archiver-0.2.0.ebuild49
-rw-r--r--app-arch/lxqt-archiver/metadata.xml11
3 files changed, 63 insertions, 0 deletions
diff --git a/app-arch/lxqt-archiver/Manifest b/app-arch/lxqt-archiver/Manifest
new file mode 100644
index 000000000000..d804fa1364e5
--- /dev/null
+++ b/app-arch/lxqt-archiver/Manifest
@@ -0,0 +1,3 @@
+DIST lxqt-archiver-0.2.0.tar.xz 155912 BLAKE2B e5c92d5939d3e6d42a79804596e9acc67b007126b630cd9317df7d0d07bb8f3e27cf9ecf6e16eef3289d31ef3627b4fa870cdb5eb52a36489df1080b03509acd SHA512 478a04d0e6e4601dc342ae260c5db4178b01191cae263154dbe400b394e5cd4cb9cd8a6bab7e7c59af57d6bf20c47a5ad2663a85d0eab5f71fbaf584f7588fd7
+EBUILD lxqt-archiver-0.2.0.ebuild 1175 BLAKE2B c33ba638b93d35bdb74f5a4c6b0a7bb9b62991520576415d070c885a7649c82241a8e83e8d1755b556477ae3817e396666b00480db654a93d548e43cfebfbf0e SHA512 aabd95530d60416584382ceaa728989cec84af6751c7ce50312b93f5d379d0b23e3c5616828f00742511c9ffd6ba554cb07aefefd7f9305c705b222474f82898
+MISC metadata.xml 329 BLAKE2B a6082a9d0185aaa5f233d41d9de505901392c80159cbf4cf769e1a38008aaa06793e2283c974df743f2141488bdb2cc087e7990953b16b752092f31de7840c83 SHA512 42d4c3e67fbc3a84a79ed73710e8322f4a30ae6565e1aa2cbf122661e6864a8e102e67ab973942953fb2358754303b3f2d2963f3ebf15188bc23fd8ca31f5e60
diff --git a/app-arch/lxqt-archiver/lxqt-archiver-0.2.0.ebuild b/app-arch/lxqt-archiver/lxqt-archiver-0.2.0.ebuild
new file mode 100644
index 000000000000..dd4a15a89c32
--- /dev/null
+++ b/app-arch/lxqt-archiver/lxqt-archiver-0.2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt GUI File Archiver"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.7.0
+"
+DEPEND="
+ dev-libs/json-glib
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ >=x11-libs/libfm-qt-0.15.0
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog "Please note that this is only a graphical front-end, and additional"
+ elog "packages are needed to have support for specific file formats."
+ elog "For example, to be able to work with the 7-Zip format, the"
+ elog "'app-arch/p7zip' package may be used."
+ elog "For the full list of supported formats, see the 'README.md' file:"
+ elog "https://github.com/lxqt/lxqt-archiver/blob/master/README.md"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}
diff --git a/app-arch/lxqt-archiver/metadata.xml b/app-arch/lxqt-archiver/metadata.xml
new file mode 100644
index 000000000000..19d4de86f7b1
--- /dev/null
+++ b/app-arch/lxqt-archiver/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>lxqt@gentoo.org</email>
+ <name>LXQt</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lxqt/lxqt-archiver</remote-id>
+ </upstream>
+</pkgmetadata>