summaryrefslogtreecommitdiff
path: root/app-arch/lxqt-archiver
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-18 05:54:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-18 05:54:20 +0100
commit5a1fb66df455454109e1de61d38b48f509dc68b8 (patch)
tree0213f12db1b0138bffda43d11208c5d701967638 /app-arch/lxqt-archiver
parent3a8423ee2874c2fd96358b28af08d38d83e9bdc0 (diff)
gentoo auto-resync : 18:04:2023 - 05:54:20
Diffstat (limited to 'app-arch/lxqt-archiver')
-rw-r--r--app-arch/lxqt-archiver/Manifest2
-rw-r--r--app-arch/lxqt-archiver/lxqt-archiver-0.8.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/app-arch/lxqt-archiver/Manifest b/app-arch/lxqt-archiver/Manifest
index 1154cafa7f1d..88e9cac49641 100644
--- a/app-arch/lxqt-archiver/Manifest
+++ b/app-arch/lxqt-archiver/Manifest
@@ -1,3 +1,5 @@
DIST lxqt-archiver-0.7.0.tar.xz 181612 BLAKE2B 41ad378f20a9a8f3d7ccfc7406d480eecfad41c991781f503947b37ee26eec5de38b44ea318507dc209a2f2f6d68db65e0f9cdf61920a47fb2d02dd975960f86 SHA512 d86fd636b1b2345ead8c4dc0161311b3e361d274902c5b34b9aaccf1a0b9af46d329fbec0d2249197b8e1c837d6949f723451f67fdc9ca4c6b7f1c2cf59daeca
+DIST lxqt-archiver-0.8.0.tar.xz 181572 BLAKE2B 7bbd2b229cd8c546c86d742c13dac4bd00e24e85a146879290652a9ae41c9ced621738d06284fe285c81f2d5f8e43a5126b9bc61e286342cfb9d7fa935c330ee SHA512 70266581478e75505f708eccee4fd1680c1ff012dd4e99138d0c2d17fb8dfab24d9d5e5453d5d4a3f7a9b8437e8a980c3edf190f3e319400c46a655ba7db4898
EBUILD lxqt-archiver-0.7.0.ebuild 1288 BLAKE2B 3e2a54ca740079896c95fee12b66e61823936e821b2ef96721d09c6bb092545ac388202b8bbbbb48af5f485c515a1a89358a1e11b4fc9fc93cb5d0613d529cfd SHA512 d32e1d1f22a83f20b5e2ad80b1ef9bf0708be0353507d7c0795b43106999dbbd0a7e487f456ffc180eb68edad1e2ca2b2cc4255769237c12b0548db22caa5cb9
+EBUILD lxqt-archiver-0.8.0.ebuild 1290 BLAKE2B a4e6d292677a8d03b1a5122828116be9d10226689719e99cd4b6320ffafa173748037017a9b1d97b4600f72ee75958f3d86429b83e9b81caccebf42986ec9390 SHA512 2a47b201c4cb828499a48805f9a94f88ac9e9e9e554f7969846e2cb95809e32cbef9958adffc3623ee853cc6b499c1e68ea2a32e7655350809d5d90c4fb2ae58
MISC metadata.xml 330 BLAKE2B 1f25c787f9b43ef0ef62206ca9ab67dfab8b95b2786fc84248541159507290229b291b9f83541adc196b58a9dcad7c0f3abd18c5c899a98978dc72403386896d SHA512 12f4638550e157da50134bf6c7cb480bd49661b9655900efdbb12a023c4bd4cd13018d7caa672096329691cf8556f89c9d13d6710463048329c8e3bd5f04f6ee
diff --git a/app-arch/lxqt-archiver/lxqt-archiver-0.8.0.ebuild b/app-arch/lxqt-archiver/lxqt-archiver-0.8.0.ebuild
new file mode 100644
index 000000000000..d305b0ec042b
--- /dev/null
+++ b/app-arch/lxqt-archiver/lxqt-archiver-0.8.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt GUI File Archiver"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~loong ~riscv ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.13.0
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ >=dev-qt/qtx11extras-5.15:5
+ >=x11-libs/libfm-qt-1.3:=
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ elog "Please note that this is only a graphical front-end, and additional"
+ elog "packages are needed to have support for specific file formats."
+ elog "For example, to be able to work with the 7-Zip format, the"
+ elog "'app-arch/p7zip' package may be used."
+ elog "For the full list of supported formats, see the 'README.md' file:"
+ elog "https://github.com/lxqt/lxqt-archiver/blob/master/README.md"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}