summaryrefslogtreecommitdiff
path: root/app-arch/lxqt-archiver
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-arch/lxqt-archiver
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-arch/lxqt-archiver')
-rw-r--r--app-arch/lxqt-archiver/Manifest2
-rw-r--r--app-arch/lxqt-archiver/lxqt-archiver-0.4.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/app-arch/lxqt-archiver/Manifest b/app-arch/lxqt-archiver/Manifest
index 2aca87d55f50..4be94b6be81e 100644
--- a/app-arch/lxqt-archiver/Manifest
+++ b/app-arch/lxqt-archiver/Manifest
@@ -1,3 +1,5 @@
DIST lxqt-archiver-0.3.0.tar.xz 157492 BLAKE2B 05d9862c75cacf3b73670333a5b2dafb6abfcfd7433a1ebc3d27948122db875f892eb58a05221c880d1ac23530362ae4d9e7c6ebe0f06552b10bb903d51a6868 SHA512 840fae890611b081a1355ceb58ca65276784e6825822859ff2d6506190212268f1c67733dc94c65c9c5758f8d6a25c286c2b339356a50f29474b0c7ce2569d2c
+DIST lxqt-archiver-0.4.0.tar.xz 167124 BLAKE2B 2d9295200c284e2dc0c2b538a92952dd0a11882211e5d1d5838141583b4a595b65c26a057e5c9733190182a5f78958e15d0e086356d75dd4e0c72d3510a34cfc SHA512 e1b323cd118af3726009e153c4f9766ec53b29fa0280530da16e2101d36ec45b55de0fe3d87c1386a4e5b3d88712fd209659b4ebb9344af689812600ae136ed6
EBUILD lxqt-archiver-0.3.0.ebuild 1173 BLAKE2B ed90bcdc16bfe9a9401ef0ee07cbba79cf7c1bba6dd4f87be0a535442f96f63c69b534bb62d0a6767dd974d6ea92c7ad3f05ca8710b66e1f117ac477dbee1f28 SHA512 7396a031b3c47f978d67a01f2cef96cfd7bfd3375b8c409bf6af5dd22f438eb922379d4c70c000f8ac0f56bb7f2652c76598bd962a42911b7e3bdcea5a117385
+EBUILD lxqt-archiver-0.4.0.ebuild 1175 BLAKE2B 5235a42a1662743906235aa3a2c70b48ff11725208e377405467dd1c7cabef7d444082a48d967656e8144eacff672b2ea0c78aa23ccc5ebf261758f5c3cd4564 SHA512 bfacb98d217c22d0b805e21f66a50ce88694f0dc2973ece09728ebb38b00fda5516011771adc245fe9c036a8e3026db7c2854853eac2212e3556888ee215b4d1
MISC metadata.xml 329 BLAKE2B a6082a9d0185aaa5f233d41d9de505901392c80159cbf4cf769e1a38008aaa06793e2283c974df743f2141488bdb2cc087e7990953b16b752092f31de7840c83 SHA512 42d4c3e67fbc3a84a79ed73710e8322f4a30ae6565e1aa2cbf122661e6864a8e102e67ab973942953fb2358754303b3f2d2963f3ebf15188bc23fd8ca31f5e60
diff --git a/app-arch/lxqt-archiver/lxqt-archiver-0.4.0.ebuild b/app-arch/lxqt-archiver/lxqt-archiver-0.4.0.ebuild
new file mode 100644
index 000000000000..4bf9466ba805
--- /dev/null
+++ b/app-arch/lxqt-archiver/lxqt-archiver-0.4.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt GUI File Archiver"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.9.0
+"
+DEPEND="
+ dev-libs/json-glib
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ >=x11-libs/libfm-qt-0.17.0
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog "Please note that this is only a graphical front-end, and additional"
+ elog "packages are needed to have support for specific file formats."
+ elog "For example, to be able to work with the 7-Zip format, the"
+ elog "'app-arch/p7zip' package may be used."
+ elog "For the full list of supported formats, see the 'README.md' file:"
+ elog "https://github.com/lxqt/lxqt-archiver/blob/master/README.md"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}