summaryrefslogtreecommitdiff
path: root/app-arch/lbzip2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /app-arch/lbzip2
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'app-arch/lbzip2')
-rw-r--r--app-arch/lbzip2/Manifest3
-rw-r--r--app-arch/lbzip2/files/lbzip2-2.5_p20181227-fix-unaligned.patch33
-rw-r--r--app-arch/lbzip2/lbzip2-2.5_p20181227-r1.ebuild (renamed from app-arch/lbzip2/lbzip2-2.5_p20181227.ebuild)9
3 files changed, 36 insertions, 9 deletions
diff --git a/app-arch/lbzip2/Manifest b/app-arch/lbzip2/Manifest
index 4a1e7eaebd06..d9aa449f923a 100644
--- a/app-arch/lbzip2/Manifest
+++ b/app-arch/lbzip2/Manifest
@@ -1,4 +1,5 @@
AUX lbzip2-2.3-s_isreg.patch 500 BLAKE2B 7839d78d204c0b88ee68d728d1279dc2bc2e6222046cb28c60001c194513de7f3343dfb93d6db91bc4424fb639e2a1cbe428db1ff6753ec2c5b3c004a2b8f321 SHA512 3158763b364e8ba41b0fea03529c6e4a0c6f3d17e7d0ce796fc9a6f6bc7e70fa7db759dc205026818619e137fb6343cf21534014b64dbf07c1cdb3bc1059cc04
+AUX lbzip2-2.5_p20181227-fix-unaligned.patch 1061 BLAKE2B a8c11adbbf53806b09d9b0b6b724247a17e450eac6953a9d9852539ab6d50901d739b243a0d4c72cc46cd7bfaa609fd6829af659e0c6ed6987e6725c471ca201 SHA512 0ddd04a06d2cc763b454074aba588d2cb252e0ab8c83c37133deb5cef2c265261fc38f6b32f8aed5ddbbc8aafdcb29e96df1b61f2f2cfd2e1b93818efd69114e
DIST lbzip2-2.5_p20181227.tar.gz 704920 BLAKE2B e5da0091c0e4fb73724c5ea472d757d76356cffbf1fc679bf4ee05e25690b7712dceaf17f355383bfd4eb525c4aea04c2e5312592df5bb99159e000769bcee2e SHA512 53b29721a106d280927f2c18f33247645bb7fb3e67d835885d73e037910bf02e473f1210d848df41a387be30f829213d98ac9387b2a9201b94d12117809fbcf5
-EBUILD lbzip2-2.5_p20181227.ebuild 858 BLAKE2B f5878366f67bdb63ee5c4d68b840d88ba6518b28dc0120600eb83feff2c963e8fee4d1b676dd3e1879caf7e61fba4299b063b851fd9a93a8a222b39e1082374f SHA512 0f51309bff560d98a0597f7e89a38e8c1d91e19af3a7f626643d00daf82cce5b05336ede1bd2d5437eed00253dc4d8a6f6775533d35c149a0835f7fa6e67528a
+EBUILD lbzip2-2.5_p20181227-r1.ebuild 837 BLAKE2B b05e6ea81314e8de6bea2464d2f90e93cf7b5d7b1da4406c06c45dcbdfcd53826727b59e89112ddc7ce7bb301356476ba91bf808ed53f5eed579ec5af956a0bf SHA512 e709c741968d528f8bc29d7fd020a7cbcaed86b3fde44da35e75bcde01ea3e8137e2e07030053862f72a06d1fbac2b18a5ec7d6c16ec0f92300012001d7c511e
MISC metadata.xml 534 BLAKE2B e09b3c70d05c66c9edffa19cc3e52be55ecade605c97da4e2f4f6c930dd1ebb548ddb873d31c50c995c0493fd3329978db661796c43ae029a5db79ac0e1974f0 SHA512 86b03f188fb14168b7d2d6956fa2df4941d94c95ff00e6bfd27451fe76b9318dac477bdb13b6443ae0186837335d66cf3e52ddc4ccc2f2979e60fe287f5ac2b2
diff --git a/app-arch/lbzip2/files/lbzip2-2.5_p20181227-fix-unaligned.patch b/app-arch/lbzip2/files/lbzip2-2.5_p20181227-fix-unaligned.patch
new file mode 100644
index 000000000000..c23d1afc4ca5
--- /dev/null
+++ b/app-arch/lbzip2/files/lbzip2-2.5_p20181227-fix-unaligned.patch
@@ -0,0 +1,33 @@
+https://github.com/kjn/lbzip2/pull/25
+
+From d570020ade2add591b97e61927545a005a2d4a6f Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Wed, 7 Aug 2019 11:47:04 -0700
+Subject: [PATCH] Align zero-length array to avoid unaligned accesses
+
+When make_tree() creates the left-justified base table (uint64_t *B)
+it does so with 64-bit stores:
+
+ B[k] = sofar;
+
+But B points to memory in the zero-length array "uint32_t tt[0]" at the
+end of struct decoder_state. Since tt's type is uint32_t, it is only
+aligned to a four byte boundary, and so the 64-bit store in make_tree()
+causes an unaligned trap on strict platforms like sparc.
+---
+ src/decode.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/decode.h b/src/decode.h
+index c9a9086..7c0ca3f 100644
+--- a/src/decode.h
++++ b/src/decode.h
+@@ -62,7 +62,7 @@ struct decoder_state {
+ uint8_t rle_char; /* current character */
+ uint8_t rle_prev; /* prevoius character */
+
+- uint32_t tt[0];
++ uint32_t tt[0] __attribute__((aligned (8)));
+ };
+
+
diff --git a/app-arch/lbzip2/lbzip2-2.5_p20181227.ebuild b/app-arch/lbzip2/lbzip2-2.5_p20181227-r1.ebuild
index 04fa9267b153..7dc8fcd267ff 100644
--- a/app-arch/lbzip2/lbzip2-2.5_p20181227.ebuild
+++ b/app-arch/lbzip2/lbzip2-2.5_p20181227-r1.ebuild
@@ -3,8 +3,6 @@
EAPI="7"
-inherit autotools
-
DESCRIPTION="Parallel bzip2 utility"
HOMEPAGE="https://github.com/kjn/lbzip2/"
SRC_URI="https://dev.gentoo.org/~whissi/dist/${PN}/${P}.tar.gz"
@@ -19,14 +17,9 @@ DEPEND=""
PATCHES=(
"${FILESDIR}"/${PN}-2.3-s_isreg.patch
+ "${FILESDIR}"/${P}-fix-unaligned.patch
)
-src_prepare() {
- default
-
- eautoreconf
-}
-
src_configure() {
local myeconfargs=(
--disable-silent-rules