summaryrefslogtreecommitdiff
path: root/app-arch/innoextract
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/innoextract
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/innoextract')
-rw-r--r--app-arch/innoextract/Manifest5
-rw-r--r--app-arch/innoextract/innoextract-1.6.ebuild35
-rw-r--r--app-arch/innoextract/innoextract-1.7.ebuild35
-rw-r--r--app-arch/innoextract/metadata.xml23
4 files changed, 98 insertions, 0 deletions
diff --git a/app-arch/innoextract/Manifest b/app-arch/innoextract/Manifest
new file mode 100644
index 000000000000..9bf87a24919e
--- /dev/null
+++ b/app-arch/innoextract/Manifest
@@ -0,0 +1,5 @@
+DIST innoextract-1.6.tar.gz 183380 BLAKE2B 581c0e28ececbabc8785f50472f312bc39c62d9174c1902645a961f06877c3e702ce0386aa611fe954c412997a1a69355e441cc33e243abd1828ff5e9d2ff8a2 SHA512 4c1b50a050d45e1a56d7236150a801cb85d15de8c80f5f1fd94750f3dd2392bdfb3f0e98c214e9504fe6132c7dce3a0dfbe0815ede438aa0f76a88380ceeef62
+DIST innoextract-1.7.tar.gz 195123 BLAKE2B 5dffb49da7ec3f8e48a70d0809e059179e84610dd50397b8ca472b9f5a96a5edd0cf36898f0e513b3f70685829e2b8edbd7d7932c9f1b47706c2929f596867e5 SHA512 5e92625a411a4351dd4639d4b63e8664519c6697122a0679c010412e94a1e5da95324c33be16211f91c2b25b8cea40fe4ba4da5e19c12d0c27a4916159465ca4
+EBUILD innoextract-1.6.ebuild 749 BLAKE2B 4b959791b3ed667c0d017f209fd7b0e65d088ab7ca880e9aedc802a3e9cbe44a7b232823578578d540eb23a937a8f2c19465c1036154800d5fb5ac97db5328b2 SHA512 991a70217b350cd81ca3b026425ede051213c804f4032b4ea1b0fe3ad05e9273d705f7d55b3154fe856de2ff56f529e148ce7931215b80fac8299976aa7e37bb
+EBUILD innoextract-1.7.ebuild 733 BLAKE2B f118d601e3de781b5d0a7c881057366776bd62630bdc456c44e55e1537b7a59da58f0e50af6e2097bf99ec65065043308255fe69139d473ae1ad9dcc49c24b4d SHA512 6bad9d6afa092d21a3bc29e89adc6f81046103501e90e0a45999aa9339c59e770c89bb500096b4204bc15f0c84d29d5dc7b985c79fe37b49c6fb73f764afb724
+MISC metadata.xml 928 BLAKE2B 032de64587c2ab814a132d09f624a86f6b87a5fb1c49a1385969fcce89a7f75975480c8b3b70889621a97bb26e1d37240d51ef5a9da868983ee2467fc5c18f92 SHA512 0fb9ebc491eec20dbeee81d92ae7616464717c88684170ea064726b42120d65ac74edfac474e2605c191d91901e952859199c17bc84af3657812671cb3fb9260
diff --git a/app-arch/innoextract/innoextract-1.6.ebuild b/app-arch/innoextract/innoextract-1.6.ebuild
new file mode 100644
index 000000000000..509f67a4b24c
--- /dev/null
+++ b/app-arch/innoextract/innoextract-1.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="A tool to unpack installers created by Inno Setup"
+HOMEPAGE="http://constexpr.org/innoextract/"
+SRC_URI="http://constexpr.org/innoextract/files/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug +iconv +lzma"
+
+RDEPEND="
+ dev-libs/boost:=
+ iconv? ( virtual/libiconv )
+ lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}"
+
+DOCS=( README.md CHANGELOG )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_use lzma LZMA)
+ $(cmake-utils_use debug DEBUG)
+ -DSET_OPTIMIZATION_FLAGS=OFF
+ -DSTRICT_USE=ON
+ -DWITH_CONV=$(usex iconv iconv builtin)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/app-arch/innoextract/innoextract-1.7.ebuild b/app-arch/innoextract/innoextract-1.7.ebuild
new file mode 100644
index 000000000000..53840c1a0cb4
--- /dev/null
+++ b/app-arch/innoextract/innoextract-1.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A tool to unpack installers created by Inno Setup"
+HOMEPAGE="http://constexpr.org/innoextract/"
+SRC_URI="http://constexpr.org/innoextract/files/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +iconv +lzma"
+
+RDEPEND="
+ dev-libs/boost:=
+ iconv? ( virtual/libiconv )
+ lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}"
+
+DOCS=( README.md CHANGELOG )
+
+src_configure() {
+ local mycmakeargs=(
+ -DDEBUG=$(usex debug)
+ -DSET_OPTIMIZATION_FLAGS=OFF
+ -DSTRICT_USE=ON
+ -DUSE_LZMA=$(usex lzma)
+ -DWITH_CONV=$(usex iconv iconv builtin)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/app-arch/innoextract/metadata.xml b/app-arch/innoextract/metadata.xml
new file mode 100644
index 000000000000..6d8f19bb3ddf
--- /dev/null
+++ b/app-arch/innoextract/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>daniel@constexpr.org</email>
+ <name>Daniel Scharrer</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="debug">Enable debug logging and the --debug command-line option</flag>
+ <flag name="lzma">Enable support for extracting lzma-compressed installers using <pkg>app-arch/xz-utils</pkg></flag>
+ </use>
+ <upstream>
+ <bugs-to>http://innoextract.constexpr.org/issues</bugs-to>
+ <changelog>http://constexpr.org/innoextract/changelog</changelog>
+ <doc lang="en">http://constexpr.org/innoextract/innoextract.1</doc>
+ <remote-id type="github">dscharrer/innoextract</remote-id>
+ <remote-id type="sourceforge">innoextract</remote-id>
+ </upstream>
+</pkgmetadata>