summaryrefslogtreecommitdiff
path: root/app-arch/funzix
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
commit76dfef0cec9170000357d2f354e412daf48941fc (patch)
tree56647120c0ee20ab3494475c86722034cd194b02 /app-arch/funzix
parentccf84bcd604130256d1377cd58f0a634ae6ee20f (diff)
gentoo resync : 30.12.2017
Diffstat (limited to 'app-arch/funzix')
-rw-r--r--app-arch/funzix/Manifest3
-rw-r--r--app-arch/funzix/files/funzix-1.0-fix-build-system.patch8
-rw-r--r--app-arch/funzix/funzix-1.0.ebuild14
3 files changed, 19 insertions, 6 deletions
diff --git a/app-arch/funzix/Manifest b/app-arch/funzix/Manifest
index 873ba1f65b10..4d69293a899c 100644
--- a/app-arch/funzix/Manifest
+++ b/app-arch/funzix/Manifest
@@ -1,3 +1,4 @@
+AUX funzix-1.0-fix-build-system.patch 113 BLAKE2B eb18a424d7f3e029f42c5102bf63f0b6e54dad213540832bdc4e4fd99fa83d52af891792248218608bd4f9883d9e2c76b3722303d54424e17b019a069235f071 SHA512 21d2f71a792ef23a501e691f514dbc4dd2c549542f6c1426bb3fbfc86d41cb97916295384a24075a6b10304a8c913b0379ae46ed42c0f87b4838dfa0b6111ddf
DIST funzix-1.0.tar.bz2 10792 BLAKE2B d7d6035e558cf6501ee84626f9720dab9d44eb87fb3cedc72721ff491c8535ecd913935b1c9618b85c471b3443a7386485b9bc01c7bd09e01752eda8261b9690 SHA512 30abf29571df7be4a1e92270cb3b4949244f5e50b088bc128c8ac63da88c244f0fe810b4d05b76c68220576b06a1c47e84a3f3339d82a4f0e35a841b29ec4c2c
-EBUILD funzix-1.0.ebuild 456 BLAKE2B 286240173835c7b262aac464890513e2a8aab4af6b16ad3ecb1dc5c32127acbdf778c2d3f8da413b3aa703304e3abde9e557230f33f88d740b9f586185c82d48 SHA512 48815f2f4cd6b6744fb0c7ba86b403b5987369176f87f60d26d0125f1c42703b5128a71d4a2bb2a86db0e2c24e6290a38ef2d3f17294db65696ab3d8989f2d20
+EBUILD funzix-1.0.ebuild 487 BLAKE2B 9ab5c04537139bd95d7cc27c3c7f02d276e1d476a2b36a0b4530012146c420b3e9ba9591ce952ab3aaa575715c7a7b17d3e39f7620bf70c37008ea272610ada5 SHA512 e8b5cd0a598d16026cf87b80e95c97556f09f6f5df3ca068d60d8fb029680a8efaf1807accff4f9d5b669c4fc3fd77319d91b26822e119abd3084747685bdaa4
MISC metadata.xml 243 BLAKE2B bdd58ee3763af689265c063ddc89e4ed90465bd520910a43e92e5d2c85aba25732a8224063b6efe0fa2891578b80ab490bd7389022cca63b6bf962c05893e0ad SHA512 1fc5c4b9fcfc9ecf016a6997a0a7fe145d2819b63bea1cc18ac8489245b347ccd41f10b1d826f6ba4f14d321308a87a51871cfcf6da3c73d80640ece101a348f
diff --git a/app-arch/funzix/files/funzix-1.0-fix-build-system.patch b/app-arch/funzix/files/funzix-1.0-fix-build-system.patch
new file mode 100644
index 000000000000..1fd5482d4dcd
--- /dev/null
+++ b/app-arch/funzix/files/funzix-1.0-fix-build-system.patch
@@ -0,0 +1,8 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,4 @@
+-CFLAGS += -Wall -g
++CFLAGS += -Wall
+ LDLIBS += -lz
+
+ all: funzix
diff --git a/app-arch/funzix/funzix-1.0.ebuild b/app-arch/funzix/funzix-1.0.ebuild
index 9d479a6c8eff..8f62fd7801f6 100644
--- a/app-arch/funzix/funzix-1.0.ebuild
+++ b/app-arch/funzix/funzix-1.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
inherit toolchain-funcs
DESCRIPTION="unpacker for the bogus ZIX format"
@@ -12,11 +14,13 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-src_compile() {
- emake CC="$(tc-getCC)" || die "emake failed"
+PATCHES=( "${FILESDIR}"/${PN}-1.0-fix-build-system.patch )
+
+src_configure() {
+ tc-export CC
}
src_install() {
- dobin funzix || die
- dodoc README
+ dobin funzix
+ einstalldocs
}