summaryrefslogtreecommitdiff
path: root/app-arch/file-roller
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /app-arch/file-roller
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'app-arch/file-roller')
-rw-r--r--app-arch/file-roller/Manifest2
-rw-r--r--app-arch/file-roller/file-roller-3.40.0.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/app-arch/file-roller/Manifest b/app-arch/file-roller/Manifest
index 19142566ccb9..35f57ddea0fe 100644
--- a/app-arch/file-roller/Manifest
+++ b/app-arch/file-roller/Manifest
@@ -1,4 +1,6 @@
AUX 3.36-packages.match 664 BLAKE2B dfe72c4eb0b44b8ab589fa81c0ceaa31bc3516dee78fabe2eb48f8131b25ed75a11630ae620e70646539ef42a7c4d7d283f71ffa0fa13f64ccf164d672acd95a SHA512 154438583492c571e4c8e1c926c3cb04972255cc4d1b74f186dfbe50c9756f25e11034fe64d893fdd8f2698c8eaaebba76682a818bb6523656c7c412f8e8b614
DIST file-roller-3.38.1.tar.xz 875572 BLAKE2B 29a05d48971c2172177bd1aa52448ed5432a69733644b131517dbd7dd50cab971801d1bff5837dba74ae48ea0487614c7c7ebd4669f04f7d42e6257161fe1776 SHA512 b1936481140084c84d7bdbf361859b0ff1fed8329e26b692f0f0c8d1a3a1ec494b493aa0fb4de9f0ea5004b18e4bd69859656fe424bf413d720b04fc56e453f6
+DIST file-roller-3.40.0.tar.xz 876424 BLAKE2B fa2483677869d5a6b4ac91938eac6bf09965177ffa07bab76a77a0be58e331466f939e7e0728d5eeeb5703c6ff12f178f8080922f8ae9d726e77700bbbd518ed SHA512 224dbe4f4358aa62589d084d67244ad8d65d718f9b6adf708ba1425b38fca68e08b07a6163f66d95c6acfd164b6062939cfeb27873ea41353e0551e322b0eb26
EBUILD file-roller-3.38.1.ebuild 2180 BLAKE2B c2c10d784a90e57eb4a3f44511689e02042db061636c3055a97f54ed7449d6b8aa4b5dde339bd445025c395046a3b1aaf207763409c735e0d15def8b706d3ef4 SHA512 7b6bac2e9da061aa93d8b5da88d44090e20ad1dc01bf1bf3b95ba2532489ae5911f4c809fab528b5101c9d22a54b5813a1a8fcd0e589245ffb09f8c0d7c35a7c
+EBUILD file-roller-3.40.0.ebuild 2195 BLAKE2B 316198d0d16c5480edb28ea6c141209e645acf760ba4223b069a02a0f6a79330122f9b18d96455f71bba8dcb5e2d8cc2a8ae6e651eb442d5d19eb70dd5b29a4d SHA512 11c0c1b25ff40ade00ab0a934616de2fbd1487d4ec25b23a7eca2b48c6e10df5814d88d0602e2a026fccbf22d1a680909bbb18031ee38f10f79f93f49756322e
MISC metadata.xml 522 BLAKE2B 555fc1eb7ab102a7bd439544e158c0a554b8dee1d3891dbc3b9441c5063ad2666795c682e9ade30a920daabe5788017a67680095832e760b9c9c666dcba94928 SHA512 6a8988a025352b00d1dff7b4ab3f75bfb4f95b890a1e1b0fcfdd840a67fe4897dfcce275f8ff439345f094924c72171b1d03e70106f84bd8e0aff8de5510d698
diff --git a/app-arch/file-roller/file-roller-3.40.0.ebuild b/app-arch/file-roller/file-roller-3.40.0.ebuild
new file mode 100644
index 000000000000..bcde653bb444
--- /dev/null
+++ b/app-arch/file-roller/file-roller-3.40.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+inherit gnome.org gnome2-utils meson python-any-r1 readme.gentoo-r1 xdg
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/FileRoller"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+IUSE="libnotify nautilus"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# gdk-pixbuf used extensively in the source
+# cairo used in eggtreemultidnd.c
+# pango used in fr-window
+RDEPEND="
+ >=app-arch/libarchive-3.2:=
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/json-glib-0.14
+ >=x11-libs/gtk+-3.22.0:3
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ libnotify? ( >=x11-libs/libnotify-0.4.3:= )
+ nautilus? ( >=gnome-base/nautilus-3.28.0 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${PN} is a frontend for several archiving utilities. If you want a
+particular archive format support, see ${HOMEPAGE}
+and install the relevant package. For example:
+7-zip - app-arch/p7zip
+ace - app-arch/unace
+arj - app-arch/arj
+brotli - app-arch/brotli
+cpio - app-arch/cpio
+deb - app-arch/dpkg
+iso - app-cdr/cdrtools
+jar,zip - app-arch/zip and app-arch/unzip
+lha - app-arch/lha
+lzop - app-arch/lzop
+lz4 - app-arch/lz4
+rar - app-arch/unrar or app-arch/unar
+rpm - app-arch/rpm
+unstuff - app-arch/stuffit
+zstd - app-arch/zstd
+zoo - app-arch/zoo"
+
+src_prepare() {
+ # File providing Gentoo package names for various archivers
+ cp -v "${FILESDIR}"/3.36-packages.match data/packages.match || die
+
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Drun-in-place=false
+ $(meson_feature nautilus nautilus-actions)
+ $(meson_feature libnotify notification)
+ -Dpackagekit=false
+ -Dlibarchive=enabled
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}