summaryrefslogtreecommitdiff
path: root/app-arch/file-roller
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-25 19:33:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-25 19:33:39 +0100
commita5b65c81168c90928784a1e92cda84ed5d6b9eb3 (patch)
tree4aa7483cd0ad7de54338afc8e7971417abe1dd81 /app-arch/file-roller
parente8f81810baa21f490d6910e8e2d424546b72a333 (diff)
gentoo resync : 25.09.2019
Diffstat (limited to 'app-arch/file-roller')
-rw-r--r--app-arch/file-roller/Manifest2
-rw-r--r--app-arch/file-roller/file-roller-3.32.2.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/app-arch/file-roller/Manifest b/app-arch/file-roller/Manifest
index 9036efffafaf..1ae985d44133 100644
--- a/app-arch/file-roller/Manifest
+++ b/app-arch/file-roller/Manifest
@@ -1,4 +1,6 @@
AUX 3.22-packages.match 589 BLAKE2B b53cde8851c08d4f538397d72d5e904b6862a091ca1c6b82c255bd79f91917953b7a87b534ef71488f0a93e18a181f554a5477c606be7a429f7c574a62f8e198 SHA512 b96be2502b2ee56fb234af547a045cfed2c5e8bd7290876db641bb1f895ea6a796e50f2e2e066fc80b42fa58eab740a5519c0f2ad78f2787f55d1077b183ee62
DIST file-roller-3.30.1.tar.xz 1443340 BLAKE2B 352b094b51d342ac71f2174b59dff262ba46b4697c21164ba18bf825d70cb609d59a35ce0efe1013e217e86754822accc11c59eb9bba7185a9f7efe5dded4def SHA512 8f3f55cd7d6769fbf8f72118bb8982775c3f83534266db1f2cc9bbfd9e8dd68545ab49baaa4e468ce22e616346dec9c99c11a0c5b4208dca2e648fac8756cea7
+DIST file-roller-3.32.2.tar.xz 850256 BLAKE2B 5e7f8fed74ff3ff87079753d3fb227cbb77c0a10b75995b84a6019e13434dd4bff16946d38c2b340c85f5dd7879692cc5edd4aa9471f30ea92d2a7fff5176296 SHA512 d1c1e08f12ce343c23c43816305f75c0f3a3f3df32316805864d7c39b5e85b5a00e04a355a0dd8001db8e01ae089daf3b72c3f38fda582795944a6be09451b2a
EBUILD file-roller-3.30.1.ebuild 2126 BLAKE2B 3ca2c6d6f7a288570dd54b2944962b61358c06ba1182a84a2d025c652103d67af751201e934867743e00e19cd0fe5e4004ebf6943931016351e52eef1b6a6ef5 SHA512 e642ec6cec104546dd84e83fe3d9f54abfc79a12ab2d2eb56419c431ada3e2a90b1ad269d354a8c18842456f753707cb9a4838eeabfee564092b960147d64af4
+EBUILD file-roller-3.32.2.ebuild 2164 BLAKE2B b4b9116e6d5dbc6c8277d18f3e48ef1c31d6de661013eec03dfcdbcdfb8d17a1394ea0980e8dd17cdd741b9fd46759821cf0cdedcb94658df92ff69ff9e66a5c SHA512 cec9ab9b3b6b07ae14a479cc63b01a3a7e78ec45dfaa5884dbb6e98abf1b2d8ee4ee9a429b6f9295b651b8e5497857861abd9a7560be8d2f6060b881cc91d673
MISC metadata.xml 648 BLAKE2B 8fc7347f0812f1b899096670b3ed809dd577e8173f8d7dac8175fbc6eb2939157d1a6100bcc39f15d22e8058e1daba2b4ac7b678baa83f1d24c1f14d77d2e989 SHA512 ea1b782f93ef9397e798d7f6cdd1e650ae95dcad71f439ec518a9e79ebc83a176c9876e85b9930d691e818f5b1efa636f5165d690cfd63b4c7ff9700ba2f956f
diff --git a/app-arch/file-roller/file-roller-3.32.2.ebuild b/app-arch/file-roller/file-roller-3.32.2.ebuild
new file mode 100644
index 000000000000..905771e02117
--- /dev/null
+++ b/app-arch/file-roller/file-roller-3.32.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson readme.gentoo-r1 xdg
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/FileRoller"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+IUSE="libnotify nautilus packagekit"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+# gdk-pixbuf used extensively in the source
+# cairo used in eggtreemultidnd.c
+# pango used in fr-window
+RDEPEND="
+ >=app-arch/libarchive-3:=
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/json-glib-0.14
+ >=x11-libs/gtk+-3.13.2:3
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ libnotify? ( >=x11-libs/libnotify-0.4.3:= )
+ nautilus? ( >=gnome-base/nautilus-2.22.2 )
+ packagekit? ( app-admin/packagekit-base )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${PN} is a frontend for several archiving utilities. If you want a
+particular archive format support, see ${HOMEPAGE}
+and install the relevant package. For example:
+7-zip - app-arch/p7zip
+ace - app-arch/unace
+arj - app-arch/arj
+brotli - app-arch/brotli
+cpio - app-arch/cpio
+deb - app-arch/dpkg
+iso - app-cdr/cdrtools
+jar,zip - app-arch/zip and app-arch/unzip
+lha - app-arch/lha
+lzop - app-arch/lzop
+lz4 - app-arch/lz4
+rar - app-arch/unrar or app-arch/unar
+rpm - app-arch/rpm
+unstuff - app-arch/stuffit
+zoo - app-arch/zoo"
+
+src_prepare() {
+ # File providing Gentoo package names for various archivers
+ cp -v "${FILESDIR}"/3.22-packages.match data/packages.match || die
+
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Drun-in-place=false
+ $(meson_use nautilus nautilus-actions)
+ $(meson_use libnotify notification)
+ $(meson_use packagekit)
+ -Dlibarchive=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}