summaryrefslogtreecommitdiff
path: root/app-arch/file-roller
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /app-arch/file-roller
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'app-arch/file-roller')
-rw-r--r--app-arch/file-roller/Manifest2
-rw-r--r--app-arch/file-roller/file-roller-3.42.0.ebuild95
2 files changed, 97 insertions, 0 deletions
diff --git a/app-arch/file-roller/Manifest b/app-arch/file-roller/Manifest
index ef2ad384dc3f..11733d2e8fae 100644
--- a/app-arch/file-roller/Manifest
+++ b/app-arch/file-roller/Manifest
@@ -1,4 +1,6 @@
AUX 3.36-packages.match 664 BLAKE2B dfe72c4eb0b44b8ab589fa81c0ceaa31bc3516dee78fabe2eb48f8131b25ed75a11630ae620e70646539ef42a7c4d7d283f71ffa0fa13f64ccf164d672acd95a SHA512 154438583492c571e4c8e1c926c3cb04972255cc4d1b74f186dfbe50c9756f25e11034fe64d893fdd8f2698c8eaaebba76682a818bb6523656c7c412f8e8b614
DIST file-roller-3.40.0.tar.xz 876424 BLAKE2B fa2483677869d5a6b4ac91938eac6bf09965177ffa07bab76a77a0be58e331466f939e7e0728d5eeeb5703c6ff12f178f8080922f8ae9d726e77700bbbd518ed SHA512 224dbe4f4358aa62589d084d67244ad8d65d718f9b6adf708ba1425b38fca68e08b07a6163f66d95c6acfd164b6062939cfeb27873ea41353e0551e322b0eb26
+DIST file-roller-3.42.0.tar.xz 878968 BLAKE2B af3a8bb566a0549434f20911315358dbcfb98aab17ca47adaad166f620fc3b8cfc6b60301842a55a0d35ca29f6317b16d07497de759b55bc42b61100e7357066 SHA512 ad151e1dc6546ca45550ab4c7384fb89e91dc2fc17a29437922192fefd5cbcd115d1f064e090dac48ae3fca33709a54bac918cbe03cbfd0e6fc3554913dd8322
EBUILD file-roller-3.40.0.ebuild 2199 BLAKE2B 5acf854c76e94908a8d5af013d298df9827ab447208549623c2aa026c95bc105f5d10911aeabba3e78dcd3f313e1768c69b9a064875107176e048af5481be3c4 SHA512 fb686a7aa3ef1c5a5bd382a1b8c3556b59d0be208539b043f7da38092aa4136a3a9e272abbca962cee9a08827e3a2be63f744ee7a416ea76e31de50e70e38f6e
+EBUILD file-roller-3.42.0.ebuild 2247 BLAKE2B 956e33e72aa27d2256aaf8d07ceb1b08c17bd4e5837fc5ecd34c6a526b7561b4f0a7397d3171afb000126f2e22507c716faa2e469956a4a3024658adc54ce71e SHA512 8773e9918958d972133b4333927f74a733ad4c05e32b1f7cae8b750205cf7baaa6e26019fa1414aba780931e123990276f3e83691b05ba97c8fbb3fe41ce9689
MISC metadata.xml 523 BLAKE2B 44d1f4c6636070d561c1d0fdb6bfaaae0f92b81608f52de78f6b5168ca717a7ab0c54ca24a8bde59cd7a7e0be96f195bd8f7eb5e53e820917fec5cf692cea7ec SHA512 79b172bc5f64b91f389c6dee90da6dca10705f07fd469b04486eb90d11988a07002233c0718c3f223df9fd63050b3fb17dc3d5f56b8923e47dfbcc231834fdc9
diff --git a/app-arch/file-roller/file-roller-3.42.0.ebuild b/app-arch/file-roller/file-roller-3.42.0.ebuild
new file mode 100644
index 000000000000..4f1ac8f72ee6
--- /dev/null
+++ b/app-arch/file-roller/file-roller-3.42.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+inherit gnome.org gnome2-utils meson python-any-r1 readme.gentoo-r1 xdg
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/FileRoller"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+IUSE="libnotify nautilus"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# gdk-pixbuf used extensively in the source
+# cairo used in eggtreemultidnd.c
+# pango used in fr-window
+RDEPEND="
+ >=app-arch/libarchive-3.2:=
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/json-glib-0.14
+ >=x11-libs/gtk+-3.22.0:3
+ >=gui-libs/libhandy-1.5.0:1
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ libnotify? ( >=x11-libs/libnotify-0.4.3:= )
+ nautilus? ( >=gnome-base/nautilus-3.28.0 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${PN} is a frontend for several archiving utilities. If you want a
+particular archive format support, see ${HOMEPAGE}
+and install the relevant package. For example:
+7-zip - app-arch/p7zip
+ace - app-arch/unace
+arj - app-arch/arj
+brotli - app-arch/brotli
+cpio - app-arch/cpio
+deb - app-arch/dpkg
+iso - app-cdr/cdrtools
+jar,zip - app-arch/zip and app-arch/unzip
+lha - app-arch/lha
+lzop - app-arch/lzop
+lz4 - app-arch/lz4
+rar - app-arch/unrar or app-arch/unar
+rpm - app-arch/rpm
+unstuff - app-arch/stuffit
+zstd - app-arch/zstd
+zoo - app-arch/zoo"
+
+src_prepare() {
+ # File providing Gentoo package names for various archivers
+ cp -v "${FILESDIR}"/3.36-packages.match data/packages.match || die
+
+ default
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Drun-in-place=false
+ $(meson_feature nautilus nautilus-actions)
+ $(meson_feature libnotify notification)
+ -Dpackagekit=false
+ -Dlibarchive=enabled
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}