summaryrefslogtreecommitdiff
path: root/app-arch/deltarpm/deltarpm-3.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-arch/deltarpm/deltarpm-3.6.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/deltarpm/deltarpm-3.6.ebuild')
-rw-r--r--app-arch/deltarpm/deltarpm-3.6.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/app-arch/deltarpm/deltarpm-3.6.ebuild b/app-arch/deltarpm/deltarpm-3.6.ebuild
deleted file mode 100644
index 3a60c4ea7da0..000000000000
--- a/app-arch/deltarpm/deltarpm-3.6.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit toolchain-funcs python-single-r1
-
-DESCRIPTION="tools to create and apply deltarpms"
-HOMEPAGE="https://github.com/rpm-software-management/deltarpm"
-SRC_URI="http://pkgs.fedoraproject.org/repo/pkgs/${PN}/${P}.tar.bz2/2cc2690bd1088cfc3238c25e59aaaec1/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="python system-zlib"
-
-RDEPEND="sys-libs/zlib
- app-arch/xz-utils
- app-arch/bzip2
- <app-arch/rpm-5
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-pkg_setup() {
- python-single-r1_pkg_setup
-
- MAKE_EXTRA_FLAGS=(
- -j1
- prefix=/usr
- mandir=/usr/share/man
- PYTHONS=$(use python && echo python)
- CFLAGS="${CFLAGS}"
- LDFLAGS="${LDFLAGS}"
- CC="$(tc-getCC)"
- )
- use system-zlib && MAKE_EXTRA_FLAGS+=(
- zlibbundled=
- zlibcppflags=
- zlibldflags=-lz
- )
-}
-
-src_compile() {
- emake "${MAKE_EXTRA_FLAGS[@]}" all $(use python && echo python)
-}
-
-src_install() {
- emake "${MAKE_EXTRA_FLAGS[@]}" DESTDIR="${ED}" install
- python_optimize
-}