summaryrefslogtreecommitdiff
path: root/app-arch/deltarpm/deltarpm-3.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/deltarpm/deltarpm-3.6.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/deltarpm/deltarpm-3.6.ebuild')
-rw-r--r--app-arch/deltarpm/deltarpm-3.6.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-arch/deltarpm/deltarpm-3.6.ebuild b/app-arch/deltarpm/deltarpm-3.6.ebuild
new file mode 100644
index 000000000000..3a60c4ea7da0
--- /dev/null
+++ b/app-arch/deltarpm/deltarpm-3.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit toolchain-funcs python-single-r1
+
+DESCRIPTION="tools to create and apply deltarpms"
+HOMEPAGE="https://github.com/rpm-software-management/deltarpm"
+SRC_URI="http://pkgs.fedoraproject.org/repo/pkgs/${PN}/${P}.tar.bz2/2cc2690bd1088cfc3238c25e59aaaec1/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python system-zlib"
+
+RDEPEND="sys-libs/zlib
+ app-arch/xz-utils
+ app-arch/bzip2
+ <app-arch/rpm-5
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+
+ MAKE_EXTRA_FLAGS=(
+ -j1
+ prefix=/usr
+ mandir=/usr/share/man
+ PYTHONS=$(use python && echo python)
+ CFLAGS="${CFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ CC="$(tc-getCC)"
+ )
+ use system-zlib && MAKE_EXTRA_FLAGS+=(
+ zlibbundled=
+ zlibcppflags=
+ zlibldflags=-lz
+ )
+}
+
+src_compile() {
+ emake "${MAKE_EXTRA_FLAGS[@]}" all $(use python && echo python)
+}
+
+src_install() {
+ emake "${MAKE_EXTRA_FLAGS[@]}" DESTDIR="${ED}" install
+ python_optimize
+}