summaryrefslogtreecommitdiff
path: root/app-arch/cabextract
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-04 07:37:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-04 07:37:02 +0000
commit5ae7efc9abae6bb8f8fac438298427769a91f5ad (patch)
treedc25abd0d9e2475f76b5060721ab492d2958a45f /app-arch/cabextract
parent2e6b794bf4361b8ae32bb6945e84696c2e1d94ba (diff)
gentoo auto-resync : 04:03:2023 - 07:37:01
Diffstat (limited to 'app-arch/cabextract')
-rw-r--r--app-arch/cabextract/Manifest4
-rw-r--r--app-arch/cabextract/cabextract-1.11.ebuild68
-rw-r--r--app-arch/cabextract/cabextract-9999.ebuild12
3 files changed, 77 insertions, 7 deletions
diff --git a/app-arch/cabextract/Manifest b/app-arch/cabextract/Manifest
index 7d93bddeefed..52b1155bc84a 100644
--- a/app-arch/cabextract/Manifest
+++ b/app-arch/cabextract/Manifest
@@ -1,4 +1,6 @@
+DIST cabextract-1.11.tar.gz 489656 BLAKE2B c0360e63359c3c3db26d442a92be8ac3f05903015be0f8fc76e81b572e882807b881756d6541aa77e55e8c083cda3363f8d2f9a32a7ab35a0b79482a9c91ef47 SHA512 416bdc5a889c3986b2a5d6ecb8526a69f2d85c34f4856da43951271ff4f31013e4197c56ea5f6b05061b511b980d5a65cb34b9b859d3013c1dbcbb89d43114f9
DIST cabextract-1.9.1.tar.gz 469369 BLAKE2B 5bfc697b40cbf47b42ab7857804b703c9622d8dae1648aae1bb5c0ec7c7978bff01b7ca2526f1b6090f193d88c00e3f49ae111f348d03fec9f575bddbb4b4096 SHA512 c354a4b20a222b40813f01baf8311c9a76611da427f9f44e977a3fd09508e24a18b486e3eef889a9debdca459f1b0c28d5d25429ccd555d3a2e4ff92d91cec14
+EBUILD cabextract-1.11.ebuild 1620 BLAKE2B 6838c6607c0e38ebed17747ffa3045fdd8c8543681799606c781db2a21e57d08c0ab3251520d64d3800bcaadb27e9857cf6e9518e03c4b5b332840f0ecb0f98f SHA512 40ae64efb6cb296960f25c84c477e0b5a151e113ed416f6c24374207813dddd48a4b609691f7cd4159f1162bd03cdabfb5276091b0a30ee49b97d1bef9a116d6
EBUILD cabextract-1.9.1.ebuild 1589 BLAKE2B ebf5886a021aee647c2cc2e0ab7df67cbd2dea6f670718e9b06e710e7a4b2bd56cb10632d38672de81923e529332edfc258c54609bb19d00c9c73de5c81f513f SHA512 e03ac17a291e90873db34ff2ad289979734941e29281a8e00fb5749bcc73338898c52d5ff199c59a0a5144ae77d4eb9e5fd789e5965d7259151ce32c51ab0661
-EBUILD cabextract-9999.ebuild 1570 BLAKE2B 3834e948a9ac30dcae4bb1261c4f09955d12f3e4bf01592915cd68e235dbc45b19f479793ddb929625fd3cf074c2b12504dbf04f8dabdae60de5872f4977f35b SHA512 3204337a930259ea04e683484033373865c6a096e2839ee826e2fc52b31a8d44df84f3fc3df8a55505a81e550689914d990e8839824c4dac68b8bcf3b5555297
+EBUILD cabextract-9999.ebuild 1620 BLAKE2B 6838c6607c0e38ebed17747ffa3045fdd8c8543681799606c781db2a21e57d08c0ab3251520d64d3800bcaadb27e9857cf6e9518e03c4b5b332840f0ecb0f98f SHA512 40ae64efb6cb296960f25c84c477e0b5a151e113ed416f6c24374207813dddd48a4b609691f7cd4159f1162bd03cdabfb5276091b0a30ee49b97d1bef9a116d6
MISC metadata.xml 556 BLAKE2B 56968f48613cd1c331acb6a8013e998d96e9da101dd4bc15bf98381501923087ba5bb49ff6e0b52d6e5fb01121bc543f05c90ce7f2657c871ce0ef07eab16212 SHA512 21a53a5f845a8cebecec884cef051b6f073a9e9009c44d033b90ba5b06d8d2dcfabd0ee3082926e60faebbb6ef297d624313cea1a22308ee1c5de88b834dd71d
diff --git a/app-arch/cabextract/cabextract-1.11.ebuild b/app-arch/cabextract/cabextract-1.11.ebuild
new file mode 100644
index 000000000000..6ed4e3092da5
--- /dev/null
+++ b/app-arch/cabextract/cabextract-1.11.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/kyz/libmspack.git"
+ inherit autotools git-r3
+ MY_P="${PN}-9999"
+
+ LIBMSPACK_DEPEND="~dev-libs/libmspack-9999:="
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+ MY_PV="${PV/_alpha/alpha}"
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="https://www.cabextract.org.uk/${P}.tar.gz"
+
+ LIBMSPACK_DEPEND=">=dev-libs/libmspack-0.8_alpha:="
+fi
+
+DESCRIPTION="Extracts files from Microsoft cabinet archive files"
+HOMEPAGE="https://www.cabextract.org.uk/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="extras"
+
+DEPEND="${LIBMSPACK_DEPEND}"
+RDEPEND="${LIBMSPACK_DEPEND}
+ extras? ( dev-lang/perl )"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ # Re-create file layout from release tarball
+ pushd "${WORKDIR}" &>/dev/null || die
+ cp -aL "${S}"/${PN} "${WORKDIR}"/${PN}-source || die
+ rm -r "${S}" || die
+ mv "${WORKDIR}"/${PN}-source "${S}" || die
+ popd &>/dev/null || die
+ fi
+
+ default
+
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-external-libmspack=yes
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog NEWS README TODO doc/magic )
+ default
+ docinto html
+ dodoc doc/wince_cab_format.html
+ if use extras; then
+ dobin src/{wince_info,wince_rename,cabinfo,cabsplit}
+ fi
+}
diff --git a/app-arch/cabextract/cabextract-9999.ebuild b/app-arch/cabextract/cabextract-9999.ebuild
index 569f885f93b4..6ed4e3092da5 100644
--- a/app-arch/cabextract/cabextract-9999.ebuild
+++ b/app-arch/cabextract/cabextract-9999.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
-inherit autotools toolchain-funcs
+inherit toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/kyz/libmspack.git"
- inherit git-r3
+ inherit autotools git-r3
MY_P="${PN}-9999"
LIBMSPACK_DEPEND="~dev-libs/libmspack-9999:="
else
- KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
MY_PV="${PV/_alpha/alpha}"
MY_P="${PN}-${MY_PV}"
SRC_URI="https://www.cabextract.org.uk/${P}.tar.gz"
@@ -45,7 +45,7 @@ src_prepare() {
default
- eautoreconf
+ [[ ${PV} == "9999" ]] && eautoreconf
}
src_configure() {