summaryrefslogtreecommitdiff
path: root/app-arch/bzip2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /app-arch/bzip2
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'app-arch/bzip2')
-rw-r--r--app-arch/bzip2/Manifest1
-rw-r--r--app-arch/bzip2/bzip2-9999.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-arch/bzip2/Manifest b/app-arch/bzip2/Manifest
index f7a357d4c36b..27e9f33e2c40 100644
--- a/app-arch/bzip2/Manifest
+++ b/app-arch/bzip2/Manifest
@@ -11,4 +11,5 @@ AUX bzip2-1.0.6-saneso.patch 443 BLAKE2B b496406e6f3c520886fff99c9206d6d1a01dc0e
AUX bzip2-1.0.6-ubsan-error.patch 921 BLAKE2B a2d746725ed9e40f24ac7c83cdbea06884e0013121bad5a2c748975817293c8f300735d46c85e646e008a54d49d002331a86a31726bc7231451514e628ad4637 SHA512 871ad39056b5b5dba35d90f30e1753569241f1054a2564f115d65186232fd84c427c92199e88ba012b4a646d9f18469b3681ef2992ec028b1004f6b7e13a110d
DIST bzip2-1.0.6.tar.gz 782025 BLAKE2B b31533af7c71d715e6600874bb0a11b9b3aebbb08af0414a6d88bd5a2ad879a482ad408338159cb6c241815da8f48798d2ea7789ea971431d0be42ee827b0a7e SHA512 00ace5438cfa0c577e5f578d8a808613187eff5217c35164ffe044fbafdfec9e98f4192c02a7d67e01e5a5ccced630583ad1003c37697219b0f147343a3fdd12
EBUILD bzip2-1.0.6-r11.ebuild 3158 BLAKE2B d1eb6c4e92bda0c1190373820b36a58b4eb1927717f6dd828a3867e616f02a9d725309dd239ad7346e6cc935f945bd32c6a83336b4fb5d7f774e1aaaa9a9e029 SHA512 d172d4d20fc6dbe7db700d165c5c75458c59154d255b40d0be0d5380fa88b606db82ddd88a87077521db0e4749bf0f005aa20870ce9722f06c71bdc8efef479a
+EBUILD bzip2-9999.ebuild 1404 BLAKE2B 3e6093b7b44d8e5b9da46f9cffd8efa73e2118711d4e3f87dda2f21ed7ae8fed9d7260b027a4b0b78136350ce7e741bd785fecad7c25b1889537d50b6658af8f SHA512 ab9db8ef978fc43dc71406dc6f8991568770fc059dba34cf360d7fcb4a41fccc86b9c3b5323fa8b7f8ad130cbc9f1fcfa8212ff3fb9b79d63b5e426f4ef132a3
MISC metadata.xml 332 BLAKE2B b949c1c7d17334fcb499bbbd042cb217092743b6ae29fc64e634f7957767bf8c6a46f865b1681ce165d60143307795ebc417887fa8ba7a69afee95062411ea07 SHA512 1a7f730b73728875e428e7b123cd8e7773e8ea88a02d6891727775b50196854c608ae541846063a258874a83aab38800dc697b37196fe1c75162abe21b8f92d0
diff --git a/app-arch/bzip2/bzip2-9999.ebuild b/app-arch/bzip2/bzip2-9999.ebuild
new file mode 100644
index 000000000000..1b4bac424b04
--- /dev/null
+++ b/app-arch/bzip2/bzip2-9999.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson multilib-minimal
+
+DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
+HOMEPAGE="https://gitlab.com/federicomenaquintero/bzip2"
+if [[ "${PV}" == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/federicomenaquintero/bzip2.git"
+else
+ SRC_URI=""
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+fi
+LICENSE="BZIP2"
+SLOT="0/1" # subslot = SONAME
+
+IUSE="static-libs"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library=$(usex static-libs both shared)
+ # Requires whole tex stack
+ -Ddocs="disabled"
+ )
+
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+
+ if multilib_is_native_abi ; then
+ gen_usr_ldscript -a bz2
+
+ dodir /bin
+ mv "${ED}"/usr/bin/bzip2 "${ED}"/bin || die
+ fi
+}
+
+multilib_src_install_all() {
+ # move "important" bzip2 binaries to /bin and use the shared libbz2.so
+ dosym bzip2 /bin/bzcat
+ dosym bzip2 /bin/bunzip2
+
+ dosym bzdiff /usr/bin/bzcmp
+ dosym bzmore /usr/bin/bzless
+ local x
+ for x in bz{e,f}grep ; do
+ dosym bzgrep /usr/bin/${x}
+ done
+
+ dosym bzip2.1 /usr/share/man/man1/bzip2recover.1
+
+ local DOCS=( AUTHORS NEWS{,-pre-1.0.7} README.md )
+ einstalldocs
+}