summaryrefslogtreecommitdiff
path: root/app-arch/bzip2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-23 11:29:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-23 11:29:49 +0100
commit55a7866dd6169a108d3a9e8d6696a970dea8a0b6 (patch)
tree4a43df088b5fd8cfde3ca236a3b1566f0f1b45af /app-arch/bzip2
parent7f740fcb9a0165d81bfecf7fb5da647763d76a1b (diff)
gentoo auto-resync : 23:09:2022 - 11:29:49
Diffstat (limited to 'app-arch/bzip2')
-rw-r--r--app-arch/bzip2/Manifest2
-rw-r--r--app-arch/bzip2/bzip2-9999.ebuild25
2 files changed, 11 insertions, 16 deletions
diff --git a/app-arch/bzip2/Manifest b/app-arch/bzip2/Manifest
index 47b288509091..13c97717083e 100644
--- a/app-arch/bzip2/Manifest
+++ b/app-arch/bzip2/Manifest
@@ -8,5 +8,5 @@ AUX bzip2-1.0.8-saneso.patch 463 BLAKE2B 83c5a905dbb3dd6481abe7ad7f57f9ce5c5cac8
DIST bzip2-1.0.8.tar.gz 810029 BLAKE2B 22ab3acd84f4db8c3d6f59340c252faedfd4447cea00dafbd652e65b6cf8a20adf6835c22e58563004cfafdb15348c924996230b4b23cae42da5e25eeac4bdad SHA512 083f5e675d73f3233c7930ebe20425a533feedeaaa9d8cc86831312a6581cefbe6ed0d08d2fa89be81082f2a5abdabca8b3c080bf97218a1bd59dc118a30b9f3
DIST bzip2-1.0.8.tar.gz.sig 310 BLAKE2B 0d702dcb19f7738da9f05ee9d719f5cd3653540365e78db143404e599ea54bc6f9d5e6a38cdf5cdd3c6550243d34266343467c6b1db9d5d3c134f9353b00f395 SHA512 4a4a3fa0ec1c10a704b9870e8e629fd007cca55184423c6bfc3049a702fb41e4aeb73bfe9ca7442c27d32d278f1f34f27523a6be67d35b37896acdded12bf40d
EBUILD bzip2-1.0.8-r3.ebuild 3343 BLAKE2B b0b9c71705eb40decdb293ac36edfbb9beb03a5d418c9397d575182b1a41b885fc2dffe57fcd2bc41320eb957e87daf4e4b05a534b0b696e1a4cb14bb1862edd SHA512 0d731c721a9c2df13a70ca40a13ce4cffb4f91dfc2787dd5e86fac97b3dc2d1e6bc0e86d58d50905a39b31d08c1890d02478ce61e5f04fbefc895f2113b4f3ff
-EBUILD bzip2-9999.ebuild 1693 BLAKE2B 0829df6dfdbe05a41af80c9207d47ee6e88f6a35ddba7b68f1d7146ed0d4e71c30570be50e6f236a44d3dd30df784953eeeef81ad9359917ef9d109657552520 SHA512 2fb7c803f45681335d92ccedc6c0610800d86d620b5ea9d992c1462deb2a1bfcdf27be0d85ad80fbbbe9bae9957228e11aa7ecfe8f3bb6cc8ba0205b50f6697b
+EBUILD bzip2-9999.ebuild 1362 BLAKE2B ef5a5447c068dea75b0ffce542583532deee44154ecfa9946ad3a21bb0a4bbd5b09c04d92bffe3da7d77c5f62d2d1200f92436923b443ed8f7e79313f5476db6 SHA512 392f1dee22e823b5973a0fe7c023b48c23769aace842d299a0389ace5ab7809fc67f76fe4e7aa28ba16a404c843a3c54b39ef97043ba89db3586a1e2b0940281
MISC metadata.xml 333 BLAKE2B 88bbfff022309d663b728da241623e9a9dd2cd00d4638cc97c4809433a3645421239d2f51360f9d848617891e7600ad6b63b17acf8c6ecd65a4e355dc1372084 SHA512 15620686ec250b2547fc7ff369c9c0854a7217e731da556db1224896cfd4e63eba836469722b12115e359a9701acea0ac09d7ecc89fa1dbf8683106432f1f9bb
diff --git a/app-arch/bzip2/bzip2-9999.ebuild b/app-arch/bzip2/bzip2-9999.ebuild
index 38d766cedafc..e463fbf759d7 100644
--- a/app-arch/bzip2/bzip2-9999.ebuild
+++ b/app-arch/bzip2/bzip2-9999.ebuild
@@ -1,26 +1,28 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson-multilib usr-ldscript
DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
-HOMEPAGE="https://gitlab.com/federicomenaquintero/bzip2"
-if [[ "${PV}" == 9999 ]] ; then
+HOMEPAGE="https://gitlab.com/bzip2/bzip2"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://gitlab.com/bzip2/bzip2"
inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/federicomenaquintero/bzip2.git"
else
- SRC_URI=""
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
+
LICENSE="BZIP2"
SLOT="0/1" # subslot = SONAME
IUSE="static-libs"
-RDEPEND="!app-arch/lbzip2[symlink(-)]
- !app-arch/pbzip2[symlink(-)]"
+RDEPEND="
+ !app-arch/lbzip2[symlink(-)]
+ !app-arch/pbzip2[symlink(-)]
+"
multilib_src_configure() {
local emesonargs=(
@@ -35,13 +37,6 @@ multilib_src_configure() {
multilib_src_install() {
meson_src_install
- # Install libbz2.so.1.0 due to accidental soname change in 1.0.7.
- # Reference: 98da0ad82192d21ad74ae52366ea8466e2acea24.
- # OK to remove one year after 2020-04-11.
- if [[ ! -L "${ED}/usr/$(get_libdir)/libbz2.so.1.0" ]]; then
- dosym libbz2.so.1 "/usr/$(get_libdir)/libbz2.so.1.0"
- fi
-
if multilib_is_native_abi ; then
gen_usr_ldscript -a bz2
@@ -51,7 +46,7 @@ multilib_src_install() {
}
multilib_src_install_all() {
- # move "important" bzip2 binaries to /bin and use the shared libbz2.so
+ # Move "important" bzip2 binaries to /bin and use the shared libbz2.so
dosym bzip2 /bin/bzcat
dosym bzip2 /bin/bunzip2