summaryrefslogtreecommitdiff
path: root/app-arch/brotli/brotli-1.0.9-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-03 20:56:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-03 20:56:28 +0100
commitfbda87924e6faa7a1919f1a2b4182490bde5ec5c (patch)
treef3114a4ed212a754756adce027aeef3a4a1a2e2a /app-arch/brotli/brotli-1.0.9-r3.ebuild
parent3b08f674e3f771b49370edb144dab0958c8cf721 (diff)
gentoo resync : 03.09.2021
Diffstat (limited to 'app-arch/brotli/brotli-1.0.9-r3.ebuild')
-rw-r--r--app-arch/brotli/brotli-1.0.9-r3.ebuild43
1 files changed, 18 insertions, 25 deletions
diff --git a/app-arch/brotli/brotli-1.0.9-r3.ebuild b/app-arch/brotli/brotli-1.0.9-r3.ebuild
index aecf41b5cb6d..2b3a1620cf76 100644
--- a/app-arch/brotli/brotli-1.0.9-r3.ebuild
+++ b/app-arch/brotli/brotli-1.0.9-r3.ebuild
@@ -1,49 +1,42 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
DISTUTILS_OPTIONAL="1"
-DISTUTILS_IN_SOURCE_BUILD="1"
-CMAKE_ECLASS=cmake
-
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit cmake-multilib distutils-r1
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/google/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
DESCRIPTION="Generic-purpose lossless compression algorithm"
HOMEPAGE="https://github.com/google/brotli"
+LICENSE="MIT python? ( Apache-2.0 )"
SLOT="0/$(ver_cut 1)"
-
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}"
-
IUSE="python static-libs test"
+
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-LICENSE="MIT python? ( Apache-2.0 )"
+# tests are currently broken, see https://github.com/google/brotli/issues/850
+RESTRICT="test"
DOCS=( README.md CONTRIBUTING.md )
-if [[ ${PV} == "9999" ]] ; then
- SRC_URI=""
- EGIT_REPO_URI="https://github.com/google/${PN}.git"
- inherit git-r3
-else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
- SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-# tests are currently broken, see https://github.com/google/brotli/issues/850
-RESTRICT="test"
+PATCHES=( "${FILESDIR}/${PV}-linker.patch" )
-PATCHES=(
- "${FILESDIR}/${PV}-linker.patch"
-)
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
src_prepare() {
- use python && distutils-r1_src_prepare
cmake_src_prepare
+ use python && distutils-r1_src_prepare
}
multilib_src_configure() {