summaryrefslogtreecommitdiff
path: root/app-arch/brotli/brotli-1.0.9-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /app-arch/brotli/brotli-1.0.9-r1.ebuild
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'app-arch/brotli/brotli-1.0.9-r1.ebuild')
-rw-r--r--app-arch/brotli/brotli-1.0.9-r1.ebuild84
1 files changed, 0 insertions, 84 deletions
diff --git a/app-arch/brotli/brotli-1.0.9-r1.ebuild b/app-arch/brotli/brotli-1.0.9-r1.ebuild
deleted file mode 100644
index d03b1d78ade1..000000000000
--- a/app-arch/brotli/brotli-1.0.9-r1.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-DISTUTILS_OPTIONAL="1"
-DISTUTILS_IN_SOURCE_BUILD="1"
-
-inherit cmake-multilib distutils-r1
-
-DESCRIPTION="Generic-purpose lossless compression algorithm"
-HOMEPAGE="https://github.com/google/brotli"
-
-SLOT="0/$(ver_cut 1)"
-
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}"
-
-IUSE="python test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-LICENSE="MIT python? ( Apache-2.0 )"
-
-DOCS=( README.md CONTRIBUTING.md )
-
-if [[ ${PV} == "9999" ]] ; then
- SRC_URI=""
- EGIT_REPO_URI="https://github.com/google/${PN}.git"
- inherit git-r3
-else
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
- SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-# tests are currently broken, see https://github.com/google/brotli/issues/850
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}/${PV}-linker.patch"
-)
-
-src_prepare() {
- use python && distutils-r1_src_prepare
- cmake-utils_src_prepare
-}
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTING="$(usex test)"
- )
- cmake-utils_src_configure
-}
-src_configure() {
- cmake-multilib_src_configure
- use python && distutils-r1_src_configure
-}
-
-multilib_src_compile() {
- cmake-utils_src_compile
-}
-src_compile() {
- cmake-multilib_src_compile
- use python && distutils-r1_src_compile
-}
-
-python_test() {
- esetup.py test || die
-}
-
-multilib_src_test() {
- cmake-utils_src_test
-}
-src_test() {
- cmake-multilib_src_test
- use python && distutils-r1_src_test
-}
-
-multilib_src_install() {
- cmake-utils_src_install
-}
-multilib_src_install_all() {
- use python && distutils-r1_src_install
-}