summaryrefslogtreecommitdiff
path: root/app-arch/arc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/arc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/arc')
-rw-r--r--app-arch/arc/Manifest6
-rw-r--r--app-arch/arc/arc-5.21p.ebuild39
-rw-r--r--app-arch/arc/files/arc-5.21m-darwin.patch11
-rw-r--r--app-arch/arc/files/arc-5.21m-gentoo-fbsd.patch12
-rw-r--r--app-arch/arc/files/arc-5.21o-interix.patch12
-rw-r--r--app-arch/arc/metadata.xml9
6 files changed, 89 insertions, 0 deletions
diff --git a/app-arch/arc/Manifest b/app-arch/arc/Manifest
new file mode 100644
index 000000000000..e627c3859a22
--- /dev/null
+++ b/app-arch/arc/Manifest
@@ -0,0 +1,6 @@
+AUX arc-5.21m-darwin.patch 268 BLAKE2B f353d9a5cfecb4c434cc65303190523fdc0a8af159c0e2d8ae6b13d19597611a12a55a983723b0b54f2fde737d6a1538c7757dc4cb2aaf8a6014d4e4a05a836e SHA512 1250a494f793d899286989f6715a504f22b651f60019149ad1b4b4d423ad2d59fc948bdd317e773ea99bb4f52f79771450a9e69263c994c7cda79bd3bec5e94f
+AUX arc-5.21m-gentoo-fbsd.patch 216 BLAKE2B 09d600cfddb692362e78aa5aa5770387b685ce23fde54f6e77c34e41ab52b29db52b29883d6772f735773e04209506ff61f36909d895595a34afe35ace7aec9d SHA512 6cf269ca19d5000deec43bcf7e766d28aefa53219c5af8f65429e80f4a8b8ec557199d73cb380665b4d14517118ac567a001edcee1514691901d8192109923c0
+AUX arc-5.21o-interix.patch 341 BLAKE2B b37abfafd5d0de28ddcf0f8c5392e2e9ea6921e5a8ebfe7d0fee836fb91513964f25bd60e65f8791f642b106b614c933d607af101408872f715f93a6d89f9d5f SHA512 7e204d6d70a5f5c591012a26b498cb2899f50a207358413e164a7b4cd39776c3eab1e8026eac4ab8c86c6cc37e2fbaf8bc34657f618b2f12295c56d6d59c99c8
+DIST arc-5.21p.tar.gz 84791 BLAKE2B 3dc6c2e9c83a9021a9a865676e248278f88b3de868846b39e1b1a9365299c410e7bb3c0ed07cfd3ad1e3f6340eb0e3d21b57a7c6e8ea92f61b51a914d7e4fa0f SHA512 c70c01ec407cc27f6507e2715d8b553277609cb49369a1e65a83d007362a24b69bb09ef2bf168ee36ca6797bd4524644a89e9114d866351ae53fece193c2967c
+EBUILD arc-5.21p.ebuild 845 BLAKE2B c3fdb7752cfccd76653e7ed12fc8ccffc41bfb53d2102b646f54d60dc4608e07be997449a694b54445d25a0b0620cd56694f6b4e5a1d554467633db3893a1008 SHA512 c17f89ba7b4155aa00c0c2f3ea23249148047a312153822b5ce33f34f0e91c8afbf2f52d09369bd2366047ce6508d475b3ca9c985b069f3b1d029f2575583594
+MISC metadata.xml 356 BLAKE2B 8f18c0ad0004f2b5a4ad4d35cb420a709bdeaaba374491c58e19ceadc06b6bccdb54419cb4c93985498e9b99b33417d2cecfe26db6228cc500a407e172124f2f SHA512 22f42b35b8c8ad43bac261820902eb8fc9835c2ed1a96e75a56fc97e0732060e6354e9485458f928177f201f7f6ebd9e75c7cae9a1cff4b376b997d3c3f20d18
diff --git a/app-arch/arc/arc-5.21p.ebuild b/app-arch/arc/arc-5.21p.ebuild
new file mode 100644
index 000000000000..21daa1b15601
--- /dev/null
+++ b/app-arch/arc/arc-5.21p.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Create & extract files from DOS .ARC files"
+HOMEPAGE="http://arc.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.21m-darwin.patch
+ "${FILESDIR}"/${PN}-5.21m-gentoo-fbsd.patch
+ "${FILESDIR}"/${PN}-5.21o-interix.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i Makefile \
+ -e 's/CFLAGS = $(OPT) $(SYSTEM)/CFLAGS += $(SYSTEM)/' \
+ || die "sed Makefile"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" OPT="${LDFLAGS}"
+}
+
+src_install() {
+ dobin arc marc
+ doman arc.1
+ dodoc Arc521.doc Arcinfo Changelog Readme
+}
diff --git a/app-arch/arc/files/arc-5.21m-darwin.patch b/app-arch/arc/files/arc-5.21m-darwin.patch
new file mode 100644
index 000000000000..fb1eb5ea2598
--- /dev/null
+++ b/app-arch/arc/files/arc-5.21m-darwin.patch
@@ -0,0 +1,11 @@
+--- arc-5.21m/tmclock.c
++++ arc-5.21m/tmclock.c
+@@ -14,7 +14,7 @@
+ /* Julian day number of the Unix* clock's origin, 01 Jan 1970. */
+ #define JD1970 2440587L
+ #define CENTURY 19
+-#if BSD
++#if BSD || defined(__MACH_O__)
+ #include <sys/time.h>
+ #else
+ #include <time.h>
diff --git a/app-arch/arc/files/arc-5.21m-gentoo-fbsd.patch b/app-arch/arc/files/arc-5.21m-gentoo-fbsd.patch
new file mode 100644
index 000000000000..f2762f74b9d2
--- /dev/null
+++ b/app-arch/arc/files/arc-5.21m-gentoo-fbsd.patch
@@ -0,0 +1,12 @@
+--- a/tmclock.c
++++ b/tmclock.c
+@@ -18,8 +18,10 @@
+ #include <sys/time.h>
+ #else
+ #include <time.h>
++#ifdef timezone
+ extern long timezone; /* should be in <time.h>, but isn't on Sun */
+ #endif
++#endif
+
+ long tzone; \ No newline at end of file
diff --git a/app-arch/arc/files/arc-5.21o-interix.patch b/app-arch/arc/files/arc-5.21o-interix.patch
new file mode 100644
index 000000000000..f95aee85e37d
--- /dev/null
+++ b/app-arch/arc/files/arc-5.21o-interix.patch
@@ -0,0 +1,12 @@
+diff -ru arc-5.21o.orig/arcdos.c arc-5.21o/arcdos.c
+--- arc-5.21o.orig/arcdos.c 2008-03-30 15:44:53 +0200
++++ arc-5.21o/arcdos.c 2008-03-30 15:45:51 +0200
+@@ -30,7 +30,7 @@
+ #if UNIX
+ #include <sys/types.h>
+ #include <sys/stat.h>
+-#if BSD
++#if BSD || defined(__INTERIX)
+ #include <sys/time.h>
+ #else
+ #include <time.h> /* Sys V. Bleah. */
diff --git a/app-arch/arc/metadata.xml b/app-arch/arc/metadata.xml
new file mode 100644
index 000000000000..2909b64a9606
--- /dev/null
+++ b/app-arch/arc/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription>A program that is able to create and extract files form the DOS .ARC file</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">arc</remote-id>
+ </upstream>
+</pkgmetadata>