summaryrefslogtreecommitdiff
path: root/app-arch/aptly/aptly-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-21 20:44:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-21 20:44:55 +0100
commitaa870ba91722a8d38ba5103297a6aa4abb54e5bc (patch)
treef91c8d19a619a57e109d68ad33c2b791a35df473 /app-arch/aptly/aptly-1.5.0.ebuild
parent2480f36bfb3d39469cc44843d1fe664bd40443a3 (diff)
gentoo auto-resync : 21:07:2022 - 20:44:55
Diffstat (limited to 'app-arch/aptly/aptly-1.5.0.ebuild')
-rw-r--r--app-arch/aptly/aptly-1.5.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-arch/aptly/aptly-1.5.0.ebuild b/app-arch/aptly/aptly-1.5.0.ebuild
new file mode 100644
index 000000000000..831d99b1b2f3
--- /dev/null
+++ b/app-arch/aptly/aptly-1.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd
+
+DESCRIPTION="Debian repository management tool"
+HOMEPAGE="https://www.aptly.info/"
+
+SRC_URI="https://github.com/aptly-dev/aptly/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT Apache-2.0 BSD BSD-2 ISC MPL-2.0 WTFPL-2 ZLIB"
+RESTRICT+=" test"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ emake install
+}
+
+src_install() {
+ dobin ~/go/bin/aptly
+ dodoc README.rst
+ systemd_dounit aptly.service aptly-api.service
+}