summaryrefslogtreecommitdiff
path: root/app-arch/7zip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /app-arch/7zip
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'app-arch/7zip')
-rw-r--r--app-arch/7zip/7zip-23.01.ebuild110
-rw-r--r--app-arch/7zip/7zip-24.05.ebuild110
-rw-r--r--app-arch/7zip/7zip-24.06.ebuild110
-rw-r--r--app-arch/7zip/7zip-24.07.ebuild2
-rw-r--r--app-arch/7zip/Manifest13
-rw-r--r--app-arch/7zip/metadata.xml2
6 files changed, 4 insertions, 343 deletions
diff --git a/app-arch/7zip/7zip-23.01.ebuild b/app-arch/7zip/7zip-23.01.ebuild
deleted file mode 100644
index 0d983a22a12f..000000000000
--- a/app-arch/7zip/7zip-23.01.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit edos2unix flag-o-matic toolchain-funcs
-
-NO_DOT_PV=$(ver_rs 1- '')
-DESCRIPTION="Free file archiver for extremely high compression"
-HOMEPAGE="https://www.7-zip.org/ https://sourceforge.net/projects/sevenzip/"
-# linux-x64 tarball is only used for docs
-SRC_URI="
- https://downloads.sourceforge.net/sevenzip/7-Zip/${PV}/7z${NO_DOT_PV}-src.tar.xz
- https://downloads.sourceforge.net/sevenzip/7-Zip/${PV}/7z${NO_DOT_PV}-linux-x64.tar.xz
-"
-S="${WORKDIR}"
-
-LICENSE="LGPL-2 BSD rar? ( unRAR )"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="uasm jwasm rar"
-REQUIRED_USE="?? ( uasm jwasm )"
-
-DOCS=( readme.txt History.txt License.txt )
-HTML_DOCS=( MANUAL )
-
-DEPEND="${RDEPEND}"
-BDEPEND="
- uasm? ( dev-lang/uasm )
- jwasm? ( dev-lang/jwasm )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-respect-build-env.patch"
-)
-
-# TODO(NRK): also build and install the library
-# TODO(NRK): make it so this package can be used as a drop-in replacement
-# for app-arch/p7zip ??
-
-pkg_setup() {
- # instructions in DOC/readme.txt, Compiling 7-Zip for Unix/Linux
- # TLDR; every combination of options (clang|gcc)+(asm/noasm)
- # has a dedicated makefile & builddir
- mfile="cmpl"
- if tc-is-clang; then
- mfile="${mfile}_clang"
- bdir=c
- elif tc-is-gcc; then
- mfile="${mfile}_gcc"
- bdir=g
- else
- die "Unsupported compiler: $(tc-getCC)"
- fi
- if use jwasm || use uasm ; then
- mfile="${mfile}_x64"
- bdir="${bdir}_x64"
- fi
- export mfile="${mfile}.mak"
- export bdir
-}
-
-src_prepare() {
- # patch doesn't deal with CRLF even if file+patch match
- # not even with --ignore-whitespace, --binary or --force
- pushd "./CPP/7zip" || die "Unable to switch directory"
- edos2unix ./7zip_gcc.mak ./var_gcc{,_x64}.mak ./var_clang{,_x64}.mak
- sed -i -e 's/-Werror //g' ./7zip_gcc.mak || die "Error removing -Werror"
- popd >/dev/null || die "Unable to switch directory"
-
- default
-}
-
-src_compile() {
- pushd "./CPP/7zip/Bundles/Alone2" || die "Unable to switch directory"
-
- # avoid executable stack when using uasm/jwasm, harmless otherwise
- append-ldflags -Wl,-z,noexecstack
- export G_CFLAGS=${CFLAGS}
- export G_CXXFLAGS=${CXXFLAGS}
- export G_LDFLAGS=${LDFLAGS}
-
- local args=(
- -f "../../${mfile}"
- CC=$(tc-getCC)
- CXX=$(tc-getCXX)
- )
- # NOTE: makefile doesn't check the value of DISABLE_RAR_COMPRESS, only
- # whether it's defined or not. so in case user has `rar` enabled
- # DISABLE_RAR_COMPRESS (and DISABLE_RAR) needs to stay undefined.
- if ! use rar; then
- # disables non-free rar code but allows listing and extracting
- # non-compressed rar archives
- args+=( DISABLE_RAR_COMPRESS=1 )
- fi
- if use jwasm; then
- args+=( USE_JWASM=1 )
- elif use uasm; then
- args+=( MY_ASM=uasm )
- fi
-
- mkdir -p "${bdir}" || die # Bug: https://bugs.gentoo.org/933619
- emake ${args[@]}
- popd > /dev/null || die "Unable to switch directory"
-}
-
-src_install() {
- dobin "./CPP/7zip/Bundles/Alone2/b/${bdir}/7zz"
- einstalldocs
-}
diff --git a/app-arch/7zip/7zip-24.05.ebuild b/app-arch/7zip/7zip-24.05.ebuild
deleted file mode 100644
index 0d983a22a12f..000000000000
--- a/app-arch/7zip/7zip-24.05.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit edos2unix flag-o-matic toolchain-funcs
-
-NO_DOT_PV=$(ver_rs 1- '')
-DESCRIPTION="Free file archiver for extremely high compression"
-HOMEPAGE="https://www.7-zip.org/ https://sourceforge.net/projects/sevenzip/"
-# linux-x64 tarball is only used for docs
-SRC_URI="
- https://downloads.sourceforge.net/sevenzip/7-Zip/${PV}/7z${NO_DOT_PV}-src.tar.xz
- https://downloads.sourceforge.net/sevenzip/7-Zip/${PV}/7z${NO_DOT_PV}-linux-x64.tar.xz
-"
-S="${WORKDIR}"
-
-LICENSE="LGPL-2 BSD rar? ( unRAR )"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="uasm jwasm rar"
-REQUIRED_USE="?? ( uasm jwasm )"
-
-DOCS=( readme.txt History.txt License.txt )
-HTML_DOCS=( MANUAL )
-
-DEPEND="${RDEPEND}"
-BDEPEND="
- uasm? ( dev-lang/uasm )
- jwasm? ( dev-lang/jwasm )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-respect-build-env.patch"
-)
-
-# TODO(NRK): also build and install the library
-# TODO(NRK): make it so this package can be used as a drop-in replacement
-# for app-arch/p7zip ??
-
-pkg_setup() {
- # instructions in DOC/readme.txt, Compiling 7-Zip for Unix/Linux
- # TLDR; every combination of options (clang|gcc)+(asm/noasm)
- # has a dedicated makefile & builddir
- mfile="cmpl"
- if tc-is-clang; then
- mfile="${mfile}_clang"
- bdir=c
- elif tc-is-gcc; then
- mfile="${mfile}_gcc"
- bdir=g
- else
- die "Unsupported compiler: $(tc-getCC)"
- fi
- if use jwasm || use uasm ; then
- mfile="${mfile}_x64"
- bdir="${bdir}_x64"
- fi
- export mfile="${mfile}.mak"
- export bdir
-}
-
-src_prepare() {
- # patch doesn't deal with CRLF even if file+patch match
- # not even with --ignore-whitespace, --binary or --force
- pushd "./CPP/7zip" || die "Unable to switch directory"
- edos2unix ./7zip_gcc.mak ./var_gcc{,_x64}.mak ./var_clang{,_x64}.mak
- sed -i -e 's/-Werror //g' ./7zip_gcc.mak || die "Error removing -Werror"
- popd >/dev/null || die "Unable to switch directory"
-
- default
-}
-
-src_compile() {
- pushd "./CPP/7zip/Bundles/Alone2" || die "Unable to switch directory"
-
- # avoid executable stack when using uasm/jwasm, harmless otherwise
- append-ldflags -Wl,-z,noexecstack
- export G_CFLAGS=${CFLAGS}
- export G_CXXFLAGS=${CXXFLAGS}
- export G_LDFLAGS=${LDFLAGS}
-
- local args=(
- -f "../../${mfile}"
- CC=$(tc-getCC)
- CXX=$(tc-getCXX)
- )
- # NOTE: makefile doesn't check the value of DISABLE_RAR_COMPRESS, only
- # whether it's defined or not. so in case user has `rar` enabled
- # DISABLE_RAR_COMPRESS (and DISABLE_RAR) needs to stay undefined.
- if ! use rar; then
- # disables non-free rar code but allows listing and extracting
- # non-compressed rar archives
- args+=( DISABLE_RAR_COMPRESS=1 )
- fi
- if use jwasm; then
- args+=( USE_JWASM=1 )
- elif use uasm; then
- args+=( MY_ASM=uasm )
- fi
-
- mkdir -p "${bdir}" || die # Bug: https://bugs.gentoo.org/933619
- emake ${args[@]}
- popd > /dev/null || die "Unable to switch directory"
-}
-
-src_install() {
- dobin "./CPP/7zip/Bundles/Alone2/b/${bdir}/7zz"
- einstalldocs
-}
diff --git a/app-arch/7zip/7zip-24.06.ebuild b/app-arch/7zip/7zip-24.06.ebuild
deleted file mode 100644
index 59e13dc0c5e5..000000000000
--- a/app-arch/7zip/7zip-24.06.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit edos2unix flag-o-matic toolchain-funcs
-
-NO_DOT_PV=$(ver_rs 1- '')
-DESCRIPTION="Free file archiver for extremely high compression"
-HOMEPAGE="https://www.7-zip.org/ https://sourceforge.net/projects/sevenzip/"
-# linux-x64 tarball is only used for docs
-SRC_URI="
- https://downloads.sourceforge.net/sevenzip/7-Zip/${PV}/7z${NO_DOT_PV}-src.tar.xz
- https://downloads.sourceforge.net/sevenzip/7-Zip/${PV}/7z${NO_DOT_PV}-linux-x64.tar.xz
-"
-S="${WORKDIR}"
-
-LICENSE="LGPL-2 BSD rar? ( unRAR )"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="uasm jwasm rar"
-REQUIRED_USE="?? ( uasm jwasm )"
-
-DOCS=( readme.txt History.txt License.txt )
-HTML_DOCS=( MANUAL )
-
-DEPEND="${RDEPEND}"
-BDEPEND="
- uasm? ( dev-lang/uasm )
- jwasm? ( dev-lang/jwasm )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-24.05-respect-build-env.patch"
-)
-
-# TODO(NRK): also build and install the library
-# TODO(NRK): make it so this package can be used as a drop-in replacement
-# for app-arch/p7zip ??
-
-pkg_setup() {
- # instructions in DOC/readme.txt, Compiling 7-Zip for Unix/Linux
- # TLDR; every combination of options (clang|gcc)+(asm/noasm)
- # has a dedicated makefile & builddir
- mfile="cmpl"
- if tc-is-clang; then
- mfile="${mfile}_clang"
- bdir=c
- elif tc-is-gcc; then
- mfile="${mfile}_gcc"
- bdir=g
- else
- die "Unsupported compiler: $(tc-getCC)"
- fi
- if use jwasm || use uasm ; then
- mfile="${mfile}_x64"
- bdir="${bdir}_x64"
- fi
- export mfile="${mfile}.mak"
- export bdir
-}
-
-src_prepare() {
- # patch doesn't deal with CRLF even if file+patch match
- # not even with --ignore-whitespace, --binary or --force
- pushd "./CPP/7zip" || die "Unable to switch directory"
- edos2unix ./7zip_gcc.mak ./var_gcc{,_x64}.mak ./var_clang{,_x64}.mak
- sed -i -e 's/-Werror //g' ./7zip_gcc.mak || die "Error removing -Werror"
- popd >/dev/null || die "Unable to switch directory"
-
- default
-}
-
-src_compile() {
- pushd "./CPP/7zip/Bundles/Alone2" || die "Unable to switch directory"
-
- # avoid executable stack when using uasm/jwasm, harmless otherwise
- append-ldflags -Wl,-z,noexecstack
- export G_CFLAGS=${CFLAGS}
- export G_CXXFLAGS=${CXXFLAGS}
- export G_LDFLAGS=${LDFLAGS}
-
- local args=(
- -f "../../${mfile}"
- CC=$(tc-getCC)
- CXX=$(tc-getCXX)
- )
- # NOTE: makefile doesn't check the value of DISABLE_RAR_COMPRESS, only
- # whether it's defined or not. so in case user has `rar` enabled
- # DISABLE_RAR_COMPRESS (and DISABLE_RAR) needs to stay undefined.
- if ! use rar; then
- # disables non-free rar code but allows listing and extracting
- # non-compressed rar archives
- args+=( DISABLE_RAR_COMPRESS=1 )
- fi
- if use jwasm; then
- args+=( USE_JWASM=1 )
- elif use uasm; then
- args+=( MY_ASM=uasm )
- fi
-
- mkdir -p "${bdir}" || die # Bug: https://bugs.gentoo.org/933619
- emake ${args[@]}
- popd > /dev/null || die "Unable to switch directory"
-}
-
-src_install() {
- dobin "./CPP/7zip/Bundles/Alone2/b/${bdir}/7zz"
- einstalldocs
-}
diff --git a/app-arch/7zip/7zip-24.07.ebuild b/app-arch/7zip/7zip-24.07.ebuild
index 59e13dc0c5e5..8a1c6685947e 100644
--- a/app-arch/7zip/7zip-24.07.ebuild
+++ b/app-arch/7zip/7zip-24.07.ebuild
@@ -17,7 +17,7 @@ S="${WORKDIR}"
LICENSE="LGPL-2 BSD rar? ( unRAR )"
SLOT="0"
-KEYWORDS="~amd64 ~arm64"
+KEYWORDS="amd64 arm64"
IUSE="uasm jwasm rar"
REQUIRED_USE="?? ( uasm jwasm )"
diff --git a/app-arch/7zip/Manifest b/app-arch/7zip/Manifest
index c9da034c5db3..97c3471c5d93 100644
--- a/app-arch/7zip/Manifest
+++ b/app-arch/7zip/Manifest
@@ -1,15 +1,6 @@
AUX 7zip-23.01-respect-build-env.patch 1556 BLAKE2B fdc1993dbcdc1bac28420d82ae19906be1c9857b7e0822f87d8c40003c55182b42b2f6ebde17897c4e1b074fe518cd4dc8d1c09a7d96d8be599aed5d2d506c91 SHA512 52dc54e980a729291fcadd097c6291fe33183c81cc92e30b10f5ad9c3f7ae09d8b0d3fd483c766ed63fb977b71b28eec0a78b2d4c7c054f68bcb63b8ef57d69a
AUX 7zip-24.05-respect-build-env.patch 1428 BLAKE2B 00a6da925ca0236a423e1f82426ae81976358c30ba8b6d30b8af368aeb8e4271c443d3e401f7ea32ef6743b21c730f2ecaf78319e0bdf8c76d6a45baa8f9c1e3 SHA512 0aabff2930325553de08314bd161d2132f5c6fd3ed0363c37c961b04e16ae8b906053c0f8f9132c55760acf3ec1dbdb47f0677d618cf82d8ce8cfe6d52cb6e8d
-DIST 7z2301-linux-x64.tar.xz 1527700 BLAKE2B 35dc74f0a7a4e586ea5ae969dce72c14e0231822630d2d70f24e1c911cea0492354a258ef65096a6ce0da1510117c12466bc6cda577cdf9e8e74ede17e47f23e SHA512 d3549468de8fd161e4c9233fa0b170af1f28c74749d20f3d0eeb3873857f6c6d2cc0777d564e6a79be7cc21c9e982e10710a795320428dc51db809a8d0f9454e
-DIST 7z2301-src.tar.xz 1378588 BLAKE2B 348484b24b39db70e513fe50d79954ea0e2dd669f83e3601fa796c8f0ca4734132ca20fac8cda9b8ba550bad9146627fc0ae07056abb99028ef6d825b6a533bd SHA512 e39f660c023aa65e55388be225b5591fe2a5c9138693f3c9107e2eb4ce97fafde118d3375e01ada99d29de9633f56221b5b3d640c982178884670cd84c8aa986
-DIST 7z2405-linux-x64.tar.xz 1553872 BLAKE2B d6c0bd4eb81f4112bfe50bf6affc68021b03d059076af5519a41c8d471e978ad2b4acc8f67c650070f9d07c518741a0146579ddfb8d56fd125f6db0beece0990 SHA512 13f97236157e2761a0bf406b08fba13a1ecc6d5663fb38f8dfe3b87f3910ba34fd359d8b36bea5135319543f31ec1e210eb512ea9864d9b140c336b9e416c313
-DIST 7z2405-src.tar.xz 1486772 BLAKE2B 609c7ae8b89e56e747ebfecb25108d8918138f48f0f2ed73183c76101ddd3615aafb9eb7823be0de2a434b450587e01f476d2ed092628a311b6e4ed091e06260 SHA512 d340adfa68e818dd3d3aa411780c81532fa37b6649178b81ec3739725f83e0bc3c01744612b2d467f4d0c2cc984dd35488406d7baee185cf372acebd9c0123a7
-DIST 7z2406-linux-x64.tar.xz 1551724 BLAKE2B e4cc8141b074209b58018e6aeb4b91f140160d5d52e1fba59da2d0cfcd41c488cbfa4bda99bdedd4915ca3c3bcca50e7f7f4289f44ce120577c8b632d2f7bf07 SHA512 fce2b8e9f26f092209613dc058a267ddf24c474a80b7e9837014fdaeab53bb892b7181561ca90048ca593fe29e010b8221e078c9c3ab9815baf23bc9caf3e829
-DIST 7z2406-src.tar.xz 1487008 BLAKE2B 0f8dd19a031520a9c233725e376bca06c91b9b513bc802a54b92ea046ae3dda69a293561938a1e4467d01333d46427bfee7a055c8b62cab7a9d04cf8262fe4eb SHA512 02c6d7d045ba0dc0e8533f471f3c138f0d6549b59594095cb81a2f0e602627bd6a49df3fd680e21400a908006121ff7ba370086db9bde639f79b821bb4c9707a
DIST 7z2407-linux-x64.tar.xz 1554932 BLAKE2B 9229fdac09148c50032656743aba0f8ce1ec06b7fd2dad2c693dc299c5f83fc093ba047e9c3c3971bf4cc9387b0db52c84167202ed7fcecfcc6f5bc508d04ada SHA512 31b5bb832e73f3c2fd0437873fe6130b8d1bd1bea8320d1b27d06bf40dd737758732eb3664fab2c36417b96ffc5daca6607b6f1aefdaa9e697122da60e37a728
DIST 7z2407-src.tar.xz 1488556 BLAKE2B 42b4f9553aaa4797e80a2d50073ff0e77b5261e50766f8c596a632fb013ac1514a2963f27b924485f07728d13a4536c69911867e3728e8f8604ec25fc4c6824e SHA512 0299e5c1e1dfd33ecf22077f812da1f25bf2146a713c7a7e2498d639520f21f029e853914e66a84d1edfc5d721e1f3d914a3171ab336a406a94bc82d5b2d8e5d
-EBUILD 7zip-23.01.ebuild 2960 BLAKE2B 9abf731f224a0cf143bcb0d11c21ccbb66a1e1f5456872c48f9ed14ed7ef1fbc46588fdcdb5d9fb10bb5f74f7322de6724f73f58db9fdbdc2c0d13b7fe0bb403 SHA512 ed752a84f6db6670a4136c35f1e932b9f141bcd169c7c608a719fe4bf6a931afad98ea620cfd72aade5fb99f853885e72febaabc1dd1e43d48284cc1bfab45a3
-EBUILD 7zip-24.05.ebuild 2960 BLAKE2B 9abf731f224a0cf143bcb0d11c21ccbb66a1e1f5456872c48f9ed14ed7ef1fbc46588fdcdb5d9fb10bb5f74f7322de6724f73f58db9fdbdc2c0d13b7fe0bb403 SHA512 ed752a84f6db6670a4136c35f1e932b9f141bcd169c7c608a719fe4bf6a931afad98ea620cfd72aade5fb99f853885e72febaabc1dd1e43d48284cc1bfab45a3
-EBUILD 7zip-24.06.ebuild 2967 BLAKE2B f94c9ea2760fe533c5d2e5435f82297220d9257c09880e44ba94b1160c7de4bece261e278d9c53b8669d096cd9b0adb916d6b0dc368131d02266c97bc71415d6 SHA512 4738a2b71e36968d9c0f39d685d2da168781f0e5b38ca35c0db37bc5bd9465597a47b818f777520189fad5546d53137b667ebc18d030b2eb7d75e7bfb361ea56
-EBUILD 7zip-24.07.ebuild 2967 BLAKE2B f94c9ea2760fe533c5d2e5435f82297220d9257c09880e44ba94b1160c7de4bece261e278d9c53b8669d096cd9b0adb916d6b0dc368131d02266c97bc71415d6 SHA512 4738a2b71e36968d9c0f39d685d2da168781f0e5b38ca35c0db37bc5bd9465597a47b818f777520189fad5546d53137b667ebc18d030b2eb7d75e7bfb361ea56
-MISC metadata.xml 967 BLAKE2B 5b54d1cc757cdc63407a51587389f9db032ae141fd9e19423185fd457f50c469ceb53095b128d8c6cd751cf3f0a87703dd36ba5d048dbfe9bea0ccd2354168b2 SHA512 c8c53c995f4bb5982461fa16dd50193f48c59aa15076bd78e38ccc4f0abf2190bf2b143df50e1c7911bd7814bd2ecb34892ee818b328764a9ff4ab2429718d37
+EBUILD 7zip-24.07.ebuild 2965 BLAKE2B d6ed142847bc95eac5d209cc03cc3ecfaeddce00fc7762af2fe6a664e73bb3ccc8cbbe62c9c9c3bd4806de28865a57ab6389e053dc6b801d447ca63488d56d41 SHA512 e09bc90a699912c4d8693b716da524cafcfa42a7aababead9a0d44a19dbee8b2076a393256c2dd18716b265a426cbcc30cf21ab24fe90c14aaec6baed7eaea48
+MISC metadata.xml 968 BLAKE2B cc816cf086d296a591c2ae494022f35102570c8823ccdc5ada3dde2a83d515060b703d283d74ebd00738f28a0fb4dd8fdeaea10ae9168423dcf146034561f213 SHA512 e4d71bc79b0e6d4435442e74256550f93815b68142cdac763fed9a22bd5e92c25ba288d94738316d726c2073f4f86dcf00f3d77c65a02b0e06ea3c1dc7699cbb
diff --git a/app-arch/7zip/metadata.xml b/app-arch/7zip/metadata.xml
index a4f1984333a5..772c93a14f12 100644
--- a/app-arch/7zip/metadata.xml
+++ b/app-arch/7zip/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person" proxied="yes">
<email>nrk@disroot.org</email>