summaryrefslogtreecommitdiff
path: root/app-antivirus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-03 11:25:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-03 11:25:07 +0100
commitf6a034d922bf54efeaa781fcb5388b325b90d945 (patch)
treeb9fafda6cf44bf7b09de2c3d74090de10f9cde04 /app-antivirus
parent007b0aae027279095b8605c214b535e59df8f6eb (diff)
gentoo auto-resync : 03:05:2023 - 11:25:06
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/Manifest.gzbin884 -> 884 bytes
-rw-r--r--app-antivirus/fangfrisch/Manifest2
-rw-r--r--app-antivirus/fangfrisch/fangfrisch-1.6.1.ebuild77
3 files changed, 79 insertions, 0 deletions
diff --git a/app-antivirus/Manifest.gz b/app-antivirus/Manifest.gz
index 883cc982a0e9..2d5585504603 100644
--- a/app-antivirus/Manifest.gz
+++ b/app-antivirus/Manifest.gz
Binary files differ
diff --git a/app-antivirus/fangfrisch/Manifest b/app-antivirus/fangfrisch/Manifest
index cfd0b52b92a4..b228155c508e 100644
--- a/app-antivirus/fangfrisch/Manifest
+++ b/app-antivirus/fangfrisch/Manifest
@@ -3,5 +3,7 @@ AUX fangfrisch.cron 170 BLAKE2B b2b3572bb468942eecc006749710900bb19e29d40ad444a4
AUX fangfrisch.service 347 BLAKE2B d7c36538bc8c96bd9f31cbfbba5e26572557cd87567b7c0aec1e6d4d6041194531a8da3ca831ba11f7df3558754e4bd965e03a5ae06ed8cadb9617b28028dbcf SHA512 e296b4c2f81754650845ed9ad9bd655cc81c2e59843508da5eca07d808a50a9bad5a3972f4f55ef4b97652d5f2f0c8d4e3b0cc63c7e38cc27074801e98961bcc
AUX fangfrisch.timer 212 BLAKE2B debdcfa78e9583aa490be4e6c91834e134e1680b0f0f1284046f5ac611fa77878e0258f92e4f99ae2c4616b57a6a240b6be797c2e36308a218983e51dbf20848 SHA512 1e5d5cf39bddd7527350ef5f2fa7b1e3018ca32b3f0b2d0df4d31184eef11c811b1c0111f547b4174e1a550ffeee73f5c7215da8c381edb0cccf71887c77f8ff
DIST fangfrisch-1.5.0.tar.gz 115352 BLAKE2B 2c8ed5484255e336a960285f4eb13180691b2e4da0260f6ed2d1308575f5104cb79602c6c5bda93d2889dfdf24817748560376c9e13e6071810d9246b6120724 SHA512 cb15933d0cacc0912e7f1f103a213e277905a40ff4f7fe818c60d28c2ce92377aaea77b413f55f0ae8701e41eb35bcb2c3b3e04c624a6a57533ca621f93e00f5
+DIST fangfrisch-1.6.1.gh.tar.gz 113497 BLAKE2B a37b5b29b31a1d0166112b8939e691acc1721a91bda9e364a90c0c8d4ea7b7d3e1a24b8849c9ef4f0632996ed7bbdfc7985ab04c44c8ca4d57df21294867fd32 SHA512 a16b39b6520d80f69c561bc2d56fef28acaca35a9da214be920cdd907f76d3d6674ed4aa1290ad11a9364ede11472594d7e331ecd21924fe23e005ef9501d4ac
EBUILD fangfrisch-1.5.0-r1.ebuild 1950 BLAKE2B b26650f5f2f8f6bedd50b4bb5abc696529078bd3332e325220d72119dff730c429798668008152751204a8a459b054b0306b5e5e6ab6ff380b80b4be3574b9f4 SHA512 fd332da696765fdf584cce62f697baa3a3d0f65c6e62755828af1d9f568227d157061265a146d0a32a744eba03d59a7f4a2fc629040f99668c61b69c55fc3efb
+EBUILD fangfrisch-1.6.1.ebuild 1993 BLAKE2B 5e39d8aff44b09c8db71c2864e8a6b08d784c1994e85c1f664eaab9fba56b19b2168ff4b67e2b7ff6400645d0dd20c864945faf036c2003c1cae80799494f0b6 SHA512 8f9002e6513466b9cb4ecc97b5d37e49ca81acad34ee906a4169f959b58a4b973cc8939e3f10c8a053547b77303513b25220b7d728c8d2f754d9b8c8eaee19fa
MISC metadata.xml 692 BLAKE2B 3896ef038265830e10720cde6131e2809084ea45302fee78ab5bba304cd56d5732b708e92119b37fa041d5a9bbd72ded926913a1ba7e4cc93ee7f2f310a53f19 SHA512 ac7bf47c11d46a81f1a81df4572b9592a5b12867db6797b7def523f73cde8b2f541e5dc8e59ff59b2b3e2cf7ba0fdc0ff5e7270913dd9b7bc718fa3e1b010771
diff --git a/app-antivirus/fangfrisch/fangfrisch-1.6.1.ebuild b/app-antivirus/fangfrisch/fangfrisch-1.6.1.ebuild
new file mode 100644
index 000000000000..f7a0fa269684
--- /dev/null
+++ b/app-antivirus/fangfrisch/fangfrisch-1.6.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 readme.gentoo-r1 systemd
+
+DESCRIPTION="Update and verify unofficial Clam Anti-Virus signatures"
+HOMEPAGE="https://github.com/rseichter/fangfrisch https://pypi.org/project/fangfrisch/"
+SRC_URI="https://github.com/rseichter/fangfrisch/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+MY_CONF="/etc/${PN}.conf"
+MY_DBDIR="/var/lib/${PN}"
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="See https://rseichter.github.io/fangfrisch/ for the official
+documentation.
+
+### Fresh installations:
+
+Modify ${MY_CONF} according to your preferences.
+Assuming you place the database into ${MY_DBDIR}
+(recommended), execute the following commands in a root shell:
+
+mkdir -m 0770 ${MY_DBDIR}
+chgrp clamav ${MY_DBDIR}
+sudo -u clamav -- fangfrisch -c ${MY_CONF} initdb
+
+You can now enable /etc/cron.d/${PN} for periodic updates.
+
+### Alternative: Updating from release 1.0.1:
+
+Either create a fresh database or manually delete all existing
+database tables, then run the initdb command as shown above."
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Due to the nature of Fangfrisch, most tests require network
+# connectivity and/or access keys to download signature files.
+PROPERTIES="test_network"
+RESTRICT="test"
+
+DEPEND="
+ >=dev-python/requests-2.22.0[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.4.0[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -i -e '/SQLAlchemy/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ insinto /etc
+ doins "${FILESDIR}/${PN}.conf"
+
+ insinto /etc/cron.d
+ newins "${FILESDIR}/${PN}.cron" ${PN}
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_dounit "${FILESDIR}/${PN}.timer"
+
+ distutils-r1_python_install_all
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ FORCE_PRINT_ELOG=1 readme.gentoo_print_elog
+}