summaryrefslogtreecommitdiff
path: root/app-antivirus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /app-antivirus
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/Manifest.gzbin724 -> 724 bytes
-rw-r--r--app-antivirus/clamav/Manifest2
-rw-r--r--app-antivirus/clamav/clamav-0.104.0-r1.ebuild25
3 files changed, 20 insertions, 7 deletions
diff --git a/app-antivirus/Manifest.gz b/app-antivirus/Manifest.gz
index 80da6340a6bf..50ab57ce800c 100644
--- a/app-antivirus/Manifest.gz
+++ b/app-antivirus/Manifest.gz
Binary files differ
diff --git a/app-antivirus/clamav/Manifest b/app-antivirus/clamav/Manifest
index 716d13e996e6..3673d863717c 100644
--- a/app-antivirus/clamav/Manifest
+++ b/app-antivirus/clamav/Manifest
@@ -21,5 +21,5 @@ AUX tmpfiles.d/clamav.conf 33 BLAKE2B 447c5ad4ad79bc70fc386833fa763451d30bf30f1a
DIST clamav-0.103.3.tar.gz 13389239 BLAKE2B 1846cceed39fbd48fcf973d05a57901cf6f9ccdbb4d7eae501e712d84ab4d0a662e4477696aa6a1446116db85a89603428d7092a55e18f7acb805016d3cd5431 SHA512 c2ee24a6f63735c064140aa5baa347d51e8240b2f7eced3480d05435202aedd481fa7057fd40ecbc2e93a62fe8b0cefb574d8accdf9acede643ffbe0d396686f
DIST clamav-0.104.0.tar.gz 11896747 BLAKE2B c3ca32c1277052301a8bff94fec66a2df8f589bc9a673a00d0f45aaf9d8fd23e8bb87dde787d4188a6318d6677c3364e377ccec16d8e44667430713ce7e2a78d SHA512 7a052e6310ef92068acc384d10a64eed6d54d2d408d203dab92defbb1a276e8a193a2096a8028c8982323ba0be83d25602f026aeffa056878ce36aa325c0046c
EBUILD clamav-0.103.3-r1.ebuild 7405 BLAKE2B 48038b8bb6c1b1f045b24ae7d955226389a121604e2e4212c6eb81ce6c9aa9eea2a4ecd7d82409d2cf01dfc4c6fedee5d7188a6dbd9f0cd88546b6a35facd51c SHA512 0f19466145c340ddf7473876443c18e10b73b607c3b8b48bda31ad0740fa0835d2f21fd546bb7e9facb03fab2f792ab2343c9965064b6a17eca9eaafcb8d6fe6
-EBUILD clamav-0.104.0-r1.ebuild 6531 BLAKE2B 9923cbb70a35a4a720c2034d610806614254fdad24fcb5accced8d1b0884eaf38e074e1d090f300145ca2de22894eda1a9d6fc55099adcc987ea5d8067618512 SHA512 9f233777906a7492ec18f2cedee16dbc578bbf808a64255a71a9d9c309d1675a1f6160df536d1000513b57883b7627917c6e8e1855953ac2762c424be9e3ccd2
+EBUILD clamav-0.104.0-r1.ebuild 6957 BLAKE2B 41e79ef3f9f2b637b42d84d5c8e0fe544a12bce1a188fd5187665f3aaca41b4bb2b3073147fe47acce4be21dce5fad0562426d93e14e3b8e9c9ea00701002871 SHA512 7e2383602f56ccb36a912b9184ad609037cb2800b60b8c3adbcd4e236f23b7ad47c4ff062a5547e3218ed1e06d3faf0f122d83960393a9d083529c0f4e3dd3ef
MISC metadata.xml 1287 BLAKE2B 75d0e2ee639919863a0b12951c04f6338fab836812a930b5cae82adc9546f0d9115c1c12a233b08e7bcf1810b38f8d0c119ee44a7640ade191f9bdb5c2bdf759 SHA512 2ef5d16db72356b72cfe6334b5a9b6c6e4d491ab445debbf9433d44c843e27d03aade9cc49a4fcad151ecfbb3dc4d99903e5a27eac8954991822eca3bad2b6c0
diff --git a/app-antivirus/clamav/clamav-0.104.0-r1.ebuild b/app-antivirus/clamav/clamav-0.104.0-r1.ebuild
index ee0e19b95004..e78447e51d55 100644
--- a/app-antivirus/clamav/clamav-0.104.0-r1.ebuild
+++ b/app-antivirus/clamav/clamav-0.104.0-r1.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-inherit cmake flag-o-matic systemd tmpfiles
+PYTHON_COMPAT=( python3_{8..10} )
+inherit cmake flag-o-matic python-any-r1 systemd tmpfiles
DESCRIPTION="Clam Anti-Virus Scanner"
HOMEPAGE="https://www.clamav.net/"
@@ -44,7 +45,11 @@ CDEPEND="acct-group/clamav
# TODO: there is no way to use this with the new build system instead of the bundled one
# dev-libs/tomsfastmath
BDEPEND="virtual/pkgconfig
- doc? ( app-doc/doxygen )"
+ doc? ( app-doc/doxygen )
+ test? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
+ )"
DEPEND="${CDEPEND}
test? ( dev-libs/check )"
RDEPEND="${CDEPEND}
@@ -54,6 +59,14 @@ PATCHES=(
"${FILESDIR}/${PN}-0.104.0-ncurses_detection.patch"
)
+python_check_deps() {
+ has_version -b "dev-python/pytest[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
src_configure() {
use elibc_musl && append-ldflags -lfts
use ppc64 && append-flags -mminimal-toc
@@ -76,6 +89,10 @@ src_configure() {
-DENABLE_DOXYGEN=$(usex doc)
-DENABLE_UNRAR=$(usex rar ON OFF)
-DENABLE_TESTS=$(usex test ON OFF)
+ # Used to enable some more tests but doesn't behave well in
+ # sandbox necessarily(?) + needs certain debug symbols present
+ # in e.g. glibc.
+ -DCMAKE_DISABLE_FIND_PACKAGE_Valgrind=ON
-DENABLE_STATIC_LIB=OFF
-DENABLE_SHARED_LIB=ON
-DENABLE_SYSTEMD=$(usex systemd ON OFF)
@@ -177,10 +194,6 @@ src_install() {
find "${ED}" -name '*.la' -delete || die
}
-src_test() {
- emake quick-check
-}
-
pkg_postinst() {
if ! use libclamav-only ; then
if use systemd ; then