summaryrefslogtreecommitdiff
path: root/app-alternatives
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-06 21:11:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-06 21:11:24 +0000
commitd479c9c5c724c7b1300a98e44975f31f4f2e51dd (patch)
treec2f5550bfe03e1b3f19014e1576dcf50e6bd818c /app-alternatives
parentee8ad1509f726e8fa598472117e5bbffd241ebab (diff)
gentoo auto-resync : 06:12:2022 - 21:11:24
Diffstat (limited to 'app-alternatives')
-rw-r--r--app-alternatives/Manifest.gzbin1680 -> 1675 bytes
-rw-r--r--app-alternatives/bc/Manifest2
-rw-r--r--app-alternatives/bc/bc-0.ebuild37
-rw-r--r--app-alternatives/cpio/Manifest2
-rw-r--r--app-alternatives/cpio/cpio-0.ebuild37
-rw-r--r--app-alternatives/gzip/Manifest2
-rw-r--r--app-alternatives/gzip/gzip-0.ebuild47
-rw-r--r--app-alternatives/lex/Manifest2
-rw-r--r--app-alternatives/lex/lex-0-r1.ebuild42
-rw-r--r--app-alternatives/tar/Manifest2
-rw-r--r--app-alternatives/tar/tar-0.ebuild37
-rw-r--r--app-alternatives/yacc/Manifest2
-rw-r--r--app-alternatives/yacc/yacc-1-r2.ebuild60
13 files changed, 118 insertions, 154 deletions
diff --git a/app-alternatives/Manifest.gz b/app-alternatives/Manifest.gz
index 8f987715b105..b4f9b38bd53f 100644
--- a/app-alternatives/Manifest.gz
+++ b/app-alternatives/Manifest.gz
Binary files differ
diff --git a/app-alternatives/bc/Manifest b/app-alternatives/bc/Manifest
index d1a21b432619..e2d13ce8ffb4 100644
--- a/app-alternatives/bc/Manifest
+++ b/app-alternatives/bc/Manifest
@@ -1,2 +1,2 @@
-EBUILD bc-0.ebuild 1011 BLAKE2B ff9630287381e9ef8228da88aa681ca5736c77b0d8d4c061fc8d9484aaef2ad90511313ad8334e8dc35b89543d7e769c3732c4b5cd2f05204c8e3aa3ededa7ee SHA512 fb496069280243abe6c6a9998b96a34b1a6efdbf7a03c88f48cc8a8bcbfcf4557440d0a9f68902cab5ecf12456dfbc76f8df63f83587ad8ea391f8035feaae39
+EBUILD bc-0.ebuild 738 BLAKE2B d52a3e8f4767721f834706648018d24e88e800ed45f331c5a477b8343c1d644d9749d92b6069bcc8deea15d5d7b06efee76ab66fa74b8b8704e1e5860c347361 SHA512 ac29861da38fda94db2fb32645242ae20738fc1cb21ef749b78c8e98804c8ca41010737da8352c9ce5695a037ddbca764696dfb24f94bc7088bf83394cf3b106
MISC metadata.xml 545 BLAKE2B ad10ffcda18dbd1728a7f63f504d4ecd8c3c864c7c3265416c8060bb8e685030e48df6d7e784083ee0d587b57f91be9b1e1401569880458b0c40e3fea63f4f5c SHA512 4a95c94b8a5f6f14171cccaacad08207570550d826f232033f581b8a974d095f73f2c3c0f70c3fd41d33507a7fa8644751724702b75467ae394edb39a44fd404
diff --git a/app-alternatives/bc/bc-0.ebuild b/app-alternatives/bc/bc-0.ebuild
index 1befe0bb8fa5..95732aa6d6b7 100644
--- a/app-alternatives/bc/bc-0.ebuild
+++ b/app-alternatives/bc/bc-0.ebuild
@@ -3,35 +3,26 @@
EAPI=8
-DESCRIPTION="bc symlink"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Base/Alternatives"
-SRC_URI=""
-S=${WORKDIR}
+ALTERNATIVES=(
+ "gnu:>=sys-devel/bc-1.07.1-r6"
+ gh:sci-calculators/bc-gh
+)
+
+inherit app-alternatives
-LICENSE="CC0-1.0"
-SLOT="0"
+DESCRIPTION="bc symlink"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="+gnu gh"
-REQUIRED_USE="^^ ( gnu gh )"
RDEPEND="
- gnu? ( >=sys-devel/bc-1.07.1-r6 )
- gh? ( sci-calculators/bc-gh )
!<sys-devel/bc-1.07.1-r6
"
src_install() {
- if use gnu; then
- dosym bc-reference /usr/bin/bc
- dosym dc-reference /usr/bin/dc
- newman - bc.1 <<<".so bc-reference.1"
- newman - dc.1 <<<".so dc-reference.1"
- elif use gh; then
- dosym bc-gh /usr/bin/bc
- dosym dc-gh /usr/bin/dc
- newman - bc.1 <<<".so bc-gh.1"
- newman - dc.1 <<<".so dc-gh.1"
- else
- die "Invalid USE flag combination (broken REQUIRED_USE?)"
- fi
+ local suffix=$(get_alternative)
+ [[ ${suffix} == gnu ]] && suffix=reference
+
+ dosym "bc-${suffix}" /usr/bin/bc
+ dosym "dc-${suffix}" /usr/bin/dc
+ newman - bc.1 <<<".so bc-${suffix}.1"
+ newman - dc.1 <<<".so dc-${suffix}.1"
}
diff --git a/app-alternatives/cpio/Manifest b/app-alternatives/cpio/Manifest
index 28ae65faaba6..8706e79b3d01 100644
--- a/app-alternatives/cpio/Manifest
+++ b/app-alternatives/cpio/Manifest
@@ -1,2 +1,2 @@
-EBUILD cpio-0.ebuild 985 BLAKE2B e62476f5bb7312e58f5ef3a2b2162a2c7b6971dcbca36a6129be3c7e27a367e735cc1dd7b0ca75438c29e21988f4b5365ca3c426eb11c96bfa6f8fef736b3047 SHA512 fb9cff72535814ceb9d1af6da22298383adf64bca30e7cbe9ee331648e7cc9e9d8064795c7dea3702460fbe24dde94ae92991beca84eb4499ec91ec80747b5d9
+EBUILD cpio-0.ebuild 806 BLAKE2B c4d997392d86b3a0e06dccc69e2d087b97bdcc17d61cb8d3e821b018aa7dc5838166e5bae1c7b9bf7a6705821e34ab09049b47296b46d630e7690fc68d809a53 SHA512 aa11fda24bd92506290804ffc0fbfedb31d2f17361ba007eb433bbb2ddcc82ef9afe844a2d0652511c131b8f17c9872ed0132cc60cbe03981ea75554cfa5676c
MISC metadata.xml 556 BLAKE2B 50f93b411b7b21af21a4d071bba8533ed58c6ff5bfa1f18bf6025c1c11dfea1be089777f3e59972c72deefcfb54bedc2065f188e0b75c369bb683b9a17ece639 SHA512 7db5fac74ffcbe3344a06f5a9f5360c07648aac7b5080985b110f2b072412ead598ac5bbc5c2f48bd15077e1bc11e36fc8491a7bb898a761f8c6977a753f067a
diff --git a/app-alternatives/cpio/cpio-0.ebuild b/app-alternatives/cpio/cpio-0.ebuild
index 20af68ac0123..0bdeb6da6b2f 100644
--- a/app-alternatives/cpio/cpio-0.ebuild
+++ b/app-alternatives/cpio/cpio-0.ebuild
@@ -3,20 +3,18 @@
EAPI=8
-DESCRIPTION="CPIO symlink"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Base/Alternatives"
-SRC_URI=""
-S=${WORKDIR}
+ALTERNATIVES=(
+ "gnu:>=app-arch/cpio-2.13-r4"
+ libarchive:app-arch/libarchive
+)
+
+inherit app-alternatives
-LICENSE="CC0-1.0"
-SLOT="0"
+DESCRIPTION="CPIO symlink"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="+gnu libarchive split-usr"
-REQUIRED_USE="^^ ( gnu libarchive )"
+IUSE="split-usr"
RDEPEND="
- gnu? ( >=app-arch/cpio-2.13-r4 )
- libarchive? ( app-arch/libarchive )
!<app-arch/cpio-2.13-r4
"
@@ -24,13 +22,14 @@ src_install() {
local usr_prefix=
use split-usr && usr_prefix=../usr/bin/
- if use gnu; then
- dosym gcpio /bin/cpio
- newman - cpio.1 <<<".so gcpio.1"
- elif use libarchive; then
- dosym "${usr_prefix}bsdcpio" /bin/cpio
- newman - cpio.1 <<<".so bsdcpio.1"
- else
- die "Invalid USE flag combination (broken REQUIRED_USE?)"
- fi
+ case $(get_alternative) in
+ gnu)
+ dosym gcpio /bin/cpio
+ newman - cpio.1 <<<".so gcpio.1"
+ ;;
+ libarchive)
+ dosym "${usr_prefix}bsdcpio" /bin/cpio
+ newman - cpio.1 <<<".so bsdcpio.1"
+ ;;
+ esac
}
diff --git a/app-alternatives/gzip/Manifest b/app-alternatives/gzip/Manifest
index 2e003e8b62ab..56a89830e4db 100644
--- a/app-alternatives/gzip/Manifest
+++ b/app-alternatives/gzip/Manifest
@@ -1,2 +1,2 @@
-EBUILD gzip-0.ebuild 1269 BLAKE2B e1bb6a3ad0fe76590937e5be1558aa6d3f5769812df813c10c7dc3b6351f6ab4a622703cdfabaf7fa9aa55f48a082e53bc81d338f8ed9b612d2319e9dc64b759 SHA512 604814007334d62429b28ada0097d9d329e5ce9a974afafd151642d5a1ef88bfcf2b1447f7e1db819665e3f50399ec80d646028be8df87a088e1f1cdc2d7ae50
+EBUILD gzip-0.ebuild 1097 BLAKE2B e4da2779aaeedd2fd0ded0f05c37fc8e184c41004c56903e779615d32a3792dae97e46adc925a28a8a3e5658c6c61c98cd924a3750291417ce5c439a00499fc7 SHA512 00499b7b2ae9130459c936d1b37700521456adee8f64105c9f20b150d8532677525eb7947b63d2b5b57b75f874eaa576f41fae69207bd3690ea231bce078d88d
MISC metadata.xml 528 BLAKE2B 099aec3cb340caeedc0fc6e2f62162baf276b1262b4758dd39695a03ee5110c717a9b553190762c939171d7776b2048fe73c1fc7a966eef916e992abeed0ec21 SHA512 e654f8d548769c00425cd9a3f796c17af28300ea297294b335166f023164a5696216135badc82074b6a88669114f7db819af827aad8144987c7cfc7a474a2191
diff --git a/app-alternatives/gzip/gzip-0.ebuild b/app-alternatives/gzip/gzip-0.ebuild
index 29e0808da453..77090242607d 100644
--- a/app-alternatives/gzip/gzip-0.ebuild
+++ b/app-alternatives/gzip/gzip-0.ebuild
@@ -3,20 +3,18 @@
EAPI=8
-DESCRIPTION="gzip symlinks"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Base/Alternatives"
-SRC_URI=""
-S=${WORKDIR}
+ALTERNATIVES=(
+ "reference:>=app-arch/gzip-1.12-r3"
+ "pigz:app-arch/pigz[-symlink(-)]"
+)
+
+inherit app-alternatives
-LICENSE="CC0-1.0"
-SLOT="0"
+DESCRIPTION="gzip symlinks"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="pigz +reference split-usr"
-REQUIRED_USE="^^ ( pigz reference )"
+IUSE="split-usr"
RDEPEND="
- pigz? ( app-arch/pigz[-symlink(-)] )
- reference? ( >=app-arch/gzip-1.12-r3 )
!<app-arch/gzip-1.12-r3
!app-arch/pigz[symlink(-)]
"
@@ -25,20 +23,21 @@ src_install() {
local usr_prefix=
use split-usr && usr_prefix=../usr/bin/
- if use pigz; then
- dosym "${usr_prefix}pigz" /bin/gzip
- dosym gzip /bin/gunzip
- dosym gzip /bin/zcat
- newman - gzip.1 <<<".so pigz.1"
- elif use reference; then
- dosym gzip-reference /bin/gzip
- # gzip uses shell wrappers rather than argv[0]
- dosym gunzip-reference /bin/gunzip
- dosym zcat-reference /bin/zcat
- newman - gzip.1 <<<".so gzip-reference.1"
- else
- die "Invalid USE flag combination (broken REQUIRED_USE?)"
- fi
+ case $(get_alternative) in
+ pigz)
+ dosym "${usr_prefix}pigz" /bin/gzip
+ dosym gzip /bin/gunzip
+ dosym gzip /bin/zcat
+ newman - gzip.1 <<<".so pigz.1"
+ ;;
+ reference)
+ dosym gzip-reference /bin/gzip
+ # gzip uses shell wrappers rather than argv[0]
+ dosym gunzip-reference /bin/gunzip
+ dosym zcat-reference /bin/zcat
+ newman - gzip.1 <<<".so gzip-reference.1"
+ ;;
+ esac
newman - gunzip.1 <<<".so gzip.1"
newman - zcat.1 <<<".so gzip.1"
diff --git a/app-alternatives/lex/Manifest b/app-alternatives/lex/Manifest
index 1a914a4eac08..b773b5d920f6 100644
--- a/app-alternatives/lex/Manifest
+++ b/app-alternatives/lex/Manifest
@@ -1,2 +1,2 @@
-EBUILD lex-0-r1.ebuild 978 BLAKE2B 93903295210aecbb2d531abaca2ccbeef50db315dd79458c677e581e11343ca6cb9bfd48c22e5d597398725710298b99f20f7a343e5f16def605d425bfbcbddd SHA512 9c8631dd1b68fa26e75ea8a3322e4aca0a5bef6eaee78c9cf87e78702ccf718a92efcd191c1712e375bdd3474d37d030484c0a80a666351c603067ef4eb4c6bf
+EBUILD lex-0-r1.ebuild 655 BLAKE2B 557b894294a8316b5db3d8fcb94ac27d577a3c3406dd856eee1903fa7b3c270d57457d91f92052eca40f8da52575831328c4e021858f61789af758def7162b7e SHA512 9c518be1738c8b5a2ed5b7e2af8cd0a01640fd481b1a0c4ae499d002b205a02e39465ed9f80bdb1d104d638898856bd15255dc74c762efe0eb43574928a148a0
MISC metadata.xml 529 BLAKE2B 6873948a644263911a6e796fde57e41b69c108e3ec01b9c07a120c1786250a9718f4d736fb5918be27c9b72ee36cf5cab4621478f2917f9bcd45f6276a7e645d SHA512 d48d002ecfba6746fcea824310b738f7839c744e7bfbb4ca95c3c037258103f30dedfb8ca2284d21e6bd56910bc5e9618f8b9351a7f7e290850ae06034e37f3a
diff --git a/app-alternatives/lex/lex-0-r1.ebuild b/app-alternatives/lex/lex-0-r1.ebuild
index 5533e1623d7a..3dc442185fd9 100644
--- a/app-alternatives/lex/lex-0-r1.ebuild
+++ b/app-alternatives/lex/lex-0-r1.ebuild
@@ -3,39 +3,27 @@
EAPI=8
-DESCRIPTION="lex symlinks"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Base/Alternatives"
-SRC_URI=""
-S=${WORKDIR}
+ALTERNATIVES=(
+ "flex:>=sys-devel/flex-2.6.4-r5"
+ reflex:sys-devel/reflex
+)
+
+inherit app-alternatives
-LICENSE="CC0-1.0"
-SLOT="0"
+DESCRIPTION="lex symlinks"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="+flex reflex"
-REQUIRED_USE="^^ ( flex reflex )"
RDEPEND="
- flex? ( >=sys-devel/flex-2.6.4-r5 )
- reflex? ( sys-devel/reflex )
!<sys-devel/flex-2.6.4-r5
"
src_install() {
- if use flex; then
- dosym flex /usr/bin/lex
- newman - lex.1 <<<".so flex.1"
-
- newenvd - 90lex <<-EOF
- LEX=flex
- EOF
- elif use reflex; then
- dosym reflex /usr/bin/lex
- newman - lex.1 <<<".so reflex.1"
-
- newenvd - 90lex <<-EOF
- LEX=reflex
- EOF
- else
- die "Invalid USE flag combination (broken REQUIRED_USE?)"
- fi
+ local alt=$(get_alternative)
+
+ dosym "${alt}" /usr/bin/lex
+ newman - lex.1 <<<".so ${alt}.1"
+
+ newenvd - 90lex <<-EOF
+ LEX=${alt}
+ EOF
}
diff --git a/app-alternatives/tar/Manifest b/app-alternatives/tar/Manifest
index fcb52a0cfa7d..ca1e5019eba0 100644
--- a/app-alternatives/tar/Manifest
+++ b/app-alternatives/tar/Manifest
@@ -1,2 +1,2 @@
-EBUILD tar-0.ebuild 974 BLAKE2B d5d055490853c5f9f19d75d04b22c2be9b01f786cead03e83bbe91c23604c661011738bfc1afb0003d5122b587cd3a4744f704b18f4b324243cbefbda9e19160 SHA512 4dbaf848070bed5446c03b6f0e6fb305f8eeddf5b3e3fe16183b301ac2af46c276e69586e17d27e417c17dbb5251b75046a0d860b1409c94cae0873332def234
+EBUILD tar-0.ebuild 795 BLAKE2B a65c06bae9aac320d154c462f80cf983226496691361f2dd628ca79aacf7040dcde70205eb24da9b73571120c283068a8544ce2f9f25b622e8ce61dc753e7f07 SHA512 39515c17467eebdc3af4cfcd155ef80d08ebf145cb5792d5a0c4e75f57eebfceea6abead1412ccbd741ba091ba7d33a531b06c495e2303fab123834229c9e5f5
MISC metadata.xml 553 BLAKE2B 084e137dd7317424c0d3555fd867ae581bb3b629705e5be59985577dbf7acb6dbc2f250ee35300cab20f0a6e7b960af12a85192c8c23fe4d3e366b176d4ac1df SHA512 4c7467710211812afcb8f91c412ce2f909a2d206ab05c9279c616a9579be67f8a000559613c50f7c7246607626dd2dc0270818f14c14f98cd7bff2eda22a9e9f
diff --git a/app-alternatives/tar/tar-0.ebuild b/app-alternatives/tar/tar-0.ebuild
index dc594b0f8933..b37377fa0f63 100644
--- a/app-alternatives/tar/tar-0.ebuild
+++ b/app-alternatives/tar/tar-0.ebuild
@@ -3,20 +3,18 @@
EAPI=8
-DESCRIPTION="Tar symlink"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Base/Alternatives"
-SRC_URI=""
-S=${WORKDIR}
+ALTERNATIVES=(
+ "gnu:>=app-arch/tar-1.34-r2"
+ libarchive:app-arch/libarchive
+)
+
+inherit app-alternatives
-LICENSE="CC0-1.0"
-SLOT="0"
+DESCRIPTION="Tar symlink"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="+gnu libarchive split-usr"
-REQUIRED_USE="^^ ( gnu libarchive )"
+IUSE="split-usr"
RDEPEND="
- gnu? ( >=app-arch/tar-1.34-r2 )
- libarchive? ( app-arch/libarchive )
!<app-arch/tar-1.34-r2
"
@@ -24,13 +22,14 @@ src_install() {
local usr_prefix=
use split-usr && usr_prefix=../usr/bin/
- if use gnu; then
- dosym gtar /bin/tar
- newman - tar.1 <<<".so gtar.1"
- elif use libarchive; then
- dosym "${usr_prefix}bsdtar" /bin/tar
- newman - tar.1 <<<".so bsdtar.1"
- else
- die "Invalid USE flag combination (broken REQUIRED_USE?)"
- fi
+ case $(get_alternative) in
+ gnu)
+ dosym gtar /bin/tar
+ newman - tar.1 <<<".so gtar.1"
+ ;;
+ libarchive)
+ dosym "${usr_prefix}bsdtar" /bin/tar
+ newman - tar.1 <<<".so bsdtar.1"
+ ;;
+ esac
}
diff --git a/app-alternatives/yacc/Manifest b/app-alternatives/yacc/Manifest
index 5cbc1ba68918..2e84cdf9d982 100644
--- a/app-alternatives/yacc/Manifest
+++ b/app-alternatives/yacc/Manifest
@@ -1,3 +1,3 @@
EBUILD yacc-0.ebuild 536 BLAKE2B ccb4b1c59c0452254507b81a52c1d9147a109fdf968ad2e71b5776735e5c59c8aa0447964614941e22d927b995c5ec045bdfa8f890fb5a1874f462ca64459f21 SHA512 aff6ef4ac24044dcec4484395cd4b155617035f8c632fd6550e8a17b1c467e0c164880ca1d0ac9df86f00df09d0879f26063457b85807874361fac822879fe57
-EBUILD yacc-1-r2.ebuild 1588 BLAKE2B dc3f5caa5eb6344cfda884841b2360257d1cd0d7665a2513fb970bb580f9f60f5eb1f7f4d1539db73bf06a267f7a91d78bfabf75f312bb822d01a96db96f58f0 SHA512 a242a4022a43c63809049a2fa07f1b4b3da80c7c983cac09eebea9f692e93939ecec3f4e61a0aef6d96c67f65d31ba1d071b75040cb3a362a7d83f953bb9c140
+EBUILD yacc-1-r2.ebuild 1190 BLAKE2B 3be447c988140d2b2630210ecbd5ce6f32d7e1f9b83f09a0954a6ad70fbc2561386301ae6a424a2fc9d3ec1ad1c6bf846533f91780316af28fd2641392c3c395 SHA512 c7c38ecfe7202e7d6454c932b5619a594c962fcf56f7d5b1ab22b9b03c0a1770f979f2624d076c2f573e982e68de7f67eabd62c5c4a9a9388382b0378877a2b0
MISC metadata.xml 604 BLAKE2B a40366e6a7aab1ac9658b2b46cc6409486d2e2b7ac456209b4151974f48facc65e68d2e44965a6eb0680af47663a379da050bfbcf480e6af50951ec6d03647e5 SHA512 24329bbcc9bd0a589559c621a89b0dc26f304f47cdbd62e09bf5d33cb190bdecfc352527970c072080a3c9a7e4a7193b6d7c71ab0a0c83d0dcb76f03e0699a5c
diff --git a/app-alternatives/yacc/yacc-1-r2.ebuild b/app-alternatives/yacc/yacc-1-r2.ebuild
index e748c4e0ab73..2a3e288c2f8b 100644
--- a/app-alternatives/yacc/yacc-1-r2.ebuild
+++ b/app-alternatives/yacc/yacc-1-r2.ebuild
@@ -3,54 +3,42 @@
EAPI=8
-DESCRIPTION="yacc symlinks"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Base/Alternatives"
-SRC_URI=""
-S=${WORKDIR}
+ALTERNATIVES=(
+ "bison:>=sys-devel/bison-3.8.2-r1"
+ byacc:dev-util/byacc
+ "reference:>=dev-util/yacc-1.9.1-r7"
+)
+
+inherit app-alternatives
-LICENSE="CC0-1.0"
-SLOT="0"
+DESCRIPTION="yacc symlinks"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="+bison byacc reference"
-REQUIRED_USE="^^ ( bison byacc reference )"
RDEPEND="
- bison? ( >=sys-devel/bison-3.8.2-r1 )
- byacc? ( dev-util/byacc )
- reference? ( >=dev-util/yacc-1.9.1-r7 )
!<dev-util/yacc-1.9.1-r7
!<sys-devel/bison-3.8.2-r1
"
src_install() {
- if use bison; then
+ local alt=$(get_alternative)
+
+ case ${alt} in
# bison installs its own small wrapper script 'yacc-bison'
# around bison(1).
- dosym yacc.bison /usr/bin/yacc
- newman - yacc.1 <<<".so yacc.bison.1"
-
- # Leaving this for now to be safe, as it's closer to pre-alternatives
- # status quo to leave it unset and let autoconf probe for Bison by itself
- # as it prefers it anyway, and might be a CPP-like situation wrt
- # calling bison or bison -y if YACC is set.
- #newenvd - 90yacc <<-EOF
- # YACC=yacc.bison
- #EOF
- elif use byacc; then
- dosym byacc /usr/bin/yacc
- newman - yacc.1 <<<".so byacc.1"
-
- newenvd - 90yacc <<-EOF
- YACC=byacc
- EOF
- elif use reference; then
- dosym yacc-reference /usr/bin/yacc
- newman - yacc.1 <<<".so yacc-reference.1"
-
+ bison) alt=yacc.bison;;
+ reference) alt=yacc-reference;;
+ esac
+
+ dosym "${alt}" /usr/bin/yacc
+ newman - yacc.1 <<<".so ${alt}.1"
+
+ # Leaving this for now to be safe, as it's closer to pre-alternatives
+ # status quo to leave it unset and let autoconf probe for Bison by itself
+ # as it prefers it anyway, and might be a CPP-like situation wrt
+ # calling bison or bison -y if YACC is set.
+ if [[ ${alt} != yacc.bison ]]; then
newenvd - 90yacc <<-EOF
- YACC=yacc
+ YACC=${alt}
EOF
- else
- die "Invalid USE flag combination (broken REQUIRED_USE?)"
fi
}