summaryrefslogtreecommitdiff
path: root/app-alternatives
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-28 16:04:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-28 16:04:42 +0000
commit59a39bcb5ac61a72539ef178989f51c0d526cea4 (patch)
tree75e591dabb04d0e566dfa3e9acddaf7ad8019736 /app-alternatives
parenta6f3e8986a2f9a96f6e7c294c4936cda47183cb6 (diff)
gentoo auto-resync : 28:11:2022 - 16:04:42
Diffstat (limited to 'app-alternatives')
-rw-r--r--app-alternatives/Manifest.gzbin0 -> 708 bytes
-rw-r--r--app-alternatives/cpio/Manifest2
-rw-r--r--app-alternatives/cpio/cpio-0.ebuild36
-rw-r--r--app-alternatives/cpio/metadata.xml20
-rw-r--r--app-alternatives/metadata.xml9
-rw-r--r--app-alternatives/sh/Manifest2
-rw-r--r--app-alternatives/sh/metadata.xml29
-rw-r--r--app-alternatives/sh/sh-0.ebuild48
-rw-r--r--app-alternatives/tar/Manifest2
-rw-r--r--app-alternatives/tar/metadata.xml20
-rw-r--r--app-alternatives/tar/tar-0.ebuild36
11 files changed, 204 insertions, 0 deletions
diff --git a/app-alternatives/Manifest.gz b/app-alternatives/Manifest.gz
new file mode 100644
index 000000000000..c60513ae81e2
--- /dev/null
+++ b/app-alternatives/Manifest.gz
Binary files differ
diff --git a/app-alternatives/cpio/Manifest b/app-alternatives/cpio/Manifest
new file mode 100644
index 000000000000..28ae65faaba6
--- /dev/null
+++ b/app-alternatives/cpio/Manifest
@@ -0,0 +1,2 @@
+EBUILD cpio-0.ebuild 985 BLAKE2B e62476f5bb7312e58f5ef3a2b2162a2c7b6971dcbca36a6129be3c7e27a367e735cc1dd7b0ca75438c29e21988f4b5365ca3c426eb11c96bfa6f8fef736b3047 SHA512 fb9cff72535814ceb9d1af6da22298383adf64bca30e7cbe9ee331648e7cc9e9d8064795c7dea3702460fbe24dde94ae92991beca84eb4499ec91ec80747b5d9
+MISC metadata.xml 556 BLAKE2B 50f93b411b7b21af21a4d071bba8533ed58c6ff5bfa1f18bf6025c1c11dfea1be089777f3e59972c72deefcfb54bedc2065f188e0b75c369bb683b9a17ece639 SHA512 7db5fac74ffcbe3344a06f5a9f5360c07648aac7b5080985b110f2b072412ead598ac5bbc5c2f48bd15077e1bc11e36fc8491a7bb898a761f8c6977a753f067a
diff --git a/app-alternatives/cpio/cpio-0.ebuild b/app-alternatives/cpio/cpio-0.ebuild
new file mode 100644
index 000000000000..20af68ac0123
--- /dev/null
+++ b/app-alternatives/cpio/cpio-0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="CPIO symlink"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Base/Alternatives"
+SRC_URI=""
+S=${WORKDIR}
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+gnu libarchive split-usr"
+REQUIRED_USE="^^ ( gnu libarchive )"
+
+RDEPEND="
+ gnu? ( >=app-arch/cpio-2.13-r4 )
+ libarchive? ( app-arch/libarchive )
+ !<app-arch/cpio-2.13-r4
+"
+
+src_install() {
+ local usr_prefix=
+ use split-usr && usr_prefix=../usr/bin/
+
+ if use gnu; then
+ dosym gcpio /bin/cpio
+ newman - cpio.1 <<<".so gcpio.1"
+ elif use libarchive; then
+ dosym "${usr_prefix}bsdcpio" /bin/cpio
+ newman - cpio.1 <<<".so bsdcpio.1"
+ else
+ die "Invalid USE flag combination (broken REQUIRED_USE?)"
+ fi
+}
diff --git a/app-alternatives/cpio/metadata.xml b/app-alternatives/cpio/metadata.xml
new file mode 100644
index 000000000000..77435f8882ae
--- /dev/null
+++ b/app-alternatives/cpio/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <use>
+ <flag name="gnu">
+ Symlink to GNU cpio (<pkg>app-arch/cpio</pkg>)
+ </flag>
+ <flag name="libarchive">
+ Symlink to bsdcpio from <pkg>app-arch/libarchive</pkg>
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/app-alternatives/metadata.xml b/app-alternatives/metadata.xml
new file mode 100644
index 000000000000..68304dc931a0
--- /dev/null
+++ b/app-alternatives/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE catmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<catmetadata>
+ <longdescription lang="en">
+ The app-alternatives category contains packages providing
+ symlinks linking different available implementations for various
+ executables.
+ </longdescription>
+</catmetadata>
diff --git a/app-alternatives/sh/Manifest b/app-alternatives/sh/Manifest
new file mode 100644
index 000000000000..b9138b0e2340
--- /dev/null
+++ b/app-alternatives/sh/Manifest
@@ -0,0 +1,2 @@
+EBUILD sh-0.ebuild 1243 BLAKE2B d8969c5ee83fe3a88656d09448607a4ad482457408dcaf809a43453c0eaeb36bee7c1299e058417a5e0939032e1e46107c56cdba96eab63be748831e69a62ac8 SHA512 a8f3296f6053ea628b9278a36a0caa122e744e4f1ccbe7709569bafd205e8e29229f9fe269841914dc17f54a7864a87051686487615b4730cf7a5a319c065db8
+MISC metadata.xml 759 BLAKE2B 4f691499f0da47c72c61999275d72604093856ff5440a7f72fdf9a6fe09ac86ce8d07e453d8a88ee9747142cf506cb4824223f9372ba2c8f0414086a3390a239 SHA512 2d2c06a26faf1cb72fea2f201a3bdabed020d8e2f1fb6bd86fdb985274a76db14080410982c74d3d5e5ccf483f1c280f2ea77d3d083d87985f36b54c190b2ec9
diff --git a/app-alternatives/sh/metadata.xml b/app-alternatives/sh/metadata.xml
new file mode 100644
index 000000000000..b91b8f41c94c
--- /dev/null
+++ b/app-alternatives/sh/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <use>
+ <flag name="bash">
+ Symlink to <pkg>app-shells/bash</pkg>
+ </flag>
+ <flag name="dash">
+ Symlink to <pkg>app-shells/dash</pkg>
+ </flag>
+ <flag name="ksh">
+ Symlink to <pkg>app-shells/ksh</pkg>
+ </flag>
+ <flag name="lksh">
+ Symlink to lksh from <pkg>app-shells/mksh</pkg>
+ </flag>
+ <flag name="mksh">
+ Symlink to mksh from <pkg>app-shells/mksh</pkg>
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/app-alternatives/sh/sh-0.ebuild b/app-alternatives/sh/sh-0.ebuild
new file mode 100644
index 000000000000..5da158c80cab
--- /dev/null
+++ b/app-alternatives/sh/sh-0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="/bin/sh (POSIX shell) symlink"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Base/Alternatives"
+SRC_URI=""
+S=${WORKDIR}
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+bash dash ksh lksh mksh"
+REQUIRED_USE="^^ ( bash dash ksh lksh mksh )"
+
+RDEPEND="
+ bash? ( app-shells/bash )
+ dash? ( app-shells/dash )
+ ksh? ( app-shells/ksh )
+ lksh? ( app-shells/mksh[lksh] )
+ mksh? ( app-shells/mksh )
+ !!app-eselect/eselect-sh
+"
+
+src_install() {
+ if use bash; then
+ dosym bash /bin/sh
+ elif use dash; then
+ dosym dash /bin/sh
+ elif use ksh; then
+ dosym ksh /bin/sh
+ elif use lksh; then
+ dosym lksh /bin/sh
+ elif use mksh; then
+ dosym mksh /bin/sh
+ else
+ die "Invalid USE flag combination (broken REQUIRED_USE?)"
+ fi
+}
+
+pkg_postrm() {
+ # make sure we don't leave the user without /bin/sh, since it's not
+ # been owned by any other package
+ if [[ ! -h ${EROOT}/bin/sh ]]; then
+ ln -s bash "${EROOT}/bin/sh" || die
+ fi
+}
diff --git a/app-alternatives/tar/Manifest b/app-alternatives/tar/Manifest
new file mode 100644
index 000000000000..fcb52a0cfa7d
--- /dev/null
+++ b/app-alternatives/tar/Manifest
@@ -0,0 +1,2 @@
+EBUILD tar-0.ebuild 974 BLAKE2B d5d055490853c5f9f19d75d04b22c2be9b01f786cead03e83bbe91c23604c661011738bfc1afb0003d5122b587cd3a4744f704b18f4b324243cbefbda9e19160 SHA512 4dbaf848070bed5446c03b6f0e6fb305f8eeddf5b3e3fe16183b301ac2af46c276e69586e17d27e417c17dbb5251b75046a0d860b1409c94cae0873332def234
+MISC metadata.xml 553 BLAKE2B 084e137dd7317424c0d3555fd867ae581bb3b629705e5be59985577dbf7acb6dbc2f250ee35300cab20f0a6e7b960af12a85192c8c23fe4d3e366b176d4ac1df SHA512 4c7467710211812afcb8f91c412ce2f909a2d206ab05c9279c616a9579be67f8a000559613c50f7c7246607626dd2dc0270818f14c14f98cd7bff2eda22a9e9f
diff --git a/app-alternatives/tar/metadata.xml b/app-alternatives/tar/metadata.xml
new file mode 100644
index 000000000000..3bf8c905056c
--- /dev/null
+++ b/app-alternatives/tar/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <use>
+ <flag name="gnu">
+ Symlink to GNU tar (<pkg>app-arch/tar</pkg>)
+ </flag>
+ <flag name="libarchive">
+ Symlink to bsdtar from <pkg>app-arch/libarchive</pkg>
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/app-alternatives/tar/tar-0.ebuild b/app-alternatives/tar/tar-0.ebuild
new file mode 100644
index 000000000000..dc594b0f8933
--- /dev/null
+++ b/app-alternatives/tar/tar-0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Tar symlink"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Base/Alternatives"
+SRC_URI=""
+S=${WORKDIR}
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+gnu libarchive split-usr"
+REQUIRED_USE="^^ ( gnu libarchive )"
+
+RDEPEND="
+ gnu? ( >=app-arch/tar-1.34-r2 )
+ libarchive? ( app-arch/libarchive )
+ !<app-arch/tar-1.34-r2
+"
+
+src_install() {
+ local usr_prefix=
+ use split-usr && usr_prefix=../usr/bin/
+
+ if use gnu; then
+ dosym gtar /bin/tar
+ newman - tar.1 <<<".so gtar.1"
+ elif use libarchive; then
+ dosym "${usr_prefix}bsdtar" /bin/tar
+ newman - tar.1 <<<".so bsdtar.1"
+ else
+ die "Invalid USE flag combination (broken REQUIRED_USE?)"
+ fi
+}