summaryrefslogtreecommitdiff
path: root/app-alternatives/gzip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-01 20:53:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-01 20:53:45 +0000
commit896d6a8a88861c42b5d531a2f147c8a29a149bd8 (patch)
tree081fe10813721a96088dca6b54bc35bcac18afc6 /app-alternatives/gzip
parent3059f20995d5ac642b7b4a38d538fdf1cc45d90d (diff)
gentoo auto-resync : 01:12:2022 - 20:53:45
Diffstat (limited to 'app-alternatives/gzip')
-rw-r--r--app-alternatives/gzip/Manifest2
-rw-r--r--app-alternatives/gzip/gzip-0.ebuild45
-rw-r--r--app-alternatives/gzip/metadata.xml20
3 files changed, 67 insertions, 0 deletions
diff --git a/app-alternatives/gzip/Manifest b/app-alternatives/gzip/Manifest
new file mode 100644
index 000000000000..2e003e8b62ab
--- /dev/null
+++ b/app-alternatives/gzip/Manifest
@@ -0,0 +1,2 @@
+EBUILD gzip-0.ebuild 1269 BLAKE2B e1bb6a3ad0fe76590937e5be1558aa6d3f5769812df813c10c7dc3b6351f6ab4a622703cdfabaf7fa9aa55f48a082e53bc81d338f8ed9b612d2319e9dc64b759 SHA512 604814007334d62429b28ada0097d9d329e5ce9a974afafd151642d5a1ef88bfcf2b1447f7e1db819665e3f50399ec80d646028be8df87a088e1f1cdc2d7ae50
+MISC metadata.xml 528 BLAKE2B 099aec3cb340caeedc0fc6e2f62162baf276b1262b4758dd39695a03ee5110c717a9b553190762c939171d7776b2048fe73c1fc7a966eef916e992abeed0ec21 SHA512 e654f8d548769c00425cd9a3f796c17af28300ea297294b335166f023164a5696216135badc82074b6a88669114f7db819af827aad8144987c7cfc7a474a2191
diff --git a/app-alternatives/gzip/gzip-0.ebuild b/app-alternatives/gzip/gzip-0.ebuild
new file mode 100644
index 000000000000..29e0808da453
--- /dev/null
+++ b/app-alternatives/gzip/gzip-0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="gzip symlinks"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Base/Alternatives"
+SRC_URI=""
+S=${WORKDIR}
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="pigz +reference split-usr"
+REQUIRED_USE="^^ ( pigz reference )"
+
+RDEPEND="
+ pigz? ( app-arch/pigz[-symlink(-)] )
+ reference? ( >=app-arch/gzip-1.12-r3 )
+ !<app-arch/gzip-1.12-r3
+ !app-arch/pigz[symlink(-)]
+"
+
+src_install() {
+ local usr_prefix=
+ use split-usr && usr_prefix=../usr/bin/
+
+ if use pigz; then
+ dosym "${usr_prefix}pigz" /bin/gzip
+ dosym gzip /bin/gunzip
+ dosym gzip /bin/zcat
+ newman - gzip.1 <<<".so pigz.1"
+ elif use reference; then
+ dosym gzip-reference /bin/gzip
+ # gzip uses shell wrappers rather than argv[0]
+ dosym gunzip-reference /bin/gunzip
+ dosym zcat-reference /bin/zcat
+ newman - gzip.1 <<<".so gzip-reference.1"
+ else
+ die "Invalid USE flag combination (broken REQUIRED_USE?)"
+ fi
+
+ newman - gunzip.1 <<<".so gzip.1"
+ newman - zcat.1 <<<".so gzip.1"
+}
diff --git a/app-alternatives/gzip/metadata.xml b/app-alternatives/gzip/metadata.xml
new file mode 100644
index 000000000000..6a439f199cb1
--- /dev/null
+++ b/app-alternatives/gzip/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <use>
+ <flag name="pigz">
+ Symlink to <pkg>app-arch/pigz</pkg>.
+ </flag>
+ <flag name="reference">
+ Symlink to <pkg>app-arch/gzip</pkg>.
+ </flag>
+ </use>
+</pkgmetadata>