summaryrefslogtreecommitdiff
path: root/app-admin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-27 17:40:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-27 17:40:28 +0000
commit5cf235d5f7f308ba0183f7fa588514966b692114 (patch)
tree196baba60d7e0a81069198200d56fe6364bb238b /app-admin
parente4be1c42deab59fa5baee33fa9b1c48e5c4c6dc7 (diff)
gentoo auto-resync : 27:02:2024 - 17:40:28
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/Manifest.gzbin31856 -> 32021 bytes
-rw-r--r--app-admin/redfishtool/Manifest3
-rw-r--r--app-admin/redfishtool/metadata.xml12
-rw-r--r--app-admin/redfishtool/redfishtool-1.1.8.ebuild21
4 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/Manifest.gz b/app-admin/Manifest.gz
index 717cbd123a1f..f3d937553f2e 100644
--- a/app-admin/Manifest.gz
+++ b/app-admin/Manifest.gz
Binary files differ
diff --git a/app-admin/redfishtool/Manifest b/app-admin/redfishtool/Manifest
new file mode 100644
index 000000000000..a82cfe5a3802
--- /dev/null
+++ b/app-admin/redfishtool/Manifest
@@ -0,0 +1,3 @@
+DIST redfishtool-1.1.8.tar.gz 83028 BLAKE2B 376d7513776aaf72bdc249d27312f25134c16ede12584ce334d7f89b07fc2abd986baa775fbc5f497d0679fba6997d5f908062af32186364b6609625fcb6e0c5 SHA512 c9aee7461013144e7d2ba2825f750cca52270cd658bb07e65764923c0ba489ec1e8a5ecb12a1b4f43ef8c0227fbe195a6869c2ae264ed778a5dddc513cbaa542
+EBUILD redfishtool-1.1.8.ebuild 476 BLAKE2B 57677ace731efaef107bc44385ffe1acd59bbb5e272d0a127a3af9fd8b74a5b08bf53ccd20a5c57f87eb18e770a7c8c3ab9640a49f6aefe4b869e4a9b9ebe5bc SHA512 38da123e7719be684b13978901e36571809fb0b899e8831a19e8fb40432e673aa29d426cc2c9bef750f2da06e8f0a2727dfa05813b2c061483eb1ccc28d6a0ba
+MISC metadata.xml 376 BLAKE2B 3a54bd3c008141b4b133ade67642ce389acb1e17dc2d3f471ae2c22e1f04dd5e8a1d996fcdb95af3f49e2ced0ef52dba105c6a2e34aea4e64c495a300e652d00 SHA512 0434f210843ac4895c07716213f624c936101c54dcaa2ac426f534d18c64db9c76e357f85c6a8b07567722243c5976e8c214769aa377d64ed15babd6ac52c6a4
diff --git a/app-admin/redfishtool/metadata.xml b/app-admin/redfishtool/metadata.xml
new file mode 100644
index 000000000000..18acf7851c64
--- /dev/null
+++ b/app-admin/redfishtool/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">redfishtool</remote-id>
+ <remote-id type="github">DMTF/Redfishtool</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/redfishtool/redfishtool-1.1.8.ebuild b/app-admin/redfishtool/redfishtool-1.1.8.ebuild
new file mode 100644
index 000000000000..79a53b30f0b9
--- /dev/null
+++ b/app-admin/redfishtool/redfishtool-1.1.8.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python package and command-line tool for accessing the Redfish API"
+HOMEPAGE="https://github.com/DMTF/Redfishtool"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"