summaryrefslogtreecommitdiff
path: root/app-admin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-22 23:28:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-22 23:28:46 +0100
commit0bf5c5a0b1ff93d1f4aaa8cdea6acda5e42c2068 (patch)
tree535db46356d46fc3f3c97342cb3691c0317e52d9 /app-admin
parentd79ab35b7ac170babebe8bc151fe5d037c16285c (diff)
gentoo auto-resync : 22:09:2022 - 23:28:46
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/Manifest.gzbin32711 -> 32875 bytes
-rw-r--r--app-admin/djbdns-logparse/Manifest3
-rw-r--r--app-admin/djbdns-logparse/djbdns-logparse-0.0.1.ebuild31
-rw-r--r--app-admin/djbdns-logparse/metadata.xml7
4 files changed, 41 insertions, 0 deletions
diff --git a/app-admin/Manifest.gz b/app-admin/Manifest.gz
index e557422dc670..d562c44fd0f1 100644
--- a/app-admin/Manifest.gz
+++ b/app-admin/Manifest.gz
Binary files differ
diff --git a/app-admin/djbdns-logparse/Manifest b/app-admin/djbdns-logparse/Manifest
new file mode 100644
index 000000000000..ff10d2ceda62
--- /dev/null
+++ b/app-admin/djbdns-logparse/Manifest
@@ -0,0 +1,3 @@
+DIST djbdns-logparse-0.0.1.tar.gz 23317 BLAKE2B d44b2af042990dc1632746e111ecb53dcd16cd0a245a778f198163afb7de26a5f41cf624c81fe06dbffad94c9370e24267bb3c69176b4afb2e26a71fa5fa1afc SHA512 e066875d3718ab7780c6a82ed022106bd26b454827532beb2f6f2ef5e38d2619b71067250b9ed22eea03380da2f0e68b26931ceb99d9300e15be77d070d7fdf2
+EBUILD djbdns-logparse-0.0.1.ebuild 766 BLAKE2B b193e11f690c92e92f4203531d271de77cbaaf05612a307773a8eef915f953b9f0dfeb6f0d517341704bf810d306f9771e358c7aba5dfa90ebf8b09b8a533cf7 SHA512 58a75436ccb0a245cde0763d6e724c9f7c1ce2339b12accf7417d5624fb045deaa5a1a68e9cc77a8d3e8bbf341cd1cd6ac5f134737a98e7a8465848fae2c01da
+MISC metadata.xml 219 BLAKE2B 27094593eb47f098fe9df926d3a827b65c2ca39ac6b03d392efe2c19d646274e5b462f65a7177ba2556a9167c994544688e53a3df810dc7f86ae43c4a75fd59e SHA512 e990bf6d766d6c0380344187a03b66380e4ed7a1554dd7a900ccf1f6f2dd3a51b06b382cedd5c73e0ad75301436b351fea0e7f1fb720c3d1345a8958554d341c
diff --git a/app-admin/djbdns-logparse/djbdns-logparse-0.0.1.ebuild b/app-admin/djbdns-logparse/djbdns-logparse-0.0.1.ebuild
new file mode 100644
index 000000000000..a37424d8def8
--- /dev/null
+++ b/app-admin/djbdns-logparse/djbdns-logparse-0.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Make tinydns and dnscache logs human-readable"
+HOMEPAGE="http://michael.orlitzky.com/code/djbdns-logparse.xhtml"
+SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.gz"
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# djbdns-logparse pipes the logs through the "tai64nlocal" program
+# that comes with sys-process/daemontools.
+RDEPEND="sys-process/daemontools"
+BDEPEND="test? ( ${RDEPEND} )"
+
+python_install_all() {
+ doman "doc/man1/${PN}.1"
+ local DOCS=( doc/README )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ esetup.py test
+}
diff --git a/app-admin/djbdns-logparse/metadata.xml b/app-admin/djbdns-logparse/metadata.xml
new file mode 100644
index 000000000000..c6418674131d
--- /dev/null
+++ b/app-admin/djbdns-logparse/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>