summaryrefslogtreecommitdiff
path: root/app-admin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-18 11:39:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-18 11:39:03 +0000
commit08f1ae6b8bd1202a10c5f0d07ee0adc846e0308c (patch)
tree030000b4df6e90b84380b6c0471fd05dd547bb0f /app-admin
parent3e4b97f04e1561890eb4b0bcb3a411b931c08d02 (diff)
gentoo auto-resync : 18:02:2024 - 11:39:02
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/Manifest.gzbin31870 -> 31870 bytes
-rw-r--r--app-admin/ansible-lint/Manifest2
-rw-r--r--app-admin/ansible-lint/ansible-lint-24.2.0.ebuild58
3 files changed, 60 insertions, 0 deletions
diff --git a/app-admin/Manifest.gz b/app-admin/Manifest.gz
index 4b08e89ed4a0..c77b639d2f29 100644
--- a/app-admin/Manifest.gz
+++ b/app-admin/Manifest.gz
Binary files differ
diff --git a/app-admin/ansible-lint/Manifest b/app-admin/ansible-lint/Manifest
index 1147562ae6b9..462048d689dc 100644
--- a/app-admin/ansible-lint/Manifest
+++ b/app-admin/ansible-lint/Manifest
@@ -1,5 +1,7 @@
+DIST ansible-lint-24.2.0.tar.gz 513719 BLAKE2B 54e05acf982cf13cb2142a10bf04250171f07936df14933525dfae68b312a0d92ceb30867603dc7ce686206b7de010f6ca4eb9ab532ca000fc3c15c77c354c81 SHA512 3276d28c7b85a6087a0142cc56442efddf9ff3e81155455c74686015a2ab45ece64847b0243373ad01145e67599d8449866c122efe8ae404cd819011e41c5235
DIST ansible-lint-6.21.1.tar.gz 508487 BLAKE2B 9a29a5d192675a8801846fc29641651c35be5cc4d120aad128ae248a86c8493aa9125b2abb428e0fa41b233cd669a8496c85a22de7d9bac99760bbcff222066c SHA512 538735ef89bcbb65077a0e02d6c9143c0aab2ce2160679d85c8dc5d222815230893f7c9bc4ee539c20d82cd7a8c1f72d3d7ee63666c49de603f4fa99964c260e
DIST ansible-lint-6.22.2.tar.gz 513988 BLAKE2B b46764751a84ff2a699203bf07f4a04362faa99d7433af6ead9f7ada9e581ff8b3d9bbf205a0127950e15e4413a72fc057cd10588dffec2fb9621f58620ae1ca SHA512 b48dec138a37754135e48007636f020524947342ab40f2b9dea36e10989e88ee6899e4742f1715feecfd7e239c80d3bed0581558c39eac783a84523507740180
+EBUILD ansible-lint-24.2.0.ebuild 1735 BLAKE2B 8db9bfcc325f9ecbbe36ed70f2ec71de32ef69095b62789bf7c77ec80c659be22f97600595534ebe71221cf60b73f8df0c845e12f025824cf94b2546da720c0d SHA512 498e5ceea04af6922bfabaf87fe6be2b7c3ab39a192439c4e166b09a572058c8940ba6d18f9e6817c0c644723852aec378c1345a4742432d7bf3be2d6fd26ca7
EBUILD ansible-lint-6.21.1.ebuild 1839 BLAKE2B 74e31b3fd094cc89ed786350f7237c7a704bd5ad48e6c0350f9441b3d90612dbbdadc12ca6d85a20320eccbbfab8e706881d4b0a164cb547157709c71eddec49 SHA512 45ec6e09c3e8f5bd9810ecf73688922c8118152201ee0f722330cb4d83dfd6502b68f1dedf0a346492f00dcb41e3ecb5fb60e1be882f3ee509781d375246f13b
EBUILD ansible-lint-6.22.2.ebuild 1735 BLAKE2B 8db9bfcc325f9ecbbe36ed70f2ec71de32ef69095b62789bf7c77ec80c659be22f97600595534ebe71221cf60b73f8df0c845e12f025824cf94b2546da720c0d SHA512 498e5ceea04af6922bfabaf87fe6be2b7c3ab39a192439c4e166b09a572058c8940ba6d18f9e6817c0c644723852aec378c1345a4742432d7bf3be2d6fd26ca7
MISC metadata.xml 561 BLAKE2B 0f55fc4da270c495c445e5afff0a8f7aaedd01abf3640f848cd9dc21e01fa7324c78846ee4bf917e4869b6c377fef61254a2288fa3d572c1bb77279571fb6631 SHA512 bd6bf6b916a0b736a0bfdd633f6569ce3124458169d77ef1cd86d6dda4099774088871560ce0106e11f139a2b48f13445e7a844e03a8669160c7e3fa44be5f36
diff --git a/app-admin/ansible-lint/ansible-lint-24.2.0.ebuild b/app-admin/ansible-lint/ansible-lint-24.2.0.ebuild
new file mode 100644
index 000000000000..3f90dcc0ab28
--- /dev/null
+++ b/app-admin/ansible-lint/ansible-lint-24.2.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
+HOMEPAGE="https://github.com/ansible/ansible-lint"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+# Upstream has stated explicitly that all tests require Internet access
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12.0[${PYTHON_USEDEP}]
+ >=dev-python/ansible-compat-4.1.11[${PYTHON_USEDEP}]
+ >=dev-python/black-22.8.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.17.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.18.5[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-8.3.2[${PYTHON_USEDEP}]
+ >=dev-util/yamllint-1.30.0[${PYTHON_USEDEP}]
+ dev-vcs/git"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+ )"
+
+# test_call_from_outside_venv doesn't play nicely with the sandbox
+# irrespective of whether Internet access is allowed or not
+EPYTEST_DESELECT=(
+ test/test_main.py::test_call_from_outside_venv
+)
+
+distutils_enable_tests pytest
+
+# Test suite fails to start without this
+python_test() {
+ epytest test
+}