summaryrefslogtreecommitdiff
path: root/app-admin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-22 00:06:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-22 00:06:25 +0100
commit236e75597883501f8700d9ba1a5c8276f578a17f (patch)
tree6b441a1dfa3a82840e3aa74678cc90c5294a4bca /app-admin
parentbfd63d5b0e96ad32e0d0a8fe15512b6a9ac6fc9e (diff)
gentoo auto-resync : 22:05:2024 - 00:06:25next
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/Manifest.gzbin32071 -> 32069 bytes
-rw-r--r--app-admin/ansible-lint/Manifest2
-rw-r--r--app-admin/ansible-lint/ansible-lint-24.5.0.ebuild57
-rw-r--r--app-admin/awscli/Manifest2
-rw-r--r--app-admin/awscli/awscli-1.32.109.ebuild90
5 files changed, 151 insertions, 0 deletions
diff --git a/app-admin/Manifest.gz b/app-admin/Manifest.gz
index ff01edba845b..9ba90c94b75c 100644
--- a/app-admin/Manifest.gz
+++ b/app-admin/Manifest.gz
Binary files differ
diff --git a/app-admin/ansible-lint/Manifest b/app-admin/ansible-lint/Manifest
index 1bb1667ebfd8..a1a1400f6d90 100644
--- a/app-admin/ansible-lint/Manifest
+++ b/app-admin/ansible-lint/Manifest
@@ -1,5 +1,7 @@
DIST ansible-lint-24.2.0.tar.gz 513719 BLAKE2B 54e05acf982cf13cb2142a10bf04250171f07936df14933525dfae68b312a0d92ceb30867603dc7ce686206b7de010f6ca4eb9ab532ca000fc3c15c77c354c81 SHA512 3276d28c7b85a6087a0142cc56442efddf9ff3e81155455c74686015a2ab45ece64847b0243373ad01145e67599d8449866c122efe8ae404cd819011e41c5235
DIST ansible-lint-24.2.2.tar.gz 515822 BLAKE2B e9d8e689dfe4e4efbd4dad44ff3567f50412400ed979f2d60150f09f17c5f63f2441f25a33ecdf0112024ced07e62ac16b8a2dbc1c01d62855ec785fc75d1b9a SHA512 3de6b14e4b64ba577abcb67920a45dbf45fedb84e21091cd6a29e3c52a7a91555a152ee3e265624aafbf9dddba96d04241c2598a18f2103ce2cae48706142446
+DIST ansible_lint-24.5.0.tar.gz 525539 BLAKE2B 2681da05c69299f62b9a180ff4a10ea8fa27731d5a9f3d836e67fd211c2def86a6baa38583900e9c8be1a5da0a8658aded6e83cb8f13f129f55bd18a06b2e574 SHA512 b390743bbb09c03c9b402c35644c2b2e29b9a94fce842bf42b8938f7094b145ea75275f643949383bdad694408c606c0bc3038d5ca733a39ac08ef77cc7dc459
EBUILD ansible-lint-24.2.0.ebuild 1734 BLAKE2B cb94d883bce5f2d8bd26dc3ef73d3a742c4457cfcccf8dfa1c51c581af41e07269d914ea93c2a428ff66ac2b0f9ac77e89f8bab58f93eb959b94cbc476771566 SHA512 14c01aa109fbef294e21b29c92d7eef24a2fa54a549a266f562869bc74ca36c2221e211f1abe3382130d7308defef35b32a893e344cb2ea110b3eb59d7c6f43a
EBUILD ansible-lint-24.2.2.ebuild 1735 BLAKE2B 109574e3d7bc7b9a5619437428dc98a3aefd3d3014f86a01c637f04a7065d5ea889110045d3949edeb72dccbe1e2e817918de6842b378f500570234ef41e8b50 SHA512 009ec5d5d3dd434f103fe9e25ff1ef54f7cda08146260873cb42da04cecd0c7c0d20fc7f698414c92e621bcf24a4e244130ad2842429ba01a5760fe4abf1b1ca
+EBUILD ansible-lint-24.5.0.ebuild 1715 BLAKE2B 49d37fa20b54dec61007f84111719fc78dd51e5e9ef81aa332bd4174af908baa54dcf110aa6a9405cde14b27c08c6efb409d5d699d80ef97ad699dd821e1c41a SHA512 ea4507f8199354a0e2723123097224bde780d1bfa0df654ee3527ad4eec005d1d9a9d385c492441f5460a140de7bd02740a9fd422e364471e7029bf3044e4f88
MISC metadata.xml 449 BLAKE2B e6d058111e04c7c54f3fcbeedf38db0e257d07d95297bf6b330cbee8d6749516684c298bd3f36f81c6b399d1046cdc2e53090d1d713f0c9ed11ffda13ee86a16 SHA512 59b9d5d3c30f6cd3b0c4c7cb8f7e915ccecdd1993f96ff2f0978d7ddbee4d03ff69be63bdb55b6f8f614e2348811b131a146b08499200ec749b3bd1d47d3c7ee
diff --git a/app-admin/ansible-lint/ansible-lint-24.5.0.ebuild b/app-admin/ansible-lint/ansible-lint-24.5.0.ebuild
new file mode 100644
index 000000000000..fcaeec307b68
--- /dev/null
+++ b/app-admin/ansible-lint/ansible-lint-24.5.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
+HOMEPAGE="https://github.com/ansible/ansible-lint"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+# Upstream has stated explicitly that all tests require Internet access
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12.0[${PYTHON_USEDEP}]
+ >=dev-python/ansible-compat-4.1.11[${PYTHON_USEDEP}]
+ >=dev-python/black-22.8.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.17.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.18.5[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-8.3.2[${PYTHON_USEDEP}]
+ >=dev-util/yamllint-1.30.0[${PYTHON_USEDEP}]
+ dev-vcs/git"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+ )"
+
+# test_call_from_outside_venv doesn't play nicely with the sandbox
+# irrespective of whether Internet access is allowed or not
+EPYTEST_DESELECT=(
+ test/test_main.py::test_call_from_outside_venv
+)
+
+distutils_enable_tests pytest
+
+# Test suite fails to start without this
+python_test() {
+ epytest test
+}
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 91a770809245..6e512ea6326f 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,9 +1,11 @@
DIST aws-cli-1.32.103.gh.tar.gz 2726436 BLAKE2B 7c08f29df7b0f786a99a7469263cb367ed8024cadb700a56955669abe6fd562cde349fe1e17e7b328b6cc69e6af6db30293f5a13129d700ebfedc1950c26fed3 SHA512 248659ee989df69ffbfbe6dd181632d4a784d4de333b8592c5e0b4a0333d2b201ec652f8ff0f44b51ffe4bc9bea230d047f655016742816cfc52bbb871a707d7
DIST aws-cli-1.32.107.gh.tar.gz 2727905 BLAKE2B 6790687edadc7ebf4bb8519ed9352961d002b95b157bf56b3ce02f50eef8e9eeeac39bb211816ab3e8e0f21dc2e41b9b3c179c77eab8c23d5650b1002fafff52 SHA512 b2f363ba8833058eb935fab311492c252dac4afff2f81e5ea70b9a8610c6e5b7e0b4ec090591af1a0c3692c3641ac1213cb8455d8ffac8a148d7ba0b7c7f4467
DIST aws-cli-1.32.108.gh.tar.gz 2728605 BLAKE2B 83606ebe909a4ee3d4f0d2875f56958b02b791d31d2fc770b1dc60072d31a56b6b7b5ef3ad79d8239b5f061f99f0dbfb554cab169bb99e6813f2b55cf8c185e2 SHA512 ce4bde840a4bfcdce91165bcf66139056e479322c80ef3211c98cd12c09d60d95bad8255f616dca4c11db3a26f3dca8149a42b76d163a8f02a88e6f986faff51
+DIST aws-cli-1.32.109.gh.tar.gz 2728758 BLAKE2B bf3a8fdf1f240db7791183b15e97574d7345a84334664790dec3649e2803a5d16a55f5bfd8be80c9cd60feffd3e829c8b14843041d4805e47c2d23a6026f2848 SHA512 281177a017375e3379978c2322a5bb743c0432bb1fd9d5a3c6ee30463efc2006ed187b0a026811c94936c6c0916701c484fc8aa860d7411aeee8e1e7eb1848e4
DIST aws-cli-1.32.98.gh.tar.gz 2723261 BLAKE2B f854a78226a9480d2966e0dcc817e372de96f32723c28bd7189ed484ab24e8fa9f33a018b1b3193d1a5be82e1ad2b69b2d0d6642f004aa6fd601a68862cbbbdc SHA512 989ad96da152423001832a502935ed64a92ef61ba63f9f413fa07e84910d2aa905056bbfcf49202508d6d0a910b4a2969da27e736857e918077693909e4ca0ea
EBUILD awscli-1.32.103.ebuild 3029 BLAKE2B 580c774489759d94cbe5c77316c3afbb84d597198c391cd0ed89722c239fb23a87fc34378bd669e9104fbfaaa75a924c3d73e8df2c52693ba6fc135da827643d SHA512 4a31562305f7156e91d78023ed1f56e74de8fb1555323a5cd63611254daeb7491b8e323d00e38351d9bbc2a751f257290a6bb4bd91638e28f9c45acb8742c809
EBUILD awscli-1.32.107.ebuild 3029 BLAKE2B 580c774489759d94cbe5c77316c3afbb84d597198c391cd0ed89722c239fb23a87fc34378bd669e9104fbfaaa75a924c3d73e8df2c52693ba6fc135da827643d SHA512 4a31562305f7156e91d78023ed1f56e74de8fb1555323a5cd63611254daeb7491b8e323d00e38351d9bbc2a751f257290a6bb4bd91638e28f9c45acb8742c809
EBUILD awscli-1.32.108.ebuild 3029 BLAKE2B 580c774489759d94cbe5c77316c3afbb84d597198c391cd0ed89722c239fb23a87fc34378bd669e9104fbfaaa75a924c3d73e8df2c52693ba6fc135da827643d SHA512 4a31562305f7156e91d78023ed1f56e74de8fb1555323a5cd63611254daeb7491b8e323d00e38351d9bbc2a751f257290a6bb4bd91638e28f9c45acb8742c809
+EBUILD awscli-1.32.109.ebuild 3029 BLAKE2B 580c774489759d94cbe5c77316c3afbb84d597198c391cd0ed89722c239fb23a87fc34378bd669e9104fbfaaa75a924c3d73e8df2c52693ba6fc135da827643d SHA512 4a31562305f7156e91d78023ed1f56e74de8fb1555323a5cd63611254daeb7491b8e323d00e38351d9bbc2a751f257290a6bb4bd91638e28f9c45acb8742c809
EBUILD awscli-1.32.98.ebuild 3022 BLAKE2B eca1e9b920babafc0c226e1d3c0b23baa63965cffceacc71118d2e4a1302945d10294223300a94f9dec4b39e52c7bd8f44e35cbf7cf30c117f9d86fe93450326 SHA512 11de7ee4880fe2bd192c6c15081b598d4c9d2f18b28064908a855cb01283408542c8981841c531d546b6de9e2b932d2a23e2fe1a9e90030566af6b966c30fd97
MISC metadata.xml 385 BLAKE2B 5accfb180a91179cc6df539d42d1de06be3ebfec73f3edb719f5d59576103b9a8cb0c7c524c1042630e0cf99f068939a19f04c7b1b4a2acf9e072369df80d913 SHA512 ccb3d516326c5dbdf53068372ce25baecc137d21a04516374362212b969cc928dacbf743b4953da33f28482905798f069d09d19c88d9913f2b32648db25115ab
diff --git a/app-admin/awscli/awscli-1.32.109.ebuild b/app-admin/awscli/awscli-1.32.109.ebuild
new file mode 100644
index 000000000000..4a677affdbc4
--- /dev/null
+++ b/app-admin/awscli/awscli-1.32.109.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}