summaryrefslogtreecommitdiff
path: root/app-admin/yadm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/yadm
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/yadm')
-rw-r--r--app-admin/yadm/Manifest5
-rw-r--r--app-admin/yadm/metadata.xml18
-rw-r--r--app-admin/yadm/yadm-1.07.ebuild43
-rw-r--r--app-admin/yadm/yadm-1.12.0.ebuild53
4 files changed, 119 insertions, 0 deletions
diff --git a/app-admin/yadm/Manifest b/app-admin/yadm/Manifest
new file mode 100644
index 000000000000..13d27bfcde22
--- /dev/null
+++ b/app-admin/yadm/Manifest
@@ -0,0 +1,5 @@
+DIST yadm-1.07.tar.gz 34240 BLAKE2B 11952a693c38aac2f2e7fa3efd469dc640941ef9c75a8a1e70974b4eea37c506df7480b2fce84ca8482c932295923ece4ff52cfc13bf9b52030dab0500f07c86 SHA512 9bbe33c82a137375cb27916ae5b5a06f06c25a75ae05688be473103c29154309d3472accc0aa0670a80a4714bc6523ab85c41fd6aa8d1909586437c5778b9144
+DIST yadm-1.12.0.tar.gz 47340 BLAKE2B ef710f56c96244c082bfcc887cae4aee00aaaadec5e7466500dde263c5e4f43df046e11742fd275e989bd9704b39a123f17248cd70d64f6ca552b28db6c44814 SHA512 402a67770154ce3ae7ab947ff4d4e26ca5040d343110fb749195ca5c3f4ee435aba1d8cdf02d4ecf4a81d3f331c1b891bed4fb3fcfcc893867e0fce45b9c8cd8
+EBUILD yadm-1.07.ebuild 895 BLAKE2B 30f232a9b56113aeb38d9b500fc4964e21d705095a3e74214159854a4b2613635a29cbc0ffed322a627805de7b6d25b41b4749e4a5fb38a652a919b9410a5b56 SHA512 7313f9adeb78b32db14351ddead4d8c13cc81c49ec3cc7ea9d78ed4318bee9704d99890a9fc403679069e830583acbe8e37d32bcf91cf4fc25839f9715a239fa
+EBUILD yadm-1.12.0.ebuild 1234 BLAKE2B 73b60da066947ed5ff45950e5809695be1b234e01005103eee4076efcab65fc3acb193716590974caca0a5c209dc13fff77ef85f778c5aa2f8c65d1c67e9ffbe SHA512 9321ffa59728389909b187a1da4cf230467ab180f9ecc24e3137dfc1909329ab68e40066c622ad1c411ff5ed3dfdce9c6b2c1f69ec77f248d7e2361e38f99218
+MISC metadata.xml 825 BLAKE2B 6fbf4554179cf6141396b8e21be3dada54c0eec7c5c5bd1e18860b73f1d170044006b92010f7dd5d3c2238f8545024ee43dc2c86305e8bc91871acdd497c8749 SHA512 0c8facf902245118eab0d6c4b48eb5a2fb63aa6cb7fe4581cc0353bd164912b7620eb2f42984b45410065d3a6e1af1cffa5028f5c26a4ecd38a9983da6b34feb
diff --git a/app-admin/yadm/metadata.xml b/app-admin/yadm/metadata.xml
new file mode 100644
index 000000000000..1151270bb4ea
--- /dev/null
+++ b/app-admin/yadm/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">TheLocehiliosan/yadm</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ yadm is a dotfile manager that handles the hassle of synchronizing the
+ dotfiles in your home folder across different workstations. It has a
+ philosophy using git and getting out of git's way to ensure it does what it
+ does best. What sets it apart is that it supports encryption, which enables
+ you to add files like mutt configuration with passwords and host it
+ publicly. It also enables you to add suffixes to your files like
+ ##Linux.hostname, and yadm will automatically symlink the file if you are
+ on that hostname.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-admin/yadm/yadm-1.07.ebuild b/app-admin/yadm/yadm-1.07.ebuild
new file mode 100644
index 000000000000..7c5907088202
--- /dev/null
+++ b/app-admin/yadm/yadm-1.07.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A dotfile manager for the config files in your home folder"
+HOMEPAGE="https://github.com/TheLocehiliosan/yadm/"
+SRC_URI="https://github.com/TheLocehiliosan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DOCS=( CHANGES CONTRIBUTORS README.md )
+
+DEPEND="
+ test? (
+ dev-tcltk/expect
+ dev-util/bats
+ dev-vcs/git
+ )"
+RDEPEND="
+ app-crypt/gnupg
+ dev-vcs/git"
+
+src_compile() {
+ emake yadm.md
+}
+
+src_test() {
+ # 109_accept_encryption tests are interactive, thus fail. Skip them
+ while IFS="" read -d $'\0' -r f ; do
+ bats "${f}" || die "Test ${f} failed"
+ done < <(find test -name '*.bats' -and -not -name '109_accept_encryption.bats' -print0)
+}
+
+src_install() {
+ einstalldocs
+
+ dobin "${PN}"
+ doman "${PN}.1"
+}
diff --git a/app-admin/yadm/yadm-1.12.0.ebuild b/app-admin/yadm/yadm-1.12.0.ebuild
new file mode 100644
index 000000000000..e6b2381a71ff
--- /dev/null
+++ b/app-admin/yadm/yadm-1.12.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="A dotfile manager for the config files in your home folder"
+HOMEPAGE="https://github.com/TheLocehiliosan/yadm/"
+SRC_URI="https://github.com/TheLocehiliosan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="zsh-completion test"
+
+DEPEND="
+ test? (
+ dev-tcltk/expect
+ dev-util/bats
+ dev-vcs/git
+ )"
+
+RDEPEND="
+ dev-vcs/git
+ app-crypt/gnupg
+ zsh-completion? ( app-shells/gentoo-zsh-completions )"
+
+src_compile() {
+ emake "${PN}.md"
+}
+
+src_test() {
+ # 109_accept_encryption tests are interactive, thus fail. Skip them
+ # 113_accept_jinja_alt.bats are depepending on the optional envtpl
+ while IFS="" read -d $'\0' -r f ; do
+ bats "${f}" || die "test ${f} failed"
+ done < <(find test -name '*.bats' -and -not -name '109_accept_encryption.bats' -and -not -name '113_accept_jinja_alt.bats' -print0)
+}
+
+src_install() {
+ einstalldocs
+
+ dobin "${PN}"
+ doman "${PN}.1"
+
+ dobashcomp completion/yadm.bash_completion
+
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ newins completion/yadm.zsh_completion _${PN}
+ fi
+}