summaryrefslogtreecommitdiff
path: root/app-admin/yadm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/yadm
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/yadm')
-rw-r--r--app-admin/yadm/Manifest4
-rw-r--r--app-admin/yadm/metadata.xml18
-rw-r--r--app-admin/yadm/yadm-1.07.ebuild43
3 files changed, 65 insertions, 0 deletions
diff --git a/app-admin/yadm/Manifest b/app-admin/yadm/Manifest
new file mode 100644
index 000000000000..b54d4377cfe3
--- /dev/null
+++ b/app-admin/yadm/Manifest
@@ -0,0 +1,4 @@
+DIST yadm-1.07.tar.gz 34240 SHA256 39f3974c7d8f3930b9dee00d5b1b2181976e60a4e2cd26c35597951c5919a4f6 SHA512 9bbe33c82a137375cb27916ae5b5a06f06c25a75ae05688be473103c29154309d3472accc0aa0670a80a4714bc6523ab85c41fd6aa8d1909586437c5778b9144 WHIRLPOOL 615c2411f86f284159e1d9623fabc1600ed1c532bcac31b3a06e8ef11ae6685e11fe14a1b914c10eac1802f8edcd8f9e6f8b67a74b0b121f55243e846886e70a
+EBUILD yadm-1.07.ebuild 895 SHA256 97ef54365bc7ce5d8bb0e1d093941f9247d89cbcd828e532b2c2fb8f1f0da4f9 SHA512 7313f9adeb78b32db14351ddead4d8c13cc81c49ec3cc7ea9d78ed4318bee9704d99890a9fc403679069e830583acbe8e37d32bcf91cf4fc25839f9715a239fa WHIRLPOOL c155e08e9372d9ca97c228063edeaa0b3065aa8d2b812c60a84e0c8b352ee5959a5a9e3be8f1c870d171c90b792524016223e3ba21931be70244412a45249470
+MISC ChangeLog 932 SHA256 d532de1b20c1f7042dd86143c291d6000be208f63236c3d9588aa9a193b3bf4b SHA512 1a20ce8fc829ef5cbddd1ef24eb14e85284ed25a7ac71b4a6b01b249bda7d40b61b7e1c839aed5c99aae34283ae241be6ee0815d35184d15391934529668ae9b WHIRLPOOL e0b4aeaa514edbd8f4c2c5f93230e5cf9db728368d28fe8b058895087b804d9caadc21968ff5fd431269b8acce12d431045e2143e37de6e7855bd4bed210f96e
+MISC metadata.xml 825 SHA256 f41c06318b490ddf8b64c83d54cd5e979f4b1147536c296639c7feeb87b1ac34 SHA512 0c8facf902245118eab0d6c4b48eb5a2fb63aa6cb7fe4581cc0353bd164912b7620eb2f42984b45410065d3a6e1af1cffa5028f5c26a4ecd38a9983da6b34feb WHIRLPOOL bf83415335e09f9b591eda821f521559e0c8232babb22db27300327b12817190b5bc3fca762fa2d25f63d3918fab6bea54888177145bdeddc5a0874383684e1d
diff --git a/app-admin/yadm/metadata.xml b/app-admin/yadm/metadata.xml
new file mode 100644
index 000000000000..1151270bb4ea
--- /dev/null
+++ b/app-admin/yadm/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">TheLocehiliosan/yadm</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ yadm is a dotfile manager that handles the hassle of synchronizing the
+ dotfiles in your home folder across different workstations. It has a
+ philosophy using git and getting out of git's way to ensure it does what it
+ does best. What sets it apart is that it supports encryption, which enables
+ you to add files like mutt configuration with passwords and host it
+ publicly. It also enables you to add suffixes to your files like
+ ##Linux.hostname, and yadm will automatically symlink the file if you are
+ on that hostname.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-admin/yadm/yadm-1.07.ebuild b/app-admin/yadm/yadm-1.07.ebuild
new file mode 100644
index 000000000000..7c5907088202
--- /dev/null
+++ b/app-admin/yadm/yadm-1.07.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A dotfile manager for the config files in your home folder"
+HOMEPAGE="https://github.com/TheLocehiliosan/yadm/"
+SRC_URI="https://github.com/TheLocehiliosan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DOCS=( CHANGES CONTRIBUTORS README.md )
+
+DEPEND="
+ test? (
+ dev-tcltk/expect
+ dev-util/bats
+ dev-vcs/git
+ )"
+RDEPEND="
+ app-crypt/gnupg
+ dev-vcs/git"
+
+src_compile() {
+ emake yadm.md
+}
+
+src_test() {
+ # 109_accept_encryption tests are interactive, thus fail. Skip them
+ while IFS="" read -d $'\0' -r f ; do
+ bats "${f}" || die "Test ${f} failed"
+ done < <(find test -name '*.bats' -and -not -name '109_accept_encryption.bats' -print0)
+}
+
+src_install() {
+ einstalldocs
+
+ dobin "${PN}"
+ doman "${PN}.1"
+}