summaryrefslogtreecommitdiff
path: root/app-admin/yadm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /app-admin/yadm
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'app-admin/yadm')
-rw-r--r--app-admin/yadm/Manifest2
-rw-r--r--app-admin/yadm/yadm-3.1.1.ebuild88
2 files changed, 90 insertions, 0 deletions
diff --git a/app-admin/yadm/Manifest b/app-admin/yadm/Manifest
index 34fd55272f63..2e66c69a9e25 100644
--- a/app-admin/yadm/Manifest
+++ b/app-admin/yadm/Manifest
@@ -1,3 +1,5 @@
DIST yadm-2.4.0.tar.gz 96877 BLAKE2B 462a5816e106c4502007ff34ab338904e14a9851ebcfc7ff79a32a8b11fbbe3e0b7e6538ed6b489ab67e2205c84b2250749e3091c77fa663886dc9792078a576 SHA512 43e16a9502f9dd9f6c6dba3bb5403bb048244a406d44cb42a96a43e62bf7342efd5f302304dbedede61423546787fc929f378d68da9031207e70239ec4e265ce
+DIST yadm-3.1.1.tar.gz 106890 BLAKE2B c85bfdaf15da8e88aea8e1b41af5396111fe95922f38c9709d09d76b6cb515d4aff99f0caaa225baf36bc408f6efe7f53e7b2febd45c78acf2b5f3c897b87290 SHA512 6be40ff6b1130be93649bb533d63ddc2dad626bb3022392863b600b31eef2529df443a9eb24915979bef2d1ea4ef04124668723ffb0ce0f86727f481a3997c74
EBUILD yadm-2.4.0.ebuild 1566 BLAKE2B ee2b55e4039b9d3718ecc08dc23b393a8999369fab0c5bc01c279a54de2922a1c79215dea8f05d95735a6e19f98b30e4fdf476afa2c8c26e4f2d784c944efa0e SHA512 833c8a2822ad71029bfce0d36b500d0f278ad831785465193b2abf3b3ee293a9674002dbb8483449d2bae28dd3dd27e40b16ecf3624af23aa420b8373c7e3223
+EBUILD yadm-3.1.1.ebuild 2147 BLAKE2B c41819203892ca9a8e4d917a764467e726ce7b744fcce2ae88c0954e92d6db865e6b554c188cdf5954afa58098b0827db2197a810306bf8536d4c685868d4458 SHA512 9802bec047a4790a250585fb660ae7481bb0fc5e5a09f7495977d6d06572ae08b3242f6678ef082a1d8c499c066008660d4e4b59fd86dca48417178e8715afcb
MISC metadata.xml 826 BLAKE2B 79c41680142d275a20557b3a0aca5f664542f45a34f3a09c42ab7dc15cec352462521b94f2c647b09e3801883c4a8c37d14b2d71e75fe12e16c7346cc7fb733e SHA512 d3d6100185add752cd59346eb6c6c4ee0026a6f409d63ae37ca58b9e7396b5be76794a341846d898a3c1724967e71097ff30ee331c4d0640ed0de8430ab177e9
diff --git a/app-admin/yadm/yadm-3.1.1.ebuild b/app-admin/yadm/yadm-3.1.1.ebuild
new file mode 100644
index 000000000000..b2d7cb882037
--- /dev/null
+++ b/app-admin/yadm/yadm-3.1.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 python-any-r1 python-utils-r1
+
+DESCRIPTION="Git based tool for managing dotfiles"
+HOMEPAGE="https://github.com/TheLocehiliosan/yadm"
+SRC_URI="https://github.com/TheLocehiliosan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-shells/bash
+ app-crypt/gnupg
+ dev-vcs/git
+"
+
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ')
+ dev-tcltk/expect
+ )
+"
+
+python_check_deps() {
+ has_version -b "dev-python/pytest[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_compile() {
+ emake "${PN}.md"
+}
+
+src_test() {
+ # prevent system config having influence on tests
+ local -x GIT_CONFIG_NOSYSTEM=1
+
+ # prevent git branch warning, it confuses tests
+ local -x GIT_CONFIG_GLOBAL="${HOME}/.gitconfig"
+ git config --global init.defaultBranch master || die "setting default branch name failed"
+
+ # un-hardcode path to tmp, otherwise encryption tests fail
+ sed -i "s@^cache_dir = /tmp@cache_dir = ${TMPDIR}@" pytest.ini || die
+
+ local EPYTEST_DESELECT=(
+ test/test_alt.py # requires envtpl, not packaged
+ test/test_compat_jinja.py # ditto
+ test/test_unit_template_j2.py # ditto
+ test/test_syntax.py # needs new yamllint, not packaged yet
+ test/test_upgrade.py::test_upgrade # needs old version of yadm
+ test/test_compat_alt.py # tests obsolete features, broken
+ test/test_unit_template_esh.py # requires esh, not packaged
+ test/test_encryption.py::test_symmetric_encrypt[clean-encrypt_exists-bad_phrase] # hangs in sandbox
+ test/test_encryption.py::test_symmetric_encrypt[overwrite-encrypt_exists-bad_phrase] # ditto
+ )
+
+ epytest
+}
+
+src_install() {
+ einstalldocs
+
+ dobin "${PN}"
+ doman "${PN}.1"
+
+ dobashcomp completion/bash/yadm
+
+ insinto /usr/share/zsh/site-functions
+ doins completion/zsh/_${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completion/fish/${PN}.fish
+}