summaryrefslogtreecommitdiff
path: root/app-admin/webapp-config
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-27 09:59:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-27 09:59:33 +0100
commitfdfde9fd41778789aaab6711adb9e4cc31c28360 (patch)
treeec3cf38d18dc8f9661b8914caec46bde349cab9d /app-admin/webapp-config
parenteb90394012a5d0ba3c13992fb861eb3387728c92 (diff)
gentoo auto-resync : 27:08:2023 - 09:59:33
Diffstat (limited to 'app-admin/webapp-config')
-rw-r--r--app-admin/webapp-config/Manifest1
-rw-r--r--app-admin/webapp-config/webapp-config-1.55-r2.ebuild72
2 files changed, 0 insertions, 73 deletions
diff --git a/app-admin/webapp-config/Manifest b/app-admin/webapp-config/Manifest
index ec8fc1f7eaa0..4067d9623eb7 100644
--- a/app-admin/webapp-config/Manifest
+++ b/app-admin/webapp-config/Manifest
@@ -1,5 +1,4 @@
DIST webapp-config-1.55.tar.bz2 72583 BLAKE2B be958dc991f0e1f6835d9c29350b7d97e3f23d52971f6013165ce59a8f4b32ac6262c9719956d1bcdbe60797f07d77910b44a749ae545c4dc15f765525144709 SHA512 44294b276fd036908438cd984ebf70433639caa18d8330bab348433b4f39ea2c42c57fa8de4f0a6198f7875429a3ef9ebe61321c288d910f9be8b3414865f438
-EBUILD webapp-config-1.55-r2.ebuild 1787 BLAKE2B 1b17975c92e0fbc0160e1e413dfb812ec5dd6966357408abc7f2db2478a83182e833650e416e288b74a4923ab3397c198f7d55d0b70e7ff4f524c40973bba959 SHA512 c910db16d538246dba10e62f22ef896752dbbf0d4a9fe5cdc5e78604447eb132d4783f525ff87337bbf876bcc23aef2e41e8f3ccedd7b962fb95a4ebc10027fb
EBUILD webapp-config-1.55-r3.ebuild 2454 BLAKE2B 8e4807d5a9daba21868277eb49f877ff9f72f6a435eaba51c32530382a1d347d6c8b2adf600a2b39f825512c7e03cd7a60600f9947b75108869fb9d696dd2671 SHA512 277d1ab115d57eef90c8af161e61be7ec424d0a4578edfadae2d9f06e7f372744d47f863cc5abc5138afca5d7d4d964e6735d6fa54e5b13e386eccd964924908
EBUILD webapp-config-9999.ebuild 2461 BLAKE2B 190826599765147db3d87c3af1b753946baebc1c6d2ede348341188e4586fda6662a3f11cb37e5ed1a5d2f93fe995fd265c7da07ea3f295b4c4502520f872b63 SHA512 a6a166671465821d6fb6ccbd27e0e70e2efccb61a7117b166e063e9afa91f2c1140e380b02fd88fa1cdf8611525c0679b9d6d0ea61b41b44e3733bda43fc5b88
MISC metadata.xml 448 BLAKE2B 14bff33f87640b065d72b7bd98742c602e1cd30be80cde6bbc5bd923cb8529f55e4296e83e630e55a9c8342da063dc3762f515bccd2614fc50d68770260fd727 SHA512 20db75371335720225afe0111925fe6ba3979448987a27459786a4490b862073ac23374ba29c218e523ea465fb811c7686d5a36e073a35a2a2b2c4521b6961f2
diff --git a/app-admin/webapp-config/webapp-config-1.55-r2.ebuild b/app-admin/webapp-config/webapp-config-1.55-r2.ebuild
deleted file mode 100644
index daf5ce1eeff8..000000000000
--- a/app-admin/webapp-config/webapp-config-1.55-r2.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 prefix
-
-if [[ ${PV} = 9999* ]]
-then
- EGIT_REPO_URI="https://anongit.gentoo.org/proj/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://dev.gentoo.org/~blueness/${PN}/${P}.tar.bz2"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-fi
-
-DESCRIPTION="Gentoo's installer for web-based applications"
-HOMEPAGE="https://sourceforge.net/projects/webapp-config/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+portage"
-
-DEPEND="app-text/xmlto
- sys-apps/gentoo-functions"
-RDEPEND="
- portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
- eprefixify WebappConfig/eprefix.py config/webapp-config
-}
-
-python_compile_all() {
- emake -C doc/
-}
-
-python_test() {
- PYTHONPATH="." "${EPYTHON}" WebappConfig/tests/external.py -v ||
- die "Testing failed with ${EPYTHON}"
-}
-
-python_install() {
- # According to this discussion:
- # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
- # distutils does not provide for specifying two different script install
- # locations. Since we only install one script here the following should
- # be ok
- distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /etc/vhosts
- doins config/webapp-config
-
- keepdir /usr/share/webapps
- keepdir /var/db/webapps
-
- dodoc AUTHORS
- doman doc/*.[58]
-}
-
-pkg_postinst() {
- elog "Now that you have upgraded webapp-config, you **must** update your"
- elog "config files in /etc/vhosts/webapp-config before you emerge any"
- elog "packages that use webapp-config."
-}