summaryrefslogtreecommitdiff
path: root/app-admin/webapp-config
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-07 17:57:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-07 17:57:54 +0000
commitbc75b42f7650c33ffdb61e5e29b0b96cb9111932 (patch)
tree867908c0cf83e6015a5b1544cfdc4e17f1c13753 /app-admin/webapp-config
parentb3fef92e618039dc93153a93176184a49606c74a (diff)
gentoo auto-resync : 07:03:2023 - 17:57:54
Diffstat (limited to 'app-admin/webapp-config')
-rw-r--r--app-admin/webapp-config/Manifest4
-rw-r--r--app-admin/webapp-config/webapp-config-1.55-r2.ebuild22
-rw-r--r--app-admin/webapp-config/webapp-config-9999.ebuild12
3 files changed, 22 insertions, 16 deletions
diff --git a/app-admin/webapp-config/Manifest b/app-admin/webapp-config/Manifest
index 68ded171d8a4..a94f39bbc4ab 100644
--- a/app-admin/webapp-config/Manifest
+++ b/app-admin/webapp-config/Manifest
@@ -1,4 +1,4 @@
DIST webapp-config-1.55.tar.bz2 72583 BLAKE2B be958dc991f0e1f6835d9c29350b7d97e3f23d52971f6013165ce59a8f4b32ac6262c9719956d1bcdbe60797f07d77910b44a749ae545c4dc15f765525144709 SHA512 44294b276fd036908438cd984ebf70433639caa18d8330bab348433b4f39ea2c42c57fa8de4f0a6198f7875429a3ef9ebe61321c288d910f9be8b3414865f438
-EBUILD webapp-config-1.55-r2.ebuild 1675 BLAKE2B abfcb263604f1c9e44e0a257a670459dd1553b248a227ea471d9dbbeac98268d2669d23d23fc5106cb117bf077b76377ccca47be8c94b3bc556cc53b127c9ef8 SHA512 544a9d0234d8882e4b65d91e27422b6ba8b476e4951909778bfa29a384ead694ec6e8502e89429185ecbdcde74c620884babaf11aca8c83984b1babfaeb9ef26
-EBUILD webapp-config-9999.ebuild 1780 BLAKE2B edfcef7369b5cf66bb6efe9618028c4616e2b22dbf4d86427c47019b12696d2fdb75390acfa99adbf65e6d8490463f1704688372a5a44e0e9b6cee4cde10bcf9 SHA512 4aba8466f98061628e5c99a3d8e1e147626d4ef90bca1542b0a731d592d5732678ebc1d416e1565ba3b113aee6f1421c99fb4b4333fb9da333b3072751e72f16
+EBUILD webapp-config-1.55-r2.ebuild 1787 BLAKE2B 1b17975c92e0fbc0160e1e413dfb812ec5dd6966357408abc7f2db2478a83182e833650e416e288b74a4923ab3397c198f7d55d0b70e7ff4f524c40973bba959 SHA512 c910db16d538246dba10e62f22ef896752dbbf0d4a9fe5cdc5e78604447eb132d4783f525ff87337bbf876bcc23aef2e41e8f3ccedd7b962fb95a4ebc10027fb
+EBUILD webapp-config-9999.ebuild 1780 BLAKE2B c3c028949ecda5556b24430d4000b0f1f5f7f7c1ad17de4f90d9cf052e39846bf0d64721d92e3f5e9a4e764c85a311748b885b0d7c598d0d1f8717f038979a56 SHA512 298f6473a69b57353720c14034861382178006173a8e850159922dc20d10a823c9e31407046d4bb64d371967448d0c41d73ea127bf9dcc8f88ac39f44ad38236
MISC metadata.xml 448 BLAKE2B 14bff33f87640b065d72b7bd98742c602e1cd30be80cde6bbc5bd923cb8529f55e4296e83e630e55a9c8342da063dc3762f515bccd2614fc50d68770260fd727 SHA512 20db75371335720225afe0111925fe6ba3979448987a27459786a4490b862073ac23374ba29c218e523ea465fb811c7686d5a36e073a35a2a2b2c4521b6961f2
diff --git a/app-admin/webapp-config/webapp-config-1.55-r2.ebuild b/app-admin/webapp-config/webapp-config-1.55-r2.ebuild
index 9ef0f49f155f..daf5ce1eeff8 100644
--- a/app-admin/webapp-config/webapp-config-1.55-r2.ebuild
+++ b/app-admin/webapp-config/webapp-config-1.55-r2.ebuild
@@ -4,12 +4,18 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 prefix
-SRC_URI="https://dev.gentoo.org/~twitch153/${PN}/${P}.tar.bz2"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+if [[ ${PV} = 9999* ]]
+then
+ EGIT_REPO_URI="https://anongit.gentoo.org/proj/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~blueness/${PN}/${P}.tar.bz2"
+ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+fi
DESCRIPTION="Gentoo's installer for web-based applications"
HOMEPAGE="https://sourceforge.net/projects/webapp-config/"
@@ -32,6 +38,11 @@ python_compile_all() {
emake -C doc/
}
+python_test() {
+ PYTHONPATH="." "${EPYTHON}" WebappConfig/tests/external.py -v ||
+ die "Testing failed with ${EPYTHON}"
+}
+
python_install() {
# According to this discussion:
# http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
@@ -54,11 +65,6 @@ python_install_all() {
doman doc/*.[58]
}
-python_test() {
- PYTHONPATH="." "${EPYTHON}" WebappConfig/tests/external.py -v ||
- die "Testing failed with ${EPYTHON}"
-}
-
pkg_postinst() {
elog "Now that you have upgraded webapp-config, you **must** update your"
elog "config files in /etc/vhosts/webapp-config before you emerge any"
diff --git a/app-admin/webapp-config/webapp-config-9999.ebuild b/app-admin/webapp-config/webapp-config-9999.ebuild
index 80bc77e30465..9aad95348cfe 100644
--- a/app-admin/webapp-config/webapp-config-9999.ebuild
+++ b/app-admin/webapp-config/webapp-config-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 prefix
@@ -38,6 +38,11 @@ python_compile_all() {
emake -C doc/
}
+python_test() {
+ PYTHONPATH="." "${EPYTHON}" WebappConfig/tests/external.py -v ||
+ die "Testing failed with ${EPYTHON}"
+}
+
python_install() {
# According to this discussion:
# http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
@@ -60,11 +65,6 @@ python_install_all() {
doman doc/*.[58]
}
-python_test() {
- PYTHONPATH="." "${EPYTHON}" WebappConfig/tests/external.py -v ||
- die "Testing failed with ${EPYTHON}"
-}
-
pkg_postinst() {
elog "Now that you have upgraded webapp-config, you **must** update your"
elog "config files in /etc/vhosts/webapp-config before you emerge any"