summaryrefslogtreecommitdiff
path: root/app-admin/webapp-config
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-08 10:19:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-08 10:19:19 +0100
commit92ebda186167f9887d5f43803ced730b499dcf57 (patch)
treeee0e4261f26516d8b6bdaa4c330eee878d9ca136 /app-admin/webapp-config
parentd84be18029b166ee26fe5416098974a8d05b2983 (diff)
gentoo auto-resync : 08:07:2023 - 10:19:19
Diffstat (limited to 'app-admin/webapp-config')
-rw-r--r--app-admin/webapp-config/Manifest3
-rw-r--r--app-admin/webapp-config/webapp-config-1.55-r3.ebuild87
-rw-r--r--app-admin/webapp-config/webapp-config-9999.ebuild27
3 files changed, 110 insertions, 7 deletions
diff --git a/app-admin/webapp-config/Manifest b/app-admin/webapp-config/Manifest
index a94f39bbc4ab..1598074d7ff7 100644
--- a/app-admin/webapp-config/Manifest
+++ b/app-admin/webapp-config/Manifest
@@ -1,4 +1,5 @@
DIST webapp-config-1.55.tar.bz2 72583 BLAKE2B be958dc991f0e1f6835d9c29350b7d97e3f23d52971f6013165ce59a8f4b32ac6262c9719956d1bcdbe60797f07d77910b44a749ae545c4dc15f765525144709 SHA512 44294b276fd036908438cd984ebf70433639caa18d8330bab348433b4f39ea2c42c57fa8de4f0a6198f7875429a3ef9ebe61321c288d910f9be8b3414865f438
EBUILD webapp-config-1.55-r2.ebuild 1787 BLAKE2B 1b17975c92e0fbc0160e1e413dfb812ec5dd6966357408abc7f2db2478a83182e833650e416e288b74a4923ab3397c198f7d55d0b70e7ff4f524c40973bba959 SHA512 c910db16d538246dba10e62f22ef896752dbbf0d4a9fe5cdc5e78604447eb132d4783f525ff87337bbf876bcc23aef2e41e8f3ccedd7b962fb95a4ebc10027fb
-EBUILD webapp-config-9999.ebuild 1780 BLAKE2B c3c028949ecda5556b24430d4000b0f1f5f7f7c1ad17de4f90d9cf052e39846bf0d64721d92e3f5e9a4e764c85a311748b885b0d7c598d0d1f8717f038979a56 SHA512 298f6473a69b57353720c14034861382178006173a8e850159922dc20d10a823c9e31407046d4bb64d371967448d0c41d73ea127bf9dcc8f88ac39f44ad38236
+EBUILD webapp-config-1.55-r3.ebuild 2461 BLAKE2B 190826599765147db3d87c3af1b753946baebc1c6d2ede348341188e4586fda6662a3f11cb37e5ed1a5d2f93fe995fd265c7da07ea3f295b4c4502520f872b63 SHA512 a6a166671465821d6fb6ccbd27e0e70e2efccb61a7117b166e063e9afa91f2c1140e380b02fd88fa1cdf8611525c0679b9d6d0ea61b41b44e3733bda43fc5b88
+EBUILD webapp-config-9999.ebuild 2461 BLAKE2B 190826599765147db3d87c3af1b753946baebc1c6d2ede348341188e4586fda6662a3f11cb37e5ed1a5d2f93fe995fd265c7da07ea3f295b4c4502520f872b63 SHA512 a6a166671465821d6fb6ccbd27e0e70e2efccb61a7117b166e063e9afa91f2c1140e380b02fd88fa1cdf8611525c0679b9d6d0ea61b41b44e3733bda43fc5b88
MISC metadata.xml 448 BLAKE2B 14bff33f87640b065d72b7bd98742c602e1cd30be80cde6bbc5bd923cb8529f55e4296e83e630e55a9c8342da063dc3762f515bccd2614fc50d68770260fd727 SHA512 20db75371335720225afe0111925fe6ba3979448987a27459786a4490b862073ac23374ba29c218e523ea465fb811c7686d5a36e073a35a2a2b2c4521b6961f2
diff --git a/app-admin/webapp-config/webapp-config-1.55-r3.ebuild b/app-admin/webapp-config/webapp-config-1.55-r3.ebuild
new file mode 100644
index 000000000000..76caefb23e6d
--- /dev/null
+++ b/app-admin/webapp-config/webapp-config-1.55-r3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 prefix
+
+if [[ ${PV} = 9999* ]]
+then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~ceamac/${CATEGORY}/${PN}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Gentoo's installer for web-based applications"
+HOMEPAGE="https://sourceforge.net/projects/webapp-config/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+portage"
+
+DEPEND="app-text/xmlto
+ sys-apps/gentoo-functions"
+RDEPEND="
+ portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # make the source from svn mirror the one in the tarball
+ if [[ ${PV} == 9999* ]]; then
+ mkdir ../webapp-config || die "Cannot create temp directory."
+ cp -r * ../webapp-config || die "Cannot copy all into the temp directory."
+ mv ../webapp-config . || die "Cannot move temp directory to its final position."
+
+ # Installation fails if version is 1.55-git
+ sed -e 's/-git//' \
+ -i webapp-config/WebappConfig/version.py \
+ -i WebappConfig/version.py || die "Cannot fix version."
+ fi
+
+ distutils-r1_python_prepare_all
+ eprefixify WebappConfig/eprefix.py config/webapp-config
+}
+
+python_compile_all() {
+ emake -C doc/
+}
+
+python_test() {
+ PYTHONPATH="." "${EPYTHON}" WebappConfig/tests/external.py -v ||
+ die "Testing failed with ${EPYTHON}"
+}
+
+python_install() {
+ # According to this discussion:
+ # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
+ # distutils does not provide for specifying two different script install
+ # locations. Since we only install one script here the following should
+ # be ok
+ distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # distutils-r1 installs the scripts in /usr/bin in PEP517 mode
+ mv "${ED}"/usr/bin "${ED}"/usr/sbin || die "Cannot rename scripts directory to /usr/sbin"
+
+ insinto /etc/vhosts
+ doins config/webapp-config
+
+ keepdir /usr/share/webapps
+ keepdir /var/db/webapps
+
+ dodoc AUTHORS
+ doman doc/*.[58]
+}
+
+pkg_postinst() {
+ elog "Now that you have upgraded webapp-config, you **must** update your"
+ elog "config files in /etc/vhosts/webapp-config before you emerge any"
+ elog "packages that use webapp-config."
+}
diff --git a/app-admin/webapp-config/webapp-config-9999.ebuild b/app-admin/webapp-config/webapp-config-9999.ebuild
index 9aad95348cfe..76caefb23e6d 100644
--- a/app-admin/webapp-config/webapp-config-9999.ebuild
+++ b/app-admin/webapp-config/webapp-config-9999.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1 prefix
if [[ ${PV} = 9999* ]]
then
- EGIT_REPO_URI="https://anongit.gentoo.org/proj/${PN}.git"
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/${PN}.git"
inherit git-r3
else
- SRC_URI="https://dev.gentoo.org/~blueness/${PN}/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+ SRC_URI="https://dev.gentoo.org/~ceamac/${CATEGORY}/${PN}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
DESCRIPTION="Gentoo's installer for web-based applications"
@@ -30,6 +30,18 @@ RDEPEND="
portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
python_prepare_all() {
+ # make the source from svn mirror the one in the tarball
+ if [[ ${PV} == 9999* ]]; then
+ mkdir ../webapp-config || die "Cannot create temp directory."
+ cp -r * ../webapp-config || die "Cannot copy all into the temp directory."
+ mv ../webapp-config . || die "Cannot move temp directory to its final position."
+
+ # Installation fails if version is 1.55-git
+ sed -e 's/-git//' \
+ -i webapp-config/WebappConfig/version.py \
+ -i WebappConfig/version.py || die "Cannot fix version."
+ fi
+
distutils-r1_python_prepare_all
eprefixify WebappConfig/eprefix.py config/webapp-config
}
@@ -55,6 +67,9 @@ python_install() {
python_install_all() {
distutils-r1_python_install_all
+ # distutils-r1 installs the scripts in /usr/bin in PEP517 mode
+ mv "${ED}"/usr/bin "${ED}"/usr/sbin || die "Cannot rename scripts directory to /usr/sbin"
+
insinto /etc/vhosts
doins config/webapp-config