summaryrefslogtreecommitdiff
path: root/app-admin/watchfolder
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/watchfolder
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/watchfolder')
-rw-r--r--app-admin/watchfolder/Manifest5
-rw-r--r--app-admin/watchfolder/files/0.3.3-64bit.patch11
-rw-r--r--app-admin/watchfolder/files/0.3.3-fortify-sources.patch11
-rw-r--r--app-admin/watchfolder/metadata.xml8
-rw-r--r--app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild43
5 files changed, 78 insertions, 0 deletions
diff --git a/app-admin/watchfolder/Manifest b/app-admin/watchfolder/Manifest
new file mode 100644
index 000000000000..3d12d6a494ea
--- /dev/null
+++ b/app-admin/watchfolder/Manifest
@@ -0,0 +1,5 @@
+AUX 0.3.3-64bit.patch 450 BLAKE2B 8d88a4677bf59cdd95a6dc539364ef8aab46ab40e59107ba88198113bc79d1b61cdbe88e52a8c9cd805e4133dee2bde9bf068ce8a2822bb5a7201c118ef29a7a SHA512 86d6e072904fed5a168398fd80f648b30a9346745dac7b6ee460122e205f8f627aa4bfff78b007726af95b711c4bb91ca8282ca1a000e6954bf6d33e399f18c0
+AUX 0.3.3-fortify-sources.patch 410 BLAKE2B d44f872bd89cb0c3cccaf5b70e6293937340562ee71ff73185ff466b6dbac1e3b4854afa6eecec6558e36a070a9ed4a1efa275dde5d91ff0f1084509bcd60054 SHA512 0e3b372b9eaf1f4874ecbf7135ed67e1dcf62366516215a5d5fc5a1288893385b24f1d34855fc134eaad0dc29562ec4de0c90365ce87b7071234fcb1750e4676
+DIST watchfolder-0.3.3.tar.gz 86741 BLAKE2B d834f8aade7e648e27f95ca896355ec07afb24bac0f0116280f374e763c6fca8e7e7ffca7850d54b11fdf1c1ccfe8d28bd52a527eeb7110d4783a55de28828fb SHA512 162a3535748d280d06db8b05ddc4c87b578ff4be08aeb7a08858c28fd4612f46c4b8ed866513283edcd6ad24207c94a02e562200ae102d1897b4b28be6717dc6
+EBUILD watchfolder-0.3.3-r1.ebuild 877 BLAKE2B 6ae578f60dd9cfbd43367aa8f3fa77cd669a77c7bc92c30fc02181fab6ef3db89b9bab49c751a768f442486fe70314521f3ccf32ca2fc4c6eaa7a84ec3ce6465 SHA512 d84172d22d08f541039e3b74816d2745ac0dd8484bd912c3e81ef20d42aed241aa3bf310c14903e6619765010bb167d343f8c8c3abec7e9949bfafd3e68a60f2
+MISC metadata.xml 241 BLAKE2B f902bc0becbcf0a1830c4b9dca2ae4acd8ae91741ff1b6bf7cc68a08be61a26293b94c7690a06446e84f38d46dfe4c22c52a9e736b426c535b82acccb644b13c SHA512 9e7d032c1d5e4be915c726c4a312eb2bdad6eb036827f2aceecf5f370bbc255e72ee420816646fe639a607dee0f5d112d843e897183f8c587ec866fe8248b452
diff --git a/app-admin/watchfolder/files/0.3.3-64bit.patch b/app-admin/watchfolder/files/0.3.3-64bit.patch
new file mode 100644
index 000000000000..070e9c019d26
--- /dev/null
+++ b/app-admin/watchfolder/files/0.3.3-64bit.patch
@@ -0,0 +1,11 @@
+--- a/watchd.c 2006-02-23 12:33:32.000000000 -0500
++++ b/watchd.c 2006-02-23 12:45:30.000000000 -0500
+@@ -176,7 +176,7 @@
+ // free(p2tmp);
+
+ p2tmp=strchr(p2,0xa); // Not very nice,
+- p2[(int)p2tmp-(int)p2]=0x00; // but in fact: It works ;)
++ *(p2+(p2tmp-p2))=0x00; // but in fact: It works ;)
+
+ while (p2[0]==' ') {p2++;} // Again, quick and dirty..
+ while (p1[strlen(p1)-1]==' ') {p1[strlen(p1)-1]=0;} // Need to say anything?;)
diff --git a/app-admin/watchfolder/files/0.3.3-fortify-sources.patch b/app-admin/watchfolder/files/0.3.3-fortify-sources.patch
new file mode 100644
index 000000000000..175e8ed29ec3
--- /dev/null
+++ b/app-admin/watchfolder/files/0.3.3-fortify-sources.patch
@@ -0,0 +1,11 @@
+--- a/watchd.c 2009-02-27 23:46:42.000000000 +0000
++++ b/watchd.c 2009-02-27 23:50:22.000000000 +0000
+@@ -671,7 +671,7 @@
+ {
+ if (folder->flags&FL_LOG_FILE)
+ {
+- log=open(curfolder->logfile, O_CREAT | O_WRONLY | O_APPEND );
++ log=open(curfolder->logfile, O_CREAT | O_WRONLY | O_APPEND, S_IRUSR | S_IWUSR );
+ if (log>0)
+ {
+ lseek(fd, SEEK_SET, 0); // Rewind temp log file..
diff --git a/app-admin/watchfolder/metadata.xml b/app-admin/watchfolder/metadata.xml
new file mode 100644
index 000000000000..b837dfa17fef
--- /dev/null
+++ b/app-admin/watchfolder/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="freshmeat">watchd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild b/app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild
new file mode 100644
index 000000000000..ff216bde996b
--- /dev/null
+++ b/app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="watches directories and processes files"
+HOMEPAGE="http://freshmeat.net/projects/watchd/"
+SRC_URI="http://dstunrea.sdf-eu.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ppc ~x86"
+
+S="${WORKDIR}/${P/folder/d}"
+
+PATCHES=(
+ # patch to remove warnings on 64 bit systems
+ "${FILESDIR}"/${PV}-64bit.patch
+ # and a gcc 4.3.3 / fortify_sources fix
+ "${FILESDIR}"/${PV}-fortify-sources.patch
+)
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/-c -o/s:OPT:CFLAGS:' \
+ -e 's:(\(LD\)\?OPT):(LDFLAGS) $(CFLAGS):' \
+ -e 's:gcc:$(CC):' \
+ Makefile || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin watchd
+ insinto /etc
+ doins watchd.conf
+ dodoc README doc/*
+}