summaryrefslogtreecommitdiff
path: root/app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild')
-rw-r--r--app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild b/app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild
new file mode 100644
index 000000000000..ff216bde996b
--- /dev/null
+++ b/app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="watches directories and processes files"
+HOMEPAGE="http://freshmeat.net/projects/watchd/"
+SRC_URI="http://dstunrea.sdf-eu.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ppc ~x86"
+
+S="${WORKDIR}/${P/folder/d}"
+
+PATCHES=(
+ # patch to remove warnings on 64 bit systems
+ "${FILESDIR}"/${PV}-64bit.patch
+ # and a gcc 4.3.3 / fortify_sources fix
+ "${FILESDIR}"/${PV}-fortify-sources.patch
+)
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/-c -o/s:OPT:CFLAGS:' \
+ -e 's:(\(LD\)\?OPT):(LDFLAGS) $(CFLAGS):' \
+ -e 's:gcc:$(CC):' \
+ Makefile || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin watchd
+ insinto /etc
+ doins watchd.conf
+ dodoc README doc/*
+}