summaryrefslogtreecommitdiff
path: root/app-admin/usbview/usbview-3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-admin/usbview/usbview-3.0.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-admin/usbview/usbview-3.0.ebuild')
-rw-r--r--app-admin/usbview/usbview-3.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/usbview/usbview-3.0.ebuild b/app-admin/usbview/usbview-3.0.ebuild
new file mode 100644
index 000000000000..217b6dadb3e2
--- /dev/null
+++ b/app-admin/usbview/usbview-3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info
+
+DESCRIPTION="Display the topology of devices on the USB bus"
+HOMEPAGE="http://www.kroah.com/linux-usb/ https://github.com/gregkh/usbview"
+SRC_URI="http://www.kroah.com/linux-usb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/imagemagick-tools[png,svg]
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ CONFIG_CHECK="~DEBUG_FS"
+ linux-info_pkg_setup
+}