summaryrefslogtreecommitdiff
path: root/app-admin/ttyplot/ttyplot-1.5.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-17 16:57:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-17 16:57:03 +0000
commit1fca4db26fb13c520980473abebd51f620d34531 (patch)
treebc3154f63a706e2b2583aeccb63997197e112c23 /app-admin/ttyplot/ttyplot-1.5.2.ebuild
parent27cf8f197a427c1c71255f86149344e3bf1be47d (diff)
gentoo auto-resync : 17:11:2023 - 16:57:03
Diffstat (limited to 'app-admin/ttyplot/ttyplot-1.5.2.ebuild')
-rw-r--r--app-admin/ttyplot/ttyplot-1.5.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-admin/ttyplot/ttyplot-1.5.2.ebuild b/app-admin/ttyplot/ttyplot-1.5.2.ebuild
new file mode 100644
index 000000000000..31b1533c83eb
--- /dev/null
+++ b/app-admin/ttyplot/ttyplot-1.5.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DESCRIPTION="Realtime plotting utility with data input from stdin"
+HOMEPAGE="https://github.com/tenox7/ttyplot"
+SRC_URI="https://github.com/tenox7/ttyplot/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ local args=(
+ PREFIX=/usr
+ MANPREFIX=/usr/share/man
+ DESTDIR="${D}"
+ )
+ emake "${args[@]}" install
+}