summaryrefslogtreecommitdiff
path: root/app-admin/tripwire/tripwire-2.4.3.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /app-admin/tripwire/tripwire-2.4.3.7.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'app-admin/tripwire/tripwire-2.4.3.7.ebuild')
-rw-r--r--app-admin/tripwire/tripwire-2.4.3.7.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/app-admin/tripwire/tripwire-2.4.3.7.ebuild b/app-admin/tripwire/tripwire-2.4.3.7.ebuild
index 423a09ff9917..b89e3608164d 100644
--- a/app-admin/tripwire/tripwire-2.4.3.7.ebuild
+++ b/app-admin/tripwire/tripwire-2.4.3.7.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools flag-o-matic
@@ -36,8 +36,17 @@ src_configure() {
# see #32613, #45823, and others.
# -taviso@gentoo.org
strip-flags
- append-cppflags -DCONFIG_DIR='"\"/etc/tripwire\""' -fno-strict-aliasing
- econf $(use_enable ssl openssl) $(use_enable static)
+
+ append-cppflags -DCONFIG_DIR='"\"/etc/tripwire\""'
+ append-flags -fno-strict-aliasing
+
+ # "integer.cpp:1162:24: error: reference to ‘byte’ is ambiguous"
+ # bug #786465
+ append-cxxflags -std=c++14
+
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable static)
}
src_install() {