summaryrefslogtreecommitdiff
path: root/app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild')
-rw-r--r--app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild b/app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild
new file mode 100644
index 000000000000..b1028a59fbb6
--- /dev/null
+++ b/app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Files which haven't been accessed are removed from specified directories"
+HOMEPAGE="https://fedorahosted.org/tmpwatch/"
+SRC_URI="https://fedorahosted.org/releases/t/m/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-tmpreaper )"
+DEPEND=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-boottime.patch"
+)
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ dosbin tmpwatch
+ doman tmpwatch.8
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/${PN}.cron" "${PN}"
+}