summaryrefslogtreecommitdiff
path: root/app-admin/testdisk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
commitdd762ff83c330186ee2ede002e08b2f780cddd51 (patch)
tree63198edcc3ad5df8e2566c28ff9bd8af50cc2174 /app-admin/testdisk
parent51af5f0eb4cddbe6aa7953717873691d77aae9ff (diff)
gentoo resync : 14.07.2019
Diffstat (limited to 'app-admin/testdisk')
-rw-r--r--app-admin/testdisk/Manifest2
-rw-r--r--app-admin/testdisk/testdisk-7.1.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/app-admin/testdisk/Manifest b/app-admin/testdisk/Manifest
index 8a33e6e5e665..0e01fb776768 100644
--- a/app-admin/testdisk/Manifest
+++ b/app-admin/testdisk/Manifest
@@ -1,3 +1,5 @@
DIST testdisk-6837474129968d7de13d91e5454bd824c9136e73.tar.gz 637265 BLAKE2B 7d7a2c875db9d34ad5be687ef0ccc8122759c645b30faf6eed7967747e69ac988078ab6c1909007c32c6bf5a879a5bfd00dff3d2d268e5b50e3b60a8b660c636 SHA512 b494e23ccd8f913a9b22f4b803b02af66e94f6971f45e6aea8a0e1dd8549996e7bdd3fafcf70078ebc242f262d064cdc5674d99cb7a367b810c45c0b1c40336d
+DIST testdisk-7.1.tar.bz2 742006 BLAKE2B ad67cbef73e502df39cd04537bae9226d043a0f5ed824ed24d5a5ac7c3262060d0c78bfcf38159890ee0c270e1cd7690cbf276eb919e1b4721357fffc8679c61 SHA512 ad6531eec45c1ed8d4a0ce6132692bb609c4c269fbca57f788ce808214e0b00b5fb1187745a859c5da8a3cb8de18b29904792d3246b15cedfa24bf24cbfe3df5
+EBUILD testdisk-7.1.ebuild 2333 BLAKE2B fbfe0ee753b893c872f3a04b8557b0e7a648bcbb769d3d2a5963fe760101b2a6ebafecc618fdfdcb0be13f8441d969d4439025c102306c3179372b4185053442 SHA512 aa0210fcc2150c2d7d096b1b78d7152bc245f9c6af0b7f97f6935469b9f39daf74fd3093654fe346a4cdcfb6b46ec5363cf61e56b3f92be8fd7184258dffaa44
EBUILD testdisk-7.1_pre20180922.ebuild 2517 BLAKE2B 2335b1e92f1b9d90e0d3e0f4e0a4088fbd4e60b1a39c6eea0cb248a8f2c51e4b083a36404904ef24357002d2dafff914ee3014e1388db0154492f7be7ed9df85 SHA512 9b9f99e977056372bb89d49e35b44f06edbc6f18edff5e555b99cbc91183422ec965e8e0f396d4e03387c15c719a74c1774b8ef3a8ff2543664ed02349b92601
MISC metadata.xml 555 BLAKE2B 4b56bad0ebd1af77d90c4fa650adba5ae59d06940dff5aa346cb0e9dc9ebfad5324f774cb1afa646e15731b41cb09d7020ee3b6a5a0d941452099b6b7884da75 SHA512 3c47ad35d151d92e4be40cd91c7f0ced271f7b61a00280f536cc70a700d25ae36426593fcb8aec76e9cf1c24ae76dc8290b00bbcb73fa4d95182210fa680562e
diff --git a/app-admin/testdisk/testdisk-7.1.ebuild b/app-admin/testdisk/testdisk-7.1.ebuild
new file mode 100644
index 000000000000..cbd57b54dca9
--- /dev/null
+++ b/app-admin/testdisk/testdisk-7.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic xdg-utils
+
+DESCRIPTION="Checks and undeletes partitions + PhotoRec, signature based recovery tool"
+HOMEPAGE="https://www.cgsecurity.org/wiki/TestDisk"
+SRC_URI="https://www.cgsecurity.org/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="ewf jpeg ntfs qt5 reiserfs static zlib"
+
+REQUIRED_USE="static? ( !qt5 )"
+
+# WARNING: reiserfs support does NOT work with reiserfsprogs
+# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
+COMMON_DEPEND="
+ static? (
+ sys-apps/util-linux[static-libs]
+ sys-fs/e2fsprogs[static-libs]
+ sys-libs/ncurses:0[static-libs]
+ jpeg? ( virtual/jpeg:0[static-libs] )
+ ntfs? ( sys-fs/ntfs3g:=[static-libs] )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8[static-libs] )
+ zlib? ( sys-libs/zlib[static-libs] )
+ !arm? ( ewf? ( app-forensics/libewf:=[static-libs] ) )
+ )
+ !static? (
+ sys-apps/util-linux
+ sys-fs/e2fsprogs
+ sys-libs/ncurses:0=
+ jpeg? ( virtual/jpeg:0 )
+ ntfs? ( sys-fs/ntfs3g )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
+ zlib? ( sys-libs/zlib )
+ !arm? ( ewf? ( app-forensics/libewf:= ) )
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ qt5? ( dev-qt/linguist-tools:5 )
+"
+RDEPEND="!static? ( ${COMMON_DEPEND} )"
+
+DOCS=()
+
+src_configure() {
+ local myconf=(
+ --enable-sudo
+ --without-ntfs
+ $(use_with ewf)
+ $(use_with jpeg)
+ $(use_with ntfs ntfs3g)
+ $(use_enable qt5 qt)
+ $(use_with reiserfs)
+ $(use_with zlib)
+ )
+
+ # this static method is the same used by upstream for their 'static' make
+ # target, but better, as it doesn't break.
+ use static && append-ldflags -static
+
+ econf "${myconf[@]}"
+
+ # perform safety checks for NTFS, REISERFS and JPEG
+ if use ntfs && ! egrep -q '^#define HAVE_LIBNTFS(3G)? 1$' "${S}"/config.h ; then
+ die "Failed to find either NTFS or NTFS-3G library."
+ fi
+ if use reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
+ die "Failed to find reiserfs library."
+ fi
+ if use jpeg && egrep -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
+ die "Failed to find jpeg library."
+ fi
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}