summaryrefslogtreecommitdiff
path: root/app-admin/testdisk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
commitc5283d322accc6097afec74eab24550829788bab (patch)
treeb99ce668128d82a026eaa31461643f9173f9b77b /app-admin/testdisk
parent5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (diff)
gentoo resync : 23.03.2018
Diffstat (limited to 'app-admin/testdisk')
-rw-r--r--app-admin/testdisk/Manifest2
-rw-r--r--app-admin/testdisk/testdisk-7.1_pre20180322.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/app-admin/testdisk/Manifest b/app-admin/testdisk/Manifest
index 850fb7df86b3..d9115b7e191f 100644
--- a/app-admin/testdisk/Manifest
+++ b/app-admin/testdisk/Manifest
@@ -1,4 +1,6 @@
AUX testdisk-7.0-qtbindir.patch 958 BLAKE2B 0d3ba4622cc6a83fe6b1fe65dd51203e05c936b7fc169fa5c070a3e77e799eac4f87068a6a6bbe9a3d6fbe25a8c6afae3a5251a72137eb4fdd4afb966e724a9e SHA512 c17dd97e058633cc3ca1f51d371bcce9d702dc2ffbd80eaad2aa1830d17c604702b23e4fb4d1516ab888f55899817e132be535d723c6b7275686d9513c6d6e31
DIST testdisk-7.0.tar.bz2 676990 BLAKE2B deeeee290f05d4a992ff69c990cca8480c74e67ba2df0b523640833b968ed98dc9f44e5f33b2666daf07286dd8349b98171d6c65f7f3baae3d5cca159a5c9584 SHA512 b1ebe1d2fca453660a17623b70c06e0195cb5f07056fb7bc683d575c034fb71dfb793582c804dcff0ca57789a6de84bbf13b1a554353811660996e42199102e2
+DIST testdisk-7.1_pre20180322.tar.gz 632598 BLAKE2B 741610622c9afa2c41d14e8eb391cbe629a5f7ac102cf4cbf446b0c0d7330cb8482a17c1ce8470aa9d1b0578aac254cf17aa061e21dd831a803152514fab5422 SHA512 fbe699ccfbe31be636d71eda5d1fccb8efb16788bf664e048ee16344c3d3689961aaa7ef4c9123690db695bb7ae3439440bd775ab8b8455500232b2fc6048ebc
EBUILD testdisk-7.0-r3.ebuild 2495 BLAKE2B c697b2ec48c74b2ca7f5da94fd9a3c563ed587626cf1872f7a30ded729dd33f7c700da3142b8fd3513c1a6b17876893b9218dd44672f1f8b2b03fefeac73889c SHA512 0a3a0d78fc7437884e81b9842c0b1ac40c58c0eae43e27c1effa01c0e2ac350dab48ccd5316fac99c4468943d7ef05545341cdb74c3eb6f5b9a153eb9a23ce8f
+EBUILD testdisk-7.1_pre20180322.ebuild 2409 BLAKE2B 23c156df12e4419d37415f17331db822c276ce6d66a9cbdd18c935da09a2875b1ff1344ddfb902009f0603f55d12068a2a7d1148953332c78d1e9d8934931996 SHA512 18371a6576525d36a28b7eb9612dbc7db4f3641b4b955b7990167153bf33f99082239eb887c005d92ccb929635f7b167c9afa60affbc6f005704052e9234b19b
MISC metadata.xml 447 BLAKE2B da97d4af9961ab42d914dd33abbf433e5974ed49efb2ac2c4ff6cfdd50735bddc48b9b9e15d86a3701d740c73ef9df31439599fdd1cb6a37a306ddcf1cdafc73 SHA512 f6e65d544043790ff6b654dce7e4995214fde5f5c5f35926e396721cc223c97f06a918d7d345e9f4f51c82437af41887a0cb442eb0c7172f839df3249eb58095
diff --git a/app-admin/testdisk/testdisk-7.1_pre20180322.ebuild b/app-admin/testdisk/testdisk-7.1_pre20180322.ebuild
new file mode 100644
index 000000000000..4aa4e9621ca4
--- /dev/null
+++ b/app-admin/testdisk/testdisk-7.1_pre20180322.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMIT=9eb2aa12ce051d8d3d31e6b440389d5abf5efaf1
+inherit autotools flag-o-matic
+
+DESCRIPTION="Checks and undeletes partitions + PhotoRec, signature based recovery tool"
+HOMEPAGE="https://www.cgsecurity.org/wiki/TestDisk"
+SRC_URI="https://git.cgsecurity.org/cgit/${PN}/snapshot/${PN}-${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
+IUSE="ewf jpeg ntfs qt5 reiserfs static zlib"
+
+REQUIRED_USE="static? ( !qt5 )"
+
+# WARNING: reiserfs support does NOT work with reiserfsprogs
+# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
+COMMON_DEPEND="
+ static? (
+ sys-apps/util-linux[static-libs]
+ sys-fs/e2fsprogs[static-libs]
+ sys-libs/ncurses:0[static-libs]
+ jpeg? ( virtual/jpeg:0[static-libs] )
+ ntfs? ( sys-fs/ntfs3g[static-libs] )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8[static-libs] )
+ zlib? ( sys-libs/zlib[static-libs] )
+ !arm? ( ewf? ( app-forensics/libewf:=[static-libs] ) )
+ )
+ !static? (
+ sys-apps/util-linux
+ sys-fs/e2fsprogs
+ sys-libs/ncurses:0=
+ jpeg? ( virtual/jpeg:0 )
+ ntfs? ( sys-fs/ntfs3g )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
+ zlib? ( sys-libs/zlib )
+ !arm? ( ewf? ( app-forensics/libewf:= ) )
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ qt5? ( dev-qt/linguist-tools:5 )
+"
+RDEPEND="!static? ( ${COMMON_DEPEND} )"
+
+DOCS=( )
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-sudo
+ --without-ntfs
+ $(use_with ewf)
+ $(use_with jpeg)
+ $(use_with ntfs ntfs3g)
+ $(use_enable qt5 qt)
+ $(use_with reiserfs)
+ $(use_with zlib)
+ )
+
+ # this static method is the same used by upstream for their 'static' make
+ # target, but better, as it doesn't break.
+ use static && append-ldflags -static
+
+ econf "${myeconfargs[@]}"
+
+ # perform safety checks for NTFS, REISERFS and JPEG
+ if use ntfs && ! egrep -q '^#define HAVE_LIBNTFS(3G)? 1$' "${S}"/config.h ; then
+ die "Failed to find either NTFS or NTFS-3G library."
+ fi
+ if use reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
+ die "Failed to find reiserfs library."
+ fi
+ if use jpeg && egrep -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
+ die "Failed to find jpeg library."
+ fi
+}