summaryrefslogtreecommitdiff
path: root/app-admin/testdisk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-15 00:47:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-15 00:47:35 +0000
commit4614848cbaec61bd1083af01a41f39c3b4a9e274 (patch)
tree0f19b06aed0cab301d46e582b0bb595429feb525 /app-admin/testdisk
parent75fab9df40cc79f887fd43dd6614b5fa0e96ba8f (diff)
gentoo auto-resync : 15:03:2024 - 00:47:35
Diffstat (limited to 'app-admin/testdisk')
-rw-r--r--app-admin/testdisk/Manifest4
-rw-r--r--app-admin/testdisk/metadata.xml1
-rw-r--r--app-admin/testdisk/testdisk-7.2.ebuild104
3 files changed, 108 insertions, 1 deletions
diff --git a/app-admin/testdisk/Manifest b/app-admin/testdisk/Manifest
index 37039c221031..15b4e44b27cc 100644
--- a/app-admin/testdisk/Manifest
+++ b/app-admin/testdisk/Manifest
@@ -1,4 +1,6 @@
AUX testdisk-7.1-backport-ntfs-3g-ioctl-prototype.patch 1268 BLAKE2B 9c57329b3576cef7f23177fe07d45cd49a449b4353a9abd3a3196a9ec2896a05e900b1d7785d087f4587642d786efb36ea655d8b2c35833c8736014fbdad9cfb SHA512 7325ff2d83350512acf2e0b3f2269cdc4a92f775eafeae62c0b337fa4f31dac0c4f56d9ed7397fbd8a29d7679eb259401ca934d48c51438bfc4e3d0e0bcf7e00
DIST testdisk-7.1.tar.bz2 742006 BLAKE2B ad67cbef73e502df39cd04537bae9226d043a0f5ed824ed24d5a5ac7c3262060d0c78bfcf38159890ee0c270e1cd7690cbf276eb919e1b4721357fffc8679c61 SHA512 ad6531eec45c1ed8d4a0ce6132692bb609c4c269fbca57f788ce808214e0b00b5fb1187745a859c5da8a3cb8de18b29904792d3246b15cedfa24bf24cbfe3df5
+DIST testdisk-7.2.tar.bz2 855781 BLAKE2B 224fae052fa9264ee83fdf6804159c77257b9db4c96ff36c7cb1dc184ec4a9f0955f0d817de24ef1e5fe69e7ef1a20c140e73fc130fb092e6df3b02df2845239 SHA512 f99dd1c8f547c3d06e5459ba072438192a49d76c569de7915994beb269645092522d8136a212999382f88ca1d29c50f6482306d47197dc0994d168bcd4141f26
EBUILD testdisk-7.1-r2.ebuild 2493 BLAKE2B c356cecde0aca3b623792c28734b7692315bda99bd186f65eb620a17b4116c9314979e747932657086976caf38932746de8493aea44840e060ece38410e6f366 SHA512 abbbe19c071a2faf9075a483eea9625f074f680975a8ddf5e47e93e3080e8b4d5dd5f87ca0062cc9cddb25245ebefe8a939a94560d5cebcea33b8e3121ec2cac
-MISC metadata.xml 640 BLAKE2B 2c906cdb19a874657ac6f51ea5ec0035b27b0644e73faac95b9234a888a991bc8d9026252a0bf1bd32841295519fe2a966f77101396ca8071dd96c3f742bfd24 SHA512 8996a1f5afaaf7cf18f088d342b717d43316737e92c7b891c63613f9698e4b60bcdc6c65d3d87e4ce4da129b40993e3a60c75544dd5503e9d104d2652460b58c
+EBUILD testdisk-7.2.ebuild 2722 BLAKE2B 1a6bd0716daa06eaecac1552d9f968cfd8d4c156340c1b5251d25567d32da61c0d532ba688f0eb41c9a91161ad9038fdc8452421a6ffb2575b7c80d0abee3839 SHA512 7ac326be1d9d6d8ac261f578c602ba6a758c39fdb4aeab30359cf037d12474dbb3a8fc8706436e6610fcfe2fa8561b5602343da03f9624e91b5eaf26f0993925
+MISC metadata.xml 698 BLAKE2B c594b2322501214086fc8505094d104b1cba10338e8e2d1831eaa6e13fa12406b0e7e374dc0c4b72c93b7c10fb4709d39d8790274b5b38ff326d7ea99d42ec70 SHA512 bbd13b1109ddbcbd8c676886c432b8fe5ed276a93de6e829ab8d708c84b8ea50e9846a717b3d9a9b6c5d400971f8d79b049285a1bf999c81e50fb4d820ebc7e4
diff --git a/app-admin/testdisk/metadata.xml b/app-admin/testdisk/metadata.xml
index adbd9697dcd6..0cde64481bdc 100644
--- a/app-admin/testdisk/metadata.xml
+++ b/app-admin/testdisk/metadata.xml
@@ -13,6 +13,7 @@
<flag name="ntfs">Include the ability to read NTFS filesystems</flag>
<flag name="reiserfs">Include reiserfs reading ability</flag>
<flag name="ewf">Include ewf library</flag>
+ <flag name="sudo">Enable sudo helper integration</flag>
</use>
<upstream>
<remote-id type="github">cgsecurity/testdisk</remote-id>
diff --git a/app-admin/testdisk/testdisk-7.2.ebuild b/app-admin/testdisk/testdisk-7.2.ebuild
new file mode 100644
index 000000000000..e30e7c0a8b9f
--- /dev/null
+++ b/app-admin/testdisk/testdisk-7.2.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic qmake-utils xdg-utils
+
+DESCRIPTION="Checks and undeletes partitions + PhotoRec, signature based recovery tool"
+HOMEPAGE="https://www.cgsecurity.org/wiki/TestDisk"
+SRC_URI="https://www.cgsecurity.org/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+IUSE="ewf jpeg ntfs gui reiserfs static +sudo zlib"
+
+REQUIRED_USE="static? ( !gui )"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ 'ntfs_mbstoucs' # configure script checking NTFS, has fallbacks
+)
+
+# WARNING: reiserfs support does NOT work with reiserfsprogs
+# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
+# sudo is detected during configure for extra functionality, see bug #892904
+DEPEND="
+ sudo? ( app-admin/sudo )
+ static? (
+ sys-apps/util-linux[static-libs]
+ sys-fs/e2fsprogs[static-libs]
+ sys-libs/ncurses:0[static-libs]
+ jpeg? ( media-libs/libjpeg-turbo:=[static-libs] )
+ ntfs? ( sys-fs/ntfs3g[static-libs] )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8[static-libs] )
+ zlib? ( sys-libs/zlib[static-libs] )
+ !arm? ( ewf? ( app-forensics/libewf[static-libs] ) )
+ )
+ !static? (
+ sys-apps/util-linux
+ sys-fs/e2fsprogs
+ sys-libs/ncurses:0=
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ ntfs? ( sys-fs/ntfs3g:= )
+ gui? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
+ zlib? ( sys-libs/zlib )
+ !arm? ( ewf? ( app-forensics/libewf:= ) )
+ )
+"
+RDEPEND="
+ sudo? ( app-admin/sudo )
+ !static? ( ${DEPEND} )
+"
+BDEPEND="gui? ( dev-qt/linguist-tools:5 )"
+
+DOCS=()
+
+PATCHES=(
+)
+
+src_configure() {
+ export MOC="$(qt5_get_bindir)/moc"
+ export PATH="$(qt5_get_bindir):${PATH}"
+
+ local myconf=(
+ --without-ntfs # old NTFS implementation, use ntfs-3g instead.
+ $(use_with ewf)
+ $(use_with jpeg)
+ $(use_with ntfs ntfs3g)
+ $(use_enable gui qt)
+ $(use_enable sudo)
+ $(use_with reiserfs)
+ $(use_with zlib)
+ )
+
+ # this static method is the same used by upstream for their 'static' make
+ # target, but better, as it doesn't break.
+ use static && append-ldflags -static
+
+ econf "${myconf[@]}"
+
+ # perform safety checks for NTFS, REISERFS and JPEG
+ if use ntfs && ! grep -E -q '^#define HAVE_LIBNTFS(3G)? 1$' "${S}"/config.h ; then
+ die "Failed to find either NTFS or NTFS-3G library."
+ fi
+ if use reiserfs && grep -E -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
+ die "Failed to find reiserfs library."
+ fi
+ if use jpeg && grep -E -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
+ die "Failed to find jpeg library."
+ fi
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}