summaryrefslogtreecommitdiff
path: root/app-admin/terraform/terraform-0.12.17.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /app-admin/terraform/terraform-0.12.17.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'app-admin/terraform/terraform-0.12.17.ebuild')
-rw-r--r--app-admin/terraform/terraform-0.12.17.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/app-admin/terraform/terraform-0.12.17.ebuild b/app-admin/terraform/terraform-0.12.17.ebuild
deleted file mode 100644
index 16e496f4ef87..000000000000
--- a/app-admin/terraform/terraform-0.12.17.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit golang-base go-module
-
-DESCRIPTION="A tool for building, changing, and combining infrastructure safely"
-HOMEPAGE="https://www.terraform.io/"
-
-EGO_PN="github.com/hashicorp/${PN}"
-SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD-2 BSD-4 ECL-2.0 imagemagick ISC JSON MIT MIT-with-advertising MPL-2.0 unicode"
-SLOT="0"
-KEYWORDS="amd64"
-
-RESTRICT="test"
-
-DOCS=( {README,CHANGELOG}.md )
-
-src_prepare() {
- default
- # the sed command is necessary to generate tests outside of the
- # default git root of `terraform', in our case the working dir
- # is `work/$PN-$PV'
- # sed -i -e "s/!=\s\+\"terraform\"/!=\ \"${P}\"/" \
- # ./scripts/generate-plugins.go || die
-}
-
-src_compile() {
- GOCACHE="${T}/go-cache" go build \
- -work -o "bin/${PN}" ./ || die
-}
-
-src_install() {
- dobin bin/terraform
-
- einstalldocs
-}
-
-pkg_postinst() {
- elog "If you would like to install shell completions please run:"
- elog " terraform -install-autocomplete"
-}