summaryrefslogtreecommitdiff
path: root/app-admin/terraform/terraform-0.12.17.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /app-admin/terraform/terraform-0.12.17.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'app-admin/terraform/terraform-0.12.17.ebuild')
-rw-r--r--app-admin/terraform/terraform-0.12.17.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-admin/terraform/terraform-0.12.17.ebuild b/app-admin/terraform/terraform-0.12.17.ebuild
new file mode 100644
index 000000000000..6183146d4a09
--- /dev/null
+++ b/app-admin/terraform/terraform-0.12.17.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit golang-base go-module
+
+DESCRIPTION="A tool for building, changing, and combining infrastructure safely"
+HOMEPAGE="https://www.terraform.io/"
+
+EGO_PN="github.com/hashicorp/${PN}"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 BSD-4 ECL-2.0 imagemagick ISC JSON MIT MIT-with-advertising MPL-2.0 unicode"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="test"
+
+DOCS=( {README,CHANGELOG}.md )
+
+src_prepare() {
+ default
+ # the sed command is necessary to generate tests outside of the
+ # default git root of `terraform', in our case the working dir
+ # is `work/$PN-$PV'
+ # sed -i -e "s/!=\s\+\"terraform\"/!=\ \"${P}\"/" \
+ # ./scripts/generate-plugins.go || die
+}
+
+src_compile() {
+ GOCACHE="${T}/go-cache" go build \
+ -work -o "bin/${PN}" ./ || die
+}
+
+src_install() {
+ dobin bin/terraform
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "If you would like to install shell completions please run:"
+ elog " terraform -install-autocomplete"
+}