summaryrefslogtreecommitdiff
path: root/app-admin/terraform/terraform-0.12.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-20 19:28:42 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-20 19:28:42 +0000
commit032a3dbb5d4ea63ec6c2ceb39c067ea6424b5792 (patch)
treed46be9dbc767750a192f7a4d505757f2eec582f3 /app-admin/terraform/terraform-0.12.16.ebuild
parent6ec19c7f1bc4aa70e5f8a86cd29d579a95d97035 (diff)
gentoo resync : 20.01.2020
Diffstat (limited to 'app-admin/terraform/terraform-0.12.16.ebuild')
-rw-r--r--app-admin/terraform/terraform-0.12.16.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/app-admin/terraform/terraform-0.12.16.ebuild b/app-admin/terraform/terraform-0.12.16.ebuild
deleted file mode 100644
index 6183146d4a09..000000000000
--- a/app-admin/terraform/terraform-0.12.16.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit golang-base go-module
-
-DESCRIPTION="A tool for building, changing, and combining infrastructure safely"
-HOMEPAGE="https://www.terraform.io/"
-
-EGO_PN="github.com/hashicorp/${PN}"
-SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD-2 BSD-4 ECL-2.0 imagemagick ISC JSON MIT MIT-with-advertising MPL-2.0 unicode"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RESTRICT="test"
-
-DOCS=( {README,CHANGELOG}.md )
-
-src_prepare() {
- default
- # the sed command is necessary to generate tests outside of the
- # default git root of `terraform', in our case the working dir
- # is `work/$PN-$PV'
- # sed -i -e "s/!=\s\+\"terraform\"/!=\ \"${P}\"/" \
- # ./scripts/generate-plugins.go || die
-}
-
-src_compile() {
- GOCACHE="${T}/go-cache" go build \
- -work -o "bin/${PN}" ./ || die
-}
-
-src_install() {
- dobin bin/terraform
-
- einstalldocs
-}
-
-pkg_postinst() {
- elog "If you would like to install shell completions please run:"
- elog " terraform -install-autocomplete"
-}