summaryrefslogtreecommitdiff
path: root/app-admin/tenshi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-admin/tenshi
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-admin/tenshi')
-rw-r--r--app-admin/tenshi/Manifest1
-rw-r--r--app-admin/tenshi/tenshi-0.17-r1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-admin/tenshi/Manifest b/app-admin/tenshi/Manifest
index d7a0499d4727..ae99c44402f2 100644
--- a/app-admin/tenshi/Manifest
+++ b/app-admin/tenshi/Manifest
@@ -1,3 +1,4 @@
DIST tenshi-0.17.tar.gz 24597 BLAKE2B 846128e65b1a2d2a3bc5edecc9356069f44d9c13757771ec7fc5c31063d8aeb9403d447dbb088d2aa7d05d3b086ac6c569cd24a05c336225540b3baa10e79bb7 SHA512 2ca93ceaab0843c321fa69d8ba1c7b31eaf809cac4348c98327ddd9ab72df4d5ff00d6b4edeb19a9f02e154161988e0c2284248fd0e84d2b42dd82fdbaac1a78
+EBUILD tenshi-0.17-r1.ebuild 1057 BLAKE2B 39ffe39519bba697a6aa01bf2d332e2eae1298544c988f10477a84175c0df3e2e41c8de37c173832ff65b0c4b673db19b7dad6ee22eb0b1ca331e9d263e4f455 SHA512 23320285b9907b9bcd9b955d0cc1d5ca4ff33943a922be68531462ff4169b28c33a5f81e31eb1bfd6be7825b009cbf9f87ce7c9a62f01efc341a74b2fb2ebb67
EBUILD tenshi-0.17.ebuild 1234 BLAKE2B ab5758e25d205694a426227b1f48af53365c2e311ffb024dec529f9ba62c9c5cbade36cbaa618234b96e209fa447040a41e1476628123a7c2d9f93ac80a1fa23 SHA512 1e71cddc001b8ba53497a5d69c262e9435f90dc392cd31e3c121795f3b74b77ecd6da909c77d8a50ede7c7beb57ecd4a50558802bce510576dda5c0371b40f97
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-admin/tenshi/tenshi-0.17-r1.ebuild b/app-admin/tenshi/tenshi-0.17-r1.ebuild
new file mode 100644
index 000000000000..83d69e58809d
--- /dev/null
+++ b/app-admin/tenshi/tenshi-0.17-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Log parsing and notification program"
+HOMEPAGE="https://inversepath.com/tenshi.html https://github.com/inversepath/tenshi"
+SRC_URI="https://github.com/inversepath/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ acct-group/tenshi
+ acct-user/tenshi
+ dev-lang/perl
+ dev-perl/IO-BufferedSelect
+ sys-apps/coreutils
+"
+
+src_prepare() {
+ default
+
+ # Fix for bug #241254
+ sed 's:^docdir =.*:docdir = /usr/share/doc/${PF}:' -i Makefile || die "docdir substitution failed"
+}
+
+src_install() {
+ default
+
+ doman tenshi.8
+ keepdir /var/lib/tenshi
+ newinitd tenshi.openrc-init tenshi
+}
+
+pkg_postinst() {
+ ewarn "The sample config installed to ${ROOT}/etc/tenshi/tenshi.conf"
+ ewarn "monitors /var/log/messages which, by default, can not be read"
+ ewarn "by the tenshi user. Make sure that the tenshi user has read"
+ ewarn "permission on all the files that you want tenshi to monitor."
+}