summaryrefslogtreecommitdiff
path: root/app-admin/system-config-printer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-07 18:53:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-07 18:53:56 +0000
commitc577a55e80fbc5ba7f9f0124a354335a98e4bf4a (patch)
tree247ea00560bad9c5ae6e4706d41222629f40db0f /app-admin/system-config-printer
parent02814fd00146251691678aa18d9937665c677086 (diff)
gentoo auto-resync : 07:01:2024 - 18:53:56
Diffstat (limited to 'app-admin/system-config-printer')
-rw-r--r--app-admin/system-config-printer/Manifest1
-rw-r--r--app-admin/system-config-printer/system-config-printer-1.5.18-r2.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/app-admin/system-config-printer/Manifest b/app-admin/system-config-printer/Manifest
index 2d572d3ed964..e24a7d4d2a4a 100644
--- a/app-admin/system-config-printer/Manifest
+++ b/app-admin/system-config-printer/Manifest
@@ -1,4 +1,5 @@
AUX system-config-printer-1.5.18-fix-debugprint-exception.patch 866 BLAKE2B 00e4c099d6b4a713d925962bcf7f3a2fece0ed86bab860d4726364cb2605035f35e49f057493b539d282bd0cfed0d81b7ea63ea9e06c9613eb5bcc9150d7940b SHA512 3d050231a42776a1f1d802cf03d873e7e2efb265e508395ed4f54359090845095cd232e045a0f1bb95e26856455c019468263b23f3214857aa085cb2f5b2cd2d
DIST system-config-printer-1.5.18.tar.xz 1396808 BLAKE2B 910e853829ee876edc597a3103b5ab857b3b8c1cb87096f25213b1088e35d9f4d320dad61f55b530283a7650b07abe028a53b4e144b33b1b66c733cb2caa8011 SHA512 33dc9c52d92f4234e055fb10a99cadd58424dcdb62554797b44bdd5319f1c3662bd2fa33417ac3a3f5ec51216d64e81e1897f3e671eb49f6be34057d7c38f3f4
EBUILD system-config-printer-1.5.18-r1.ebuild 2155 BLAKE2B c7bea686d21f69d7bf4237a7bd55e74f1add00cc5faa566e8b63afdf601f61920f0073967a310ec49d02b183e4b4600aac664c62d3edea67ffa084851617083d SHA512 1a23e2639ab1670f42c422f7fbf745a66347feacc0dba48ace614a098adfe77074438e5c6d0abbbf33721c37b46f2baf78d2dbd65c235b0458d3cadd88408a05
+EBUILD system-config-printer-1.5.18-r2.ebuild 2110 BLAKE2B 3070ca97ab2f9dce61f2cf73ff9c18b69ac204e8621c512e0138d8b4e5df80228f3355013424feb296e605f490b103501eb7bd6b8df05a8a7bccb68dc440fdfd SHA512 df60220595171945a2deb72b312d94a32e9d1712ec19fc19161460626d8639573b2bf4d2fa303c7bb748266d82b4434651479b19aeb305c1bc72498f47350e8a
MISC metadata.xml 597 BLAKE2B 4691f7f385a864b26ed00b5d05310d45aa52d1cbcfb118ec4b1323df470a761162bb7c037cc8eec253f1dd5302d0036379044e83257ba6be43d878b28ebf11e6 SHA512 e4b52d3a4070116472e4fb617796a7cdaef0b3cfc825ccdc39392b5ba63afdedad4232a9eacf89c209a3202d95c2c0cadf17ae8d3698d2e2258310cebfa89744
diff --git a/app-admin/system-config-printer/system-config-printer-1.5.18-r2.ebuild b/app-admin/system-config-printer/system-config-printer-1.5.18-r2.ebuild
new file mode 100644
index 000000000000..6df5fa717fd3
--- /dev/null
+++ b/app-admin/system-config-printer/system-config-printer-1.5.18-r2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 systemd udev xdg
+
+DESCRIPTION="Graphical user interface for CUPS administration"
+HOMEPAGE="https://github.com/OpenPrinting/system-config-printer/"
+SRC_URI="
+ https://github.com/OpenPrinting/${PN}/releases/download/v${PV}/${P}.tar.xz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="keyring policykit"
+# Needs cups running, bug 284005
+RESTRICT="test"
+
+# Additional unhandled dependencies
+# gnome-extra/gnome-packagekit[${PYTHON_USEDEP}] with pygobject:2 ?
+# python samba client: smbc
+# selinux: needed for troubleshooting
+DEPEND="
+ dev-libs/glib:2
+ net-print/cups[dbus]
+ virtual/libusb:1
+ >=virtual/udev-172
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ >=app-text/xmlto-0.0.22
+ dev-perl/XML-Parser
+ dev-util/desktop-file-utils
+ >=sys-devel/gettext-0.20
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pycups[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ ')
+ keyring? ( app-crypt/libsecret[introspection] )
+ policykit? ( net-print/cups-pk-helper )
+"
+
+PATCHES=(
+ # git master (1.5.19)
+ "${FILESDIR}/${P}-fix-debugprint-exception.patch"
+)
+
+src_configure() {
+ local myeconfargs=(
+ --with-xmlto
+ --enable-nls
+ --with-desktop-vendor=Gentoo
+ --with-udev-rules
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake PYTHON=:
+ distutils-r1_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" PYTHON=: install
+ python_fix_shebang "${ED}"
+ distutils-r1_src_install
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}