summaryrefslogtreecommitdiff
path: root/app-admin/system-config-printer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /app-admin/system-config-printer
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'app-admin/system-config-printer')
-rw-r--r--app-admin/system-config-printer/Manifest3
-rw-r--r--app-admin/system-config-printer/system-config-printer-1.5.11.ebuild89
2 files changed, 92 insertions, 0 deletions
diff --git a/app-admin/system-config-printer/Manifest b/app-admin/system-config-printer/Manifest
index f6e7e3c5830a..cfbb277780e1 100644
--- a/app-admin/system-config-printer/Manifest
+++ b/app-admin/system-config-printer/Manifest
@@ -1,3 +1,6 @@
DIST system-config-printer-1.4.8.tar.xz 904068 BLAKE2B dfadfd7f2ef8c37a588d2a4755c977a07c16d3779cf30652ca1056986d5de073fa334a912e4a8e865e88b323888f88b83c5ef8b086e4afafd7bf284c1b597f3d SHA512 9f832f11e0e6bca32a29201b9f78d7a3ea35a46f7484548e5e71e6939fd51065e07325e12bdb1bc577ee606299cfef54759def6564923904a79f27b654ec5304
+DIST system-config-printer-1.5.11-patchset-01.tar.xz 6948 BLAKE2B effe29c51cbe74fc72566df65f10ab845c9dc1f40ca2966c40be87e19f98046f34311c24b7bc77f471b840e35b0c8eb7754a7c5464d50335c8ab2e2ed0e79afd SHA512 2501bda0e75ea51cc8e14df6b3746a0ea51618919ef35ace849efeded0cddc49e6e3793142d1cd128ce3ce62c21661d5fdb85b19718df07b87a20f5fc641885b
+DIST system-config-printer-1.5.11.tar.xz 949816 BLAKE2B 96b41d64e0aa3494b7fc7ed15ac926d833a046ba2880b36b6f5dd4e7508e2bc1fac4cb52c9940c13cec6e34cb8972fbc11fcd5a7df510296444ca08a23f4cb2b SHA512 cc0a6faec0022092e64de3d7ab28669039c93853c6931d26c264f0035486e09ad0af784833e88ee8e3dc1b6f5be9dcf84144a2a6464dfa9711172966fa6a22b4
EBUILD system-config-printer-1.4.8.ebuild 2305 BLAKE2B 594c35c24a8d0ed8c79ed6af9d73069022d3af1d8dd321898dd8b3a1773c38673e2ab26d4b4da065a03e5e54ae738f1d67bc9032a3933dbefc8c4889cae6ce23 SHA512 0e1d651a46c0cfec924aec183fdfbfe175e668d3e0c566838c72527d90a28ab194a92952cda5c9a46999b03487b7441cab4709521f2a5e1757b112d5ab09878f
+EBUILD system-config-printer-1.5.11.ebuild 2363 BLAKE2B 15afe46a1a6e953e99f227a09c086be95e852804381a915931afe2d622c081fa5d44c7316e6fe364474e0cb1abba82ddcef0ede6e7a18662303b452d93fa3d7e SHA512 612ba38005a37124927a04c8172ae90a519c78ef9aac0c778c4fde8b3fa3dc5d41d2e3a7deaf12a2c1c707ef12c1faabd589d987ef82d5f04bf3d59b4fcf301e
MISC metadata.xml 463 BLAKE2B 8cc3de37cb766555e89dca64b9be719c3b2885144f08e5a126084e5f8125ff085e9c51705216cd51fb3c66daa29016a790dd606de2b443a7e65f6677f4c46fa4 SHA512 8521e871b99b17ea2bb754dc9bf1b1a49bd32673acce3fe561ec087c5c4bacfbefbf904af1cf5a6ada369e936a0e06a7116074ef622f882e434da7afdee12533
diff --git a/app-admin/system-config-printer/system-config-printer-1.5.11.ebuild b/app-admin/system-config-printer/system-config-printer-1.5.11.ebuild
new file mode 100644
index 000000000000..0d78b3182a04
--- /dev/null
+++ b/app-admin/system-config-printer/system-config-printer-1.5.11.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_REQ_USE="xml"
+inherit gnome2 python-single-r1 systemd
+
+DESCRIPTION="Graphical user interface for CUPS administration"
+HOMEPAGE="https://github.com/zdohnal/system-config-printer"
+SRC_URI="https://github.com/zdohnal/${PN}/releases/download/${PV}/${P}.tar.xz
+ https://dev.gentoo.org/~asturm/distfiles/${P}-patchset-01.tar.xz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+SLOT="0"
+
+IUSE="doc gnome-keyring policykit"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Needs cups running, bug 284005
+RESTRICT="test"
+
+# Additional unhandled dependencies
+# gnome-extra/gnome-packagekit[${PYTHON_USEDEP}] with pygobject:2 ?
+# python samba client: smbc
+# selinux: needed for troubleshooting
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/glib:2
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pycups-1.9.60[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ net-print/cups[dbus]
+ virtual/libusb:1
+ >=virtual/udev-172
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-libs/pango[introspection]
+ gnome-keyring? ( app-crypt/libsecret[introspection] )
+ policykit? ( >=sys-auth/polkit-0.104-r1 )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=app-text/xmlto-0.0.22
+ dev-util/desktop-file-utils
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? ( dev-python/epydoc )
+"
+
+PATCHES=(
+ "${WORKDIR}"/${P}-auth-dialog.patch
+ "${WORKDIR}"/${P}-libsecret-optional-{1,2}.patch
+ "${WORKDIR}"/${P}-scp-dbus-service-{1,2}.patch
+ "${WORKDIR}"/${P}-typo.patch
+ "${WORKDIR}"/${P}-appdata.patch
+ "${WORKDIR}"/${P}-empty-LC_MESSAGES.patch
+ "${WORKDIR}"/${P}-fdopen-utf8.patch
+ "${WORKDIR}"/${P}-typeerror.patch
+ "${WORKDIR}"/${P}-debugprint-typo.patch
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-nls \
+ --with-desktop-vendor=Gentoo \
+ --with-udev-rules \
+ --with-systemdsystemunitdir=$(systemd_get_systemunitdir)
+}
+
+src_compile() {
+ gnome2_src_compile
+ use doc && emake html
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( html/. )
+ gnome2_src_install
+ python_fix_shebang "${ED}"
+}